Have one Warning couldn't open module nouveau in X.org

My Computer configuration

System:
  Host: qin-inspiron7559 Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.3 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Inspiron 7559 v: 1.3.0 
  serial: <root required> 
  Mobo: Dell model: 0H87XC v: A00 serial: <root required> UEFI: Dell 
  v: 1.3.0 date: 12/01/2018 
Battery:
  ID-1: BAT0 charge: 62.2 Wh condition: 62.2/74.0 Wh (84%) 
  model: SIMPLO Dell status: Full 
CPU:
  Topology: Quad Core model: Intel Core i5-6300HQ bits: 64 type: MCP 
  arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 18406 
  Speed: 800 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Dell driver: nvidia 
  v: 440.100 bus ID: 02:00.0 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.1.3 
  direct render: Yes 

If I use a command 'DRI_PRIME=1 glxinfo | grep "OpenGL renderer"':

libGL error: failed to create dri screen
libGL error: failed to load driver: nouveau

And X.org message:

	信息	[     6.084] (==) Matched nouveau as autoconfigured driver 3
	信息	[     6.085] (II) LoadModule: "nouveau"
	信息	[     6.085] (WW) Warning, couldn't open module nouveau
	信息	[     6.085] (EE) Failed to load module "nouveau" (module does not exist, 0)

What should I do to solve the problem? I want to use nvidia for play game.

So you want to run a specific game with the Nvidia GPU via Prime? Have you prefixed the command with prime-run?
So for example prime-run glxinfo | grep OpenGL.

Try the command prime-run gimp ,but use the command nvidia-smi check ,then after nvidia PID is not the processe.

I think it's probably because “nouveau” mode failed to start.

Could you post the output of mhwd -li && mhwd -l?
Nouveau is the kernel version of the proprietary Nvidia driver.
Also i think you would even need to run nvidia-smi prefixed with prime-run. Not absolutely sure though.

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

I run 'prime-run nvidia-smi' , and nvidia-smi is the same result.

I found a wiki about "nouveau" :slight_smile:Nouveau
but I don't understand.

There are 2 possible drivers for the Nvidia Card.. The open-source Kernel driver called nouveau and the closed source driver by Nvidia. What you are currently using is the closed source driver by Nvidia which should be appropriate for what you want to do.

That's what I was thinking, but the problem is that I can't start the program I want to run with the Nvidia driver right now.
English is not my native language, and I can't understand some documents. Could you please have a look at the wiki I found? Is my Noveaou not set up properly

What program do you want to run? Maybe that would be a better starting point, since you somehow got the notion it needed to be run on the nouveau driver.

I run GIMP And Steam with NVIDIA Driver,edit code can be displayed using the Inter set.Let me look at the driver question again , and thank you for answering my so much question.

To run a specific game with the Nvidia GPU you need to edit the launch options/commands in the options of the game in your library. Simply add prime-run %command% to it to have the game start using the Nvidia GPU.
image

Now I can't even start GPU drivers with this command prime-run gimp . First, I think run GIMP on NVIDIA drivers,then I will experiment with Steam. :upside_down_face:

what is the output if you try to run prime-run gimp?

Before you keep digging a deeper hole ..
Your initial outputs looked fine.
'Nouveau' is the open-source driver that you really dont want to use on your proprietary nvidia card unless you really have some specific reason to do so.
So its failing to load ... because it is being told not to because you dont want to use it.
You are using the proper nvidia instead .. well, when you load it that is .. because you have dual-gpu .. so intel is the default.

Output some edited images, but use the command nvidia-smi or prime-run nvidia-smiview not mounted to the GPU driver, I think this is a problem.

I think you are looking at this wrong.
Assuming you havent messed up your correctly installed drivers..

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

What do those 2 commands show? Copy here.

I am using "video-hybrid-intel-nvidia-440xx-prime " as MANJARO's graphics driver.
How do I get certain programs to run on a separate graphics card?I've tried "prime-run" ,but I
runnvidia-smi or prime-run nvidia-smi what the display does not hang on the PID.

If you refuse to follow directions I cant help you.
Enter the commands I posted above into your terminal and press enter.
Then copy the output here.

glxinfo | grep 'renderer string'

OpenGL renderer string: Mesa Intel(R) HD Graphics 530 (SKL GT2)

prime-run glxinfo | grep 'renderer string'

OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2

Is this running result correct?

Perfectly fine. Your switchable graphics are operating normally.
Anything you want to run on the nvidia card you preface with
prime-run

PS - the case of steam is particular. Do not launch steam itself with prime-run .. but rather edit the launch options of each game as @Takei showed above. Assuming no other options are present it should look like this exactly:

prime-run %command%

Forum kindly sponsored by