Having an issue with X forwarding

Hi! I've just installed Manjaro Linux with KDE Plasma on a Walmart Motile with a Ryzen 5 processor. I'm very happy with the experience so far and I love plasma. I'm not used to using pacman or yay and i feel uncomfortable compared to on ubuntu or debian based distros which I am familiar with. I am excited to learn, though.

I have been getting all the software that I need installed, but I've run into an issue with what I believe is x11 or x.Org. Here is the error:

[nicholas@nicholas-m142 bin]$ ssh -X nallbritton@silicon.indstate.edu
nallbritton@silicon.indstate.edu's password: 
Last login: Sat Jul 18 20:15:35 2020 from 10.46.128.23
Authorized uses only. All activity may be monitored and reported.
server does not have extension for "r rate" option
X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  102 (X_ChangeKeyboardControl)
  Serial number of failed request:  8
  Current serial number in output stream:  10
nallbritton@silicon~> Connection to silicon.indstate.edu closed.

I need x server up so that I can run programs like xmgrace and have them open a window on my computer. I have been googling for a while and I cannot find any solution.

here is my info:

System:    Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 
           info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: MOTILE product: M142 v: Standard serial: <filter> 
           Mobo: MOTILE model: PF4PU1F v: Standard serial: <filter> UEFI: American Megatrends v: N.1.06 date: 11/27/2019 
Battery:   ID-1: BAT0 charge: 38.3 Wh condition: 46.7/46.7 Wh (100%) volts: 12.9/11.4 model: standard type: Li-ion 
           serial: <filter> status: Charging 
Memory:    RAM: total: 5.81 GiB used: 2.18 GiB (37.5%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen+ rev: 1 
           L2 cache: 2048 KiB bogomips: 33551 
           Speed: 1224 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1226 2: 1235 3: 1278 4: 1242 5: 1223 
           6: 1242 7: 1250 8: 1222 
           Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 bpext clflush clflushopt clzero cmov 
           cmp_legacy constant_tsc cpb cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fpu 
           fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr 
           mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
           perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 rdrand rdseed rdtscp rep_good sep sev 
           sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext 
           tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: Tongfang Hongkong Limited driver: amdgpu v: kernel 
           bus ID: 03:00.0 chip ID: 1002:15d8 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.36.0 5.6.16-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Tongfang Hongkong Limited 
           driver: snd_hda_intel v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Tongfang Hongkong Limited driver: snd_hda_intel 
           v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Tongfang Hongkong Limited driver: r8169 
           v: kernel port: f000 bus ID: 01:00.0 chip ID: 10ec:8168 
           IF: enp1s0 state: down mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: f000 bus ID: 02:00.0 
           chip ID: 8086:24fb 
           IF: wlp2s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           IF-ID-1: cscotun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IP v4: <filter> scope: global broadcast: <filter> 
           IP v6: <filter> scope: link 
           IP v6: <filter> virtual: stable-privacy scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 11.72 GiB (4.9%) 
           ID-1: /dev/sda vendor: BIWIN model: SSD size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: 4A0 scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 224.77 GiB used: 11.72 GiB (5.2%) fs: ext4 dev: /dev/sda2 label: N/A 
           uuid: dac9682f-70d1-4aff-aeaa-36e78869734b 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A uuid: E451-0DF8 
           ID-3: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 label: N/A 
           uuid: bc3672af-5ece-46f0-bf69-2d56bfe6465c 
Unmounted: Message: No unmounted partitions found. 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 3-1:2 info: Chicony HD Webcam type: Video driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
           chip ID: 04f2:b68b serial: <filter> 
           Hub: 3-2:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 05e3:0608 
           Device-2: 3-2.2:4 info: Realtek RTS5129 Card Reader Controller type: <vendor specific> 
           driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 0bda:0129 
           serial: <filter> 
           Device-3: 3-2.4:5 info: Intel type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
           chip ID: 8087:0aa7 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 44.1 C mobo: N/A gpu: amdgpu temp: 44 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 249 Uptime: 1h 04m Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 running in: konsole 
           inxi: 3.0.37```
type or paste code here

Welcome to the forum! :beers:

You have to install the xhost-xorg package ─ it's in the repository but it's not installed by default ─ and then use it to give access to applications on the remote machine for connecting to your local X server, in the form of...

xhost nallbritton@silicon.indstate.edu

You can read the official man page by clicking here, albeit that it should also be available on your system once you've installed the xhost-xorg package.

You might consider asking your local technical support people for help. They know their systems and the software you're trying to run.

Ordinary X forwarding shouldn't require anything other than X, i.e. it works for me without:

image

(bloomin' slow over a WAN, though... x2go or xpra or something helps a lot...)

1 Like

I have sent an email to my professor asking about who I can contact, and if I find the issue I will post here. Still if anyone has any info that might help it would be greatly appreciated. It will probably take a few days to get the contact info for the administrators I need to talk to and if they can help me it will take them until Monday to replay at least. In the mean-time a critical part of my job I will not be able to do from this laptop which will make the time from now until I solve this issue with x forwarding really difficult.

I'm fairly new to both pacman and yay and manjaro in general. I've tried to install the xhost package and neither yay nor pacman could find it. And a google search for how to install it got no results.

OMG I love yay.
Just do 'yay package' to get a list of stuff related to 'package' then hit the number of your choice.

After a week, you'll understand why we prefer using yay to apt.

Try again, I got this:

~ >>> yay xhost
1 extra/xorg-xhost 1.0.8-2 (11.7 KiB 23.6 KiB) [xorg-apps xorg]
Server access control program for X
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==>

Thank you!

I have installed xhost and added the remote to the access control list, but still I cannot use x forwarding.

Did you try ssh -Y instead of -X ?

For Silicon, I assume it's this:

https://www.indstate.edu/cas/chem_phys/high-performance-computing-clusters

(although it doesn't appear to have any disks in the drive bays... :grin:)

If you normally use University-level support routes, then here:

https://www2.indstate.edu/oit/

That's the same thing, just people on the other server can snoop on your session. It's not a good option to use.

That's not our problem - that's their problem. You're subsidising your institution through the good-will of unpaid people.

If it's a "critical part of your job" then you should be using their remote-access service rather than your own laptop.

Also, why are you working over a weekend when they are not?

The package is called xhost-xorg. It's in the repo. :wink:

That's not our problem - that's their problem. You're subsidising your institution through the good-will of unpaid people.

I don't know what you mean by this. I'm just an undergrad who has a job in the department for research. I work whenever I have time off from my other job whereas the university employees often have weekends off.
I posted in the forums and not somewhere else because I just figured it was an issue with my laptop and not their servers. X forwarding has always worked before. And since you're wondering why I'm working from my own laptop: coronavirus. The university closed down and so I had to leave town and work from home. I really have no other way of doing it.

I did not have issues using mobaxterm on my old laptop or x forwarding on ubuntu/mint, and I just want to figure out how I can get x forwarding to work because I need it for my job and just in general it is an issue I am having with my laptop. I want it fixed.

I do have some new information though. I get a failure to save/load acpi_video1 on boot. I do not know if that is helpful to you, though.

All of that is covered by your local technical support people.

Just because you run Manjaro doesn't mean this forum is the appropriate place for asking for help with job-related issues - whether caused by Coronavirus or not. You don't seriously think that you're the only one hit by that, do you?

If, after investigation by your local technical support, there is an issue within Manjaro (e.g., a driver or kernel issue) then reporting it here is appropriate.

Asking us to provide you with technical support is not fair, and it's absolutely not fair to try to "guilt" us into helping you by calling it "critical" or "urgent" or whatever - it's your problem, not ours.

As far as the SSH log goes, the local system administrator will be able to look and tell you exactly why the server closed the connection. Anyone else will simply be guessing.

As it is, a very quick web search (https://www.startpage.com/do/dsearch?query=server+does+not+have+extension+for+"r+rate") leads to this:

https://wiki.archlinux.org/index.php/Xorg/Keyboard_configuration#Using_xset

Does any of that sound familiar?

Ok I thought this forum was for talking and asking about issues you have with manjaro as well as just discussing features and what not... Just because it is "job related" doesn't make it untouchable for other manjaro users. It boils down to an issue I am having with my manjaro install and the main use I run into the issue for is when I'm using my job.

My issue isn't caused by coronavirus by the way. I only mentioned it because you for whatever reason asked me why I am ssh-ing to university servers. I'm not acting like I'm the only one hit, and I can't comprehend how you would think that.

I appreciate the time you've spent and I appreciate the link. I do not know how xset would be a problem, though. I will continue to google while I wait on my professor to get back to me.

Otherwise, if you think that this thread isn't appropriate then just close it, I guess.

Yes indeed.

Your issue involves your local servers, which have administrators who can help solve your problem.

Please talk to them.

If it turns out to be something specific with Manjaro - and on the Manjaro end - then we can try and work out what's going on.

Yes that does work! I think that I will use that until I can figure out why X forwarding will not work. I do not know why this works but -X doesn't, though.

I saw on internet it solved the private resource denied issue for put off people..
After it seems -Y is less secure.. But I'm bout edit enough to investigate more about why it cause the issue or not.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by