HDMI monitor on KDE Plasma showing mouse but not windows

I have an external monitor connected via HDMI to a Lenovo Thinkpad P53 with Nvidia Quadro RTX300.

The display appears on the display settings, and I can see the mouse when moving it to the external display area. But windows do not appear in it. When I drag one from the laptop screen to the external monitor, I can see the pointer and even click and drag the window back to the laptop screen (blindly), but it never appears on the external monitor.

If I click on the "recognize" button, the name doesn't appear on the external monitor but it does on the laptop screen.

When I put the laptop screen over the external display in the layout, I can see the desktop background and the mouse mirrors the movements, but the windows don't show up in de display.

Is this a driver's issue?

There is a way to know more about that system. From terminal run:
inxi -Fxxxza --no-host
Share them here. Use ``` above and bellow that text for proper formatting.

thanks @bogdancovaciu.

This is the output for inxi:

System:    Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=0f617cdf-277e-425f-9555-0efa7c2d90e5 rw quiet 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20QNCTO1WW v: ThinkPad P53 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 20QNCTO1WW v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N2NET37W (1.22 ) 
           date: 04/28/2020 
Battery:   ID-1: BAT0 charge: 84.6 Wh condition: 91.0/90.0 Wh (101%) volts: 12.2/11.2 model: Celxpert 5B10W13902 
           type: Li-poly serial: <filter> status: Discharging cycles: 1 
CPU:       Topology: 6-Core model: Intel Core i7-9850H bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 9E (158) stepping: D (13) microcode: CA L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 801 6: 800 7: 800 
           8: 800 9: 799 10: 800 11: 801 12: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: tsx_async_abort mitigation: TSX disabled 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA TU106GLM [Quadro RTX 3000 Mobile / Max-Q] vendor: Lenovo driver: N/A bus ID: 01:00.0 
           chip ID: 10de:1f36 
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: intel alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:15bb 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 bus ID: 52:00.0 chip ID: 8086:2723 
           IF: wlp82s0 state: up mac: <filter> 
Drives:    Local Storage: total: 953.87 GiB used: 21.86 GiB (2.3%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBQNTY-1T00-1001 size: 953.87 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11130101 scheme: GPT 
Partition: ID-1: / raw size: 452.84 GiB size: 444.74 GiB (98.21%) used: 21.83 GiB (4.9%) fs: ext4 
           dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 58.0 C mobo: 50.0 C 
           Fan Speeds (RPM): cpu: 2093 
Info:      Processes: 300 Uptime: 2m Memory: 30.98 GiB used: 1.84 GiB (5.9%) Init: systemd v: 245 Compilers: 
           gcc: 10.1.0 alt: 8 Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37 

and here the output for mhwd:

 > Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI

Warning: No installed USB configs!

No driver for that dGPU, and the system seem to run trough the iGPU only.
I wonder if in your case this would apply

I have zero idea and knowledge about the Quadro RTX 3000 Mobile. Proceed with caution on this one and make sure you backup your system.

1 Like

If you're using the screen extended us normal, you don't gonna see panels on that screen, just right click and choose wallpaper, if you not maybe there's a problem. You just try the clone mode to see if it works fine

thanks @bogdancovaciu , that's an excellent guide, but unfortunately didn't work.
I've tried on Plasma KDE and XFCE with the same result, which is that now the external display is not even recognized, and -obviously- I cannot see the mouse anymore. Although I can switch between GPUs alright.

I guess I'll have to wait until this card is supported. Hopefully it won't take years. And I suppose that totally discards being able to use a cintiq with this machine on Linux.

On hybrid mode current drivers don't support multimonitors so that's a normal behaviour. Incoming 450xx drivers will have that feature. In full Intel and Nvidia mode, muliti-monitors should work. If Plasma's options won't work, try xrandr. It is possible you need to set it to a right frequency to unlock the blockage, after that usual settings should work. This was my problem in the past. Somehow the secondary monitor was locked with wrong frequency and then the resolution didn't work for it. xrandr is a powerful tool in command line so read about it.

Thanks @michaldybczak, I'll try that. It hadn't occurred to me to change the frequency. I've used xandr in i3wm before and worked great. I'll give it a go. I'll report back with the results.

I got it working, somwhat.

Before installing xrandr, optimus-manager got always back to Intel-only mode no matter what mode I selected.

After installing xrandr the external monitor doesn't work with Intel-only mode. It does with Nvidia-only. But if I have the HDMI cable plugged in when I switch to it I get stuck in the login dialog that keeps asking me for the password in a loop.

I managed to make it work setting Nvidia-only mode with the HDMI cable unplugged, then plugging it in when already logged in the session and then enabling the external monitor with

xrandr --output HDMI-0 --mode 1920x1200 --rate 60

Not the best and more efficient solution, but it works.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by