Help calamares wont run. After buildiso

hi guys, I just create the new custom manjaro spin for my project with Manjaro-KDE, after all, is working so far, but now I have problem with calamares when I create Buildiso buildiso -f -p myproject -b stable -k linux56
and run the iso my calamares still won't run.

when i run this

 /usr/bin/calamares_polkit %f

i got this error

QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
"Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"

when i check calamares $ calamares on terminal

i got this authentication
image
image

23:17:06 [2]: void Calamares::flavorAndSide(const YAML::Node&, const char*, Calamares::Branding::PanelFlavor&, Calamares::Branding::PanelSide&)
    WARNING:Branding setting for sidebar is missing, using "widget" "left" 
23:17:06 [2]: void Calamares::flavorAndSide(const YAML::Node&, const char*, Calamares::Branding::PanelFlavor&, Calamares::Branding::PanelSide&)
    WARNING:Branding setting for navigation is missing, using "widget" "bottom" 
23:17:06 [2]: Calamares::Branding::Branding(const QString&, QObject*)
    WARNING:Invalid or missing *slideshowAPI* in branding file. 
23:17:06 [2]: Calamares::Branding::Branding(const QString&, QObject*)
    WARNING:the branding component "/usr/share/calamares/branding/manjaro" does not ship translations. 
23:17:06 [0]: Icon theme "Surfn" not found.
23:17:06 [0]: Icon theme "Numix" not found.
23:17:06 [0]: Icon theme "Numix-Circle-Light" not found.
23:17:06 [0]: Icon theme "Numix-Circle" not found.
23:17:06 [2]: QString Calamares::_stylesheet(const QDir&)
    WARNING:The branding component "/usr/share/calamares/branding/manjaro" does not ship stylesheet.qss. 
23:17:06 [2]: virtual void PartitionViewStep::setConfigurationMap(const QVariantMap&)
    WARNING:Partition-module does not support *userSwapChoices* setting "file" 
23:17:06 [2]: virtual void PartitionViewStep::setConfigurationMap(const QVariantMap&)
    WARNING:Partition-module does not support *userSwapChoices* setting "reuse" 
23:17:06 [2]: virtual void MachineIdJob::setConfigurationMap(const QVariantMap&)
    WARNING:MachineId: configuration setting *symlink* is deprecated, use *dbus-symlink*. 
23:17:06 [2]: virtual void FinishedViewStep::setConfigurationMap(const QVariantMap&)
    WARNING:Configuring the finished module with deprecated restartNowEnabled settings 

note: I have already to reinstall and delete manjaro-tools cache, and try to build with another computer and still same result. maybe is the calamares problem or just my iso profile settings. ?

new: I have try with another default profile KDE and still the same result

you can see my iso-profiles in here
ISO-Profiles

thanks

posted before looking at the profile.conf. Not sure why its doing it.

i just unset livecd to my personal password

################# livecd #################

# unset defaults to given value
hostname="incubieos"

# unset defaults to given value
username="incubieos"

# unset defaults to given value
password="incubieos"

i have try with another profile like the default KDE and still got same error

I have built KDE before, but it was version 18.5. Here are the differences in my profile.

# unset defaults to given values
addgroups="lp,network,power,wheel,disk,optical,scanner,users"

yeah,
when 4 days ago when i just buildiso test there was no error in calamares

but right now theres problem.
its like problem with root user
is theres anything else ?

Nope, other than the username and password since I make Manjaro spins its manjaro. But its been some time since I built KDE, lots and lots of updates between 18.5 and 20.0.

Okay thanks for help bro, can i post this in technical issues? Or in newbie section?

I guess you can, I would post it in technical and not newbie.

I took a look at my latest Lxqt build that I just did today and its doing the same thing. calamares 3.2.23.2-1 appears to be broken. I downgraded to 3.2.23.1-1 and the problem went away. Not all the mirrors are synced on that version though. Another thing is that its the 19.0 installer, but its easy to change the version number in /etc/manjaro-tools/manjaro-tools.conf

Oh thanks i try that.

What problem do you have? Normally the newer version should fix stuff. Also use manjaro-tools-iso-git as the stable release is way outdated.

We will see on how we can fix it ...

The exact same problem that Maverick describes in the first post in this thread.
I will switch to the manjaro-tools-iso-git right after I rebuild the Lxqt release with calamares 3.2.23.1-1. My Lxqt spin was already released once and an update broke compton a few days later, I need to get iso's done asap.

Fixed the issue already. No need to hold back

1 Like

so this is a calamares issues ?
okay thanks bro...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by