Help, Have to Ctrl+Alt+F2 to start gdm

Hi, I'm using Manjaro Gnome.

After removing lightdm in flavor to gdm my computer is stuck to the command line.
But as soon as i hit CTRL+ALT+F2 gdm start and all is working ok.

What is this happening, and how can i restore the correct behavior ?

I've tried an "sudo systemctl enable gdm" but with no success.

To enable GDM in Manjaro enter the command:

sudo systemctl enable gdm.service -f

Have a look here:

I think this may help you, but before you do anything, first read this thread to make sure your problem is the same:

... so if you run into this same issue just downgrade to 'webkit2gtk-2.14.2-2-x86_64.pkg.tar.gz':

cd /var/cache/pacman/pkg
sudo pacman -U webkit2gtk-2.14.2-2-x86_64.pkg.tar.gz'


pacman -U /var/cache/pacman/pkg/webkit2gtk-2.14.2-2-x86_64.pkg.tar.gz


Yes @AIManja ! my problem was the same at first, black screen with pointer.
That's where without any clue I've incrimined LightDM and removed it for GDM.
I don't know for now if "sudo systemctl enable gdm.service -f" resolved my problem, reboot will have to wait the end of the week :wink:

Cheers and thank you

1 Like

Solved thanks

Forum kindly sponsored by