Help me find a solution to get my system or at least my data back

Well, isn't this so special!!!!!! i used pamac. it downloaded two files, the keyring stuff. all was fine.

so I went to click on octopi, did not load, and IN FACT, NO PROGRAMS WOULD LOAD. They start to load and that is it, NOTHING!!!! So I tried the old trick of reboothing. I could not even reboot. It stopped on the first three lines of the bootup.

I am the jerk for not backing up my work yet. BUT phil, I don't like that you were playing around. So now I am running on the DVD.

My question is: HOW CAN I GET ACCESS TO MY STUFF ON MY HARD DRIVE?

@philm

Okay, let's not panic. Phil and the team do this on a sunday, appreciate that a little...okay?
So, to business.
Boot the live DVD and mount your drive.
Got an external drive? Mount that too.
Copy to the external drive.
Dont panic, dont shout, dont forget: backups...
Melissa
PS - I personally do not like that remark...

2 Likes

First, why not following your own plan and wait longer?

You backed up your work, good, but better would be backing up whole disk or partition with clonezilla. If you would, you could easy now reverse back. Everyone knows at some point there can be some problems, it is your responsibility to make sure you are safe in any case.

This is rude and over the top. Too bad there is no 'ignore' button. Although I can start using mental ignore.

7 Likes

@Manjaro-Team could you please do something and find a working solution for the filesystem conflicts on update. manjaro-system seems to not work always or even destroys the system sometimes. Again it was impossible to "just update" and on the secound try pacman was unable to download anything because of missing certificates or something.

Again I'm re-installing manjaro right now :confused:
I don't think it's userfriendly to re-install manjaro with every """""stable""""" update.

:sweat:[quote="zoner, post:95, topic:20843"]
HOW CAN I GET ACCESS TO MY STUFF ON MY HARD DRIVE?
[/quote]

I can just fine find my files in /run/media/manjaro/home/miu/ on a livesystem

That behavior is unacceptable. You should apologize and ask for help in a polite manner. It is no shame, all of us may get over our heads sometimes.

3 Likes

i do not have an external drive. and i assume that i cannot copy to a dvd because i am running on the dvd, so what now

okay, got a server handy? I used to back up to a server over FTP...
I suppose the google drive is not an option...
How big is the bundle? Ever considered a USB stick? And...get an external drive, for the going prices...

nope. I apologize. but there does not appear to be a solution.

got a spare PC lying around?
Edit - can your PC boot of a USB stick?

no. there is no solution for me. so that is my punishment for complaining. whatever goes around comes around!

you are the only one who has tried to help me. thank you for that.

1 Like

the problem happened when I was on this site. they did an update to the new design. i saw it. when i clicked on my user icon, something weird happened. it would display any of my stuff. just log out and i did. and that is when this all happened. i never got around to starting the update.

a browser lock up. Happened to me recently with firefox many times. Other users reported that, too.

Your data will still be there, so just wait until you can get a free USB stick or an external hard drive and get the data from the live system.

Sorry that the update broke so badly! But just check how much Phil and other experts are working to get the new Mesa work with Nvidia and AMD driveres on Manjaro, 22 days, and that is just an example. [Xorg] MESA with libglvnd support

2 Likes

I live on a pension. little money because of a really bad divorce. so i am toast
That is why i was writing a big program using Qt. those files are backed up. so tomorrow, i will format c: and load this outdated version back in. Oh, the data is all there. I mounted the c drive. but even if i could back up the files, i will loose all of my bookmarks.

and yes firefox crashed.

Boot of a live dvd, mount the drive, email the stuff to your self using a web mail account - will only work for small stuff.

Next time use something like Dropbox and store your important files there.

@zoner: We had to push out the mesa-libgvnd update some day. We already tested a lot to avoid some issues happening. We also released new install medias with todays update included. However here is a way to fix your issue. Simple put your system was not fully updated and since the symlinks for libgl are removed no graphical application will work. That is logical and fixable.

First open a terminal with CTRL+ALT+F3. This will open tty3 for you. Log in with your root user or your normal user. With your normal user you have to add sudo before each cmd.

  • First update our keys with pacman -Sy archlinux-keyring manjaro-keyring
  • Then try to use our update script to fix issues or things missing with pacman -S manjaro-system
  • If you run a 64bit system, you may install also mesa for 32bit applications with pacman -S lib32-mesa
  • Then you may update to latest mhwd with pacman -S mhwd
  • That done a normal system update might finalize your update with pacman -Syu
  • Last step would be to reboot.

Hope this helps getting your system up and running again. Else, don't hesitate to post your issues if you still have some in more detail.

5 Likes

i will try those. have to write them down.

i never got to the update. firefox blew up when you updated the site. eugene-b called it a browser blowup. but i will try.

can i do this while on the dvd and use konsole or reboot

Can you get into a tty - press ctrl+alt+f2 or f3 etc, when your boot freezes. If you can do it there.

sorry, i have not done this in a very long time. once i log in will the tty3 or type that in after logging in

Forum kindly sponsored by