Help setting up GPU slot in foldingathome

I’ve been running folding at home since the quarantine and I’ve recently switched to Manjaro to get off of Windows 10 and because I believe it to be a good learning experience.

After a fair bit of time I was able to get foldingathome to run on the new Manjaro machine, however I can’t get the gpu slot to function. This is the error I get.

According to the system info OpenCL does not seem to be detected.

However, following the ArchWiki page on folding at home I installed everything that it told me to, the ocl-icd and the OpenCL package for the current Nvidia driver.

I’m a bit stumped. I tried to run foldingathome-Nvidia.service per the wiki but it brings back an exit error.

Anyone have any input on this?

Thank you.

1 Like

:+1: Welcome to Manjaro! :+1:

Please read this:

and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...


P.S. And please don't post pictures of text, copy-aste the text itself, as we cannot copy-paste from pics. :grin:

My appologies, I was posting from my phone. This is what I get when I try to enable foldingathome-nvidia.service per the Arch wiki.

[hansk@Hans-Gaming Desktop]$ sudo systemctl enable --now foldingathome-nvidia.service
Job for foldingathome-nvidia.service failed because the control process exited with error code.
See "systemctl status foldingathome-nvidia.service" and "journalctl -xe" for details.
[hansk@Hans-Gaming Desktop]$ systemctl status foldingathome-nvidia.service
● foldingathome-nvidia.service - Folding@home helper for NVIDIA GPUs`
 foldingathome-nvidia.service - Folding@home helper for NVIDIA GPUs
     Loaded: loaded (/usr/lib/systemd/system/foldingathome-nvidia.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sun 2020-04-26 05:57:26 EDT; 20s ago
    Process: 11190 ExecStart=/usr/bin/nvidia-modprobe (code=exited, status=0/SUCCESS)
    Process: 11191 ExecStart=/usr/bin/nvidia-modprobe -c 0 -u (code=exited, status=0/SUCCESS)
    Process: 11192 ExecStart=/usr/bin/clinfo (code=exited, status=203/EXEC)
   Main PID: 11192 (code=exited, status=203/EXEC)

Apr 26 05:57:26 Hans-Gaming systemd[1]: Starting Folding@home helper for NVIDIA GPUs...
Apr 26 05:57:26 Hans-Gaming systemd[11192]: foldingathome-nvidia.service: Failed to execute command: No such file or directory
Apr 26 05:57:26 Hans-Gaming systemd[11192]: foldingathome-nvidia.service: Failed at step EXEC spawning /usr/bin/clinfo: No such fi>
Apr 26 05:57:26 Hans-Gaming systemd[1]: foldingathome-nvidia.service: Main process exited, code=exited, status=203/EXEC
Apr 26 05:57:26 Hans-Gaming systemd[1]: foldingathome-nvidia.service: Failed with result 'exit-code'.
Apr 26 05:57:26 Hans-Gaming systemd[1]: Failed to start Folding@home helper for NVIDIA GPUs.

The minimum we need is:

inxi --full --verbosity=7 --filter

The output to the following will help too:

[hansk@Hans-Gaming Desktop]$ inxi --full --verbosity=7 --filter
  Host: Hans-Gaming Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: MSI model: Z270 GAMING M5 (MS-7A78) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.A0 date: 07/03/2018 
  RAM: total: 15.60 GiB used: 1.71 GiB (10.9%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Topology: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 8192 KiB bogomips: 67224 
  Speed: 4400 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4400 2: 4400 
  3: 4400 4: 4400 5: 4400 6: 4400 7: 4400 8: 4400 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
  flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm 
  lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] vendor: 
  driver: nvidia v: 440.82 bus ID: 01:00.0 chip ID: 10de:17c8 
  Display: x11 server: X.Org 1.20.8 driver: nvidia tty: N/A 
  OpenGL: renderer: GeForce GTX 980 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  direct render: Yes 
  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA GM200 High Definition Audio vendor: 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb0 
  Sound Server: ALSA v: k5.6.7-1-MANJARO 
  Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet 
  vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus ID: 04:00.0 
  chip ID: 1969:e0b1 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 1.26 TiB used: 11.14 GiB (0.9%) 
  ID-1: /dev/nvme0n1 vendor: HP model: SSD EX900 250GB size: 232.89 GiB 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: S0614B0 scheme: GPT 
  ID-2: /dev/sda vendor: Toshiba model: THNSNK128GVN8 M.2 2280 128GB 
  size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> rev: 4101 scheme: GPT 
  ID-3: /dev/sdb vendor: Hitachi model: HDS721010CLA332 size: 931.51 GiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A3MA scheme: MBR 
  ID-4: /dev/sdc type: USB model: Mass Storage Device size: 7.52 GiB 
  serial: <filter> rev: 1.00 scheme: MBR 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / size: 227.94 GiB used: 11.14 GiB (4.9%) fs: ext4 
  dev: /dev/nvme0n1p2 label: N/A uuid: 753fdada-06b6-477f-8ff0-2b391ce432cb 
  ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 label: N/A uuid: 898F-189A 
  ID-3: /mnt/GameShare size: 3.05 TiB used: 347.16 GiB (11.1%) fs: nfs4 
  remote: label: N/A uuid: N/A 
  ID-1: /dev/sda1 size: 16.0 MiB fs: <root required> label: N/A uuid: N/A 
  ID-2: /dev/sda2 size: 119.23 GiB fs: ntfs label: N/A 
  uuid: 80B2416EB2416A2C 
  ID-3: /dev/sdb1 size: 931.51 GiB fs: ntfs label: Storage 
  uuid: D480BE7980BE6222 
  ID-4: /dev/sdc1 size: 7.51 GiB fs: vfat label: N/A uuid: 6E30-1ED8 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-9:5 info: Super Top microSD card reader (SY-T18) 
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.0 
  speed: 480 Mb/s chip ID: 14cd:1212 serial: <filter> 
  Device-2: 1-11:2 info: Microdia USB DEVICE type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0c45:652f 
  Device-3: 1-12:3 info: Logitech M-U0007 [Corded Mouse M500] type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 046d:c069 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 60.0 C mobo: 27.8 C gpu: nvidia temp: 27 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 22% 
  Processes: 238 Uptime: 4h 18m Init: systemd v: 244 Compilers: gcc: 9.3.0 
  clang: 10.0.0 Shell: bash v: 5.0.16 running in: xfce4-terminal 
  inxi: 3.0.37

Might not have done this one correctly.

[hansk@Hans-Gaming Desktop]$ /usr/bin/clinfo
bash: /usr/bin/clinfo: No such file or directory

Well, that is the issue: You must've forgotten to install something because that's the error you're getting:

Ask on the Folding@Home support page what this means (I haven't run @home software in the last few years!)


Thank you very much, sir!

1 Like

I use GPU for F@H. I have the NVidia proprietary driver 440xx installed. Works great.

The three CL packages I downloaded and installed were: ocl-icd, opencl-headers, and opencl-nvidia-440xx

I also downloaded and installed the package: cuda

The only service I need to enable and run F@H is: foldingathome.service
I do have foldingathome-nvidia.service installed but it always seems to be dead, and does not have any effect.

So I figured it out! After reinstalling everything several times with no effect I finally went into preferences to mess with the slot settings. Changed the OpenCL-index from -1 to 0 and now it works great!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by