Help with setting up Ibus for Korean

Hi guys. New user her using Manjaro KDE.

I originally posted on r/linux4noobs but it didn't get any solutions so I'm posting here once again.

I've been trying to get Linux to type in both English and Korean and according to this article, I can use Ibus to do just that. I installed Ibus-Hangul and the necessary fonts I want to use. Then I made a .xprofile text file in my home directory and inputted.

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus 
export QT_IM_MODULE=ibus 
export OOO_FORCE_DESKTOP="gnome"
ibus-daemon -drx

Now, when I open Ibus Preferences this screen pops up

Post image

The thing is that this screen keeps popping up even after multiple restarts of Ibus settings and the system. As a result, I haven't been able to get it to work.

I would follow the directions written here but I have no idea what they mean and how to go about it.

If anyone knows the know-how to fix my problem a comment would be appreciated. Thanks

Edit: So, I found the bashhrc file and I wrote the three lines. This is what it currently looks like.

#
# ~/.bashrc
#

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

[[ $- != *i* ]] && return

colors() {
	local fgc bgc vals seq0

	printf "Color escapes are %s\n" '\e[${value};...;${value}m'
	printf "Values 30..37 are \e[33mforeground colors\e[m\n"
	printf "Values 40..47 are \e[43mbackground colors\e[m\n"
	printf "Value  1 gives a  \e[1mbold-faced look\e[m\n\n"

	# foreground colors
	for fgc in {30..37}; do
		# background colors
		for bgc in {40..47}; do
			fgc=${fgc#37} # white
			bgc=${bgc#40} # black

			vals="${fgc:+$fgc;}${bgc}"
			vals=${vals%%;}

			seq0="${vals:+\e[${vals}m}"
			printf "  %-9s" "${seq0:-(default)}"
			printf " ${seq0}TEXT\e[m"
			printf " \e[${vals:+${vals+$vals;}}1mBOLD\e[m"
		done
		echo; echo
	done
}

[ -r /usr/share/bash-completion/bash_completion ] && . /usr/share/bash-completion/bash_completion

# Change the window title of X terminals
case ${TERM} in
	xterm*|rxvt*|Eterm*|aterm|kterm|gnome*|interix|konsole*)
		PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/\~}\007"'
		;;
	screen*)
		PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/\~}\033\\"'
		;;
esac

use_color=true

# Set colorful PS1 only on colorful terminals.
# dircolors --print-database uses its own built-in database
# instead of using /etc/DIR_COLORS.  Try to use the external file
# first to take advantage of user additions.  Use internal bash
# globbing instead of external grep binary.
safe_term=${TERM//[^[:alnum:]]/?}   # sanitize TERM
match_lhs=""
[[ -f ~/.dir_colors   ]] && match_lhs="${match_lhs}$(<~/.dir_colors)"
[[ -f /etc/DIR_COLORS ]] && match_lhs="${match_lhs}$(</etc/DIR_COLORS)"
[[ -z ${match_lhs}    ]] \
	&& type -P dircolors >/dev/null \
	&& match_lhs=$(dircolors --print-database)
[[ 
```\n'${match_lhs} == *
```\n'"TERM "${safe_term}* ]] && use_color=true

if ${use_color} ; then
	# Enable colors for ls, etc.  Prefer ~/.dir_colors #64489
	if type -P dircolors >/dev/null ; then
		if [[ -f ~/.dir_colors ]] ; then
			eval $(dircolors -b ~/.dir_colors)
		elif [[ -f /etc/DIR_COLORS ]] ; then
			eval $(dircolors -b /etc/DIR_COLORS)
		fi
	fi

	if [[ ${EUID} == 0 ]] ; then
		PS1='\[\033[01;31m\][\h\[\033[01;36m\] \W\[\033[01;31m\]]\$\[\033[00m\] '
	else
		PS1='\[\033[01;32m\][\u@\h\[\033[01;37m\] \W\[\033[01;32m\]]\$\[\033[00m\] '
	fi

	alias ls='ls --color=auto'
	alias grep='grep --colour=auto'
	alias egrep='egrep --colour=auto'
	alias fgrep='fgrep --colour=auto'
else
	if [[ ${EUID} == 0 ]] ; then
		# show root@ when we don't have colors
		PS1='\u@\h \W \$ '
	else
		PS1='\u@\h \w \$ '
	fi
fi

unset use_color safe_term match_lhs sh

alias cp="cp -i"                          # confirm before overwriting something
alias df='df -h'                          # human-readable sizes
alias free='free -m'                      # show sizes in MB
alias np='nano -w PKGBUILD'
alias more=less

xhost +local:root > /dev/null 2>&1

complete -cf sudo

# Bash won't get SIGWINCH if another process is in the foreground.
# Enable checkwinsize so that bash will check the terminal size when
# it regains control.  #65623
# http://cnswww.cns.cwru.edu/~chet/bash/FAQ (E11)
shopt -s checkwinsize

shopt -s expand_aliases

# export QT_SELECT=4

# Enable history appending instead of overwriting.  #139609
shopt -s histappend

#
# # ex - archive extractor
# # usage: ex <file>
ex ()
{
  if [ -f $1 ] ; then
    case $1 in
      *.tar.bz2)   tar xjf $1   ;;
      *.tar.gz)    tar xzf $1   ;;
      *.bz2)       bunzip2 $1   ;;
      *.rar)       unrar x $1     ;;
      *.gz)        gunzip $1    ;;
      *.tar)       tar xf $1    ;;
      *.tbz2)      tar xjf $1   ;;
      *.tgz)       tar xzf $1   ;;
      *.zip)       unzip $1     ;;
      *.Z)         uncompress $1;;
      *.7z)        7z x $1      ;;
      *)           echo "'$1' cannot be extracted via ex()" ;;
    esac
  else
    echo "'$1' is not a valid file"
  fi
}

Also, launching Ibus-setup from the console outputs

(ibus-setup:2494): Gtk-WARNING **: 12:47:17.083: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(ibus-setup:2494): Gtk-WARNING **: 12:47:17.083: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(ibus-setup:2494): Gtk-WARNING **: 12:47:17.083: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version

and the a window pops up saying

ibus daemon is not running. Do you wish to start it?

Selecting Yes prompts the

Ibus has been started! If you cannot use ibus then add the following lines.....

Popup to open while no closes the program.
This occurs every time I launch ibus-setup and rebooting doesn't seem to do anything as well.

Any solutions? I'm quite lost here. If I can't get this to work soon I might have to switch back to windows so...

1 Like

Please see this:

1 Like

Yes, I've tried both SCIM and Fcitx but no results. Tried asking some korean Linux users and they recommended I use Ibus instead. Also, I'm the one that asked that question in the first place.

1 Like

Right, you marked my comment as solution on the other treat, meaning you solved the issue, so now because you put

in your .bashrc i pointed you again to the previous posts that mentioned to place them in .xprofile
then the second link had another comment how to deal with IBUS

1 Like

oh...Ohhhhhh.. thanks. Sorry for the back and forth, I was getting confused here haha.

So, following these steps, I no longer get the daemon is not running window to popup, so I guess Ibus is now working fine.

One last question though,

Go to Input Method -> Add Korean -> select Hangul, lastly from IBus tray icon select Korean
Hope that will help!

I can't seem to be able to find the Ibus tray icon. I'm using a custom panel at the top of the screen so I guess that's why it's not appearing. Is there a way to add it as a widget?

See here:
https://wiki.archlinux.org/index.php/IBus#KDE

1 Like

OMG Thank you my man. I can finally type in Korean.
한국어로 이제 타이핑 할 수 있어요.
I can't thank you enough!!!!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by