HFS+ is already mounted, read and write, but I am unable of creating, copying and pasting

, ,

Hello,

My external HD of 1TB for backup is HFS+, whose it belongs to /dev/sdb1

  • I installed hfsprogs
  • I ran:
sudo mkdir /media
sudo mkdir/media/HFS+
sudo umount /dev/sdb1
sudo mount -t hfsplus -o force,auto,user,rw /dev/sdb1 /media/HFS+

Then I ran sudo krusader so I can create, copy, delete and move. But Krusader warned me Could not write.... I trid to solve all the ways, but nothing worked.

I also tried sudo fsck.hfsplus -f /dev/sdb1. But it refused to repair after 3 attempts. Including https://wiki.archlinux.org/index.php/Mac#HFS_partition_sharing.

Here is the details of my external HDD:

Disk /dev/sdb: 931.5 GiB, 1000203803648 bytes, 1953523054 sectors
Disk model: Expansion Desk  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 33553920 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start        End    Sectors   Size Id Type
/dev/sdb1           2 1953523053 1953523052 931.5G af HFS / HFS+

try with:
sudo mount -t hfsplus -o remount,force,rw /dev/sdb1 /media/HFS+

personally i prefer to first mount the partition with the File Manager, and that will mount in /run/media/myname/Label
then i run:
sudo mount -t hfsplus -o remount,force,rw /dev/sdb1 /run/media/myname/Label
I make use of alias in .bashrc so is easier ...

1 Like

I have just run this command, but I also received a warning from Krusader that I could not write.

It needs to be unmounted then mounted as default with no rw, then run that command.
Dolphin works perfectly here. Don't know about other File Managers in KDE.

I ran like:

sudo umount /dev/sdb1
sudo sudo mount -t hfsplus -o force /dev/sdb1 /media/HFS+
sudo mount -t hfsplus -o remount,force,rw /dev/sdb1 /media/HFS+

Then I ran Krusader as sudo and still received the same warning.

Once i was stubborn too ... then i changed :slight_smile:

1 Like

I am not sure, but I don't like this name.. Have you tried another name (I mean without +)?

2 Likes

Yes, I tried with ~/GusHFS. But Krusader did not allow me to create, delete, move, copy and paste yet. But I checked the following questions:

I believe it be size limit and journaling. I am on macOS and have just disabled journaling. When I am ready with MacPorts and Paragon extFS, I will return to Manjaro for testing.

Hi @bogdancovaciu and @AgentS.

Now it worked after disabling journaling.

Mulţumesc mult and ευχαριστώ πολύ for your patience!

2 Likes

Hello,

I have mount my disk hfs+. But in every restart i have to mount it again. Is there a solution on that?
I have used this command: sudo sudo mount -t hfsplus -o force /dev/sdc2 /run/media/sss/4tbb

Thank you in advance
Stefanos

Geía @stefgrifon,

You need to add your HFS+ disk to /etc/fstab:

# <file system>             <mount point>           <type>    <options>  <dump>  <pass>
UUID=(HFS+'s UUID)          /run/media/sss/4tbb     hfsplus   force,rw    0       1

Remember to update the grub.

1 Like

Info:
hfs: write access to a journaled filesystem is not supported, use the force option at your own risk, mounting read-only.

Thank you! This works
Thank you all

1 Like

You are welcome/Παρακαλώ!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by