Hi guys, please help me with this small bug

Edit: Solved. I reinstall the whole system, recustomizing everything + SAVED with Timeshift and with my google drive account on the BackUp program.
Just y.all take care on that Rambox program. :wink:

Hello guys ! I just finished installing my Manjaro Linux after SEVERAL mistakes i did . I never had a laptop before and i hate windows because it reminds me of highschool pcs.

I chose GnomeManjaro because i really love the gnome feel over the kda one.
i have a mediocre laptop too so ubuntu & windows were outta question for me.
My system had no problem in running the Manjaro Gnome and i finally succed to install it correctly after messing up (and finally giving up) trying manual partitioning from yt tutorials.

Screenshot_20200620-015457

I started to customizing my desktop BUT LIKE A NOOB i forgot to make a back-up in he timeshift program AND i forgot to make one in the backup apps as well !

This was my final desktop result i stayed like 5 hours to make it like this

IMG_20200620_015601 IMG_20200620_015707

But i LISTENED AGAIN to this guy ( https://youtu.be/a5cvg9XKEL8 ) even though i TOLD MYSELF I WILL NOT listen ever to random guys online ! And i install the cursed << rambox >> i found on the Pamac store.

Sadly i do not remember if it was a snap or an official repository but after the install was finished i open it up to set up my apps. It was so confusing to use that app i gaved up and tried to close it.

IT DID NOT WANT TO CLOSE !!!! NO MATTER how many times i tried.

I knew on that moment i should've done some " pkill " in terminal or smth but i got scared for some reason to mess up with that and instead i went back to Pamac and press remove on the Rambox program. Of course it couldn't remove it cuz it was still active lol.

So i got really scared and fkin shut down the whole laptop. i waited a couple sec and reboot it .

It seemed like Rambox was gone and the laptop was fine.
I did another 3 reboots just to be sure and then j went into Pacman -> installed section.

THE PAMAC LOADED FOR A 1 SEC AND CLOSED.

I got scared.
i releated the process and it .ll end up the same.

I tried searching for Rambox instead. After pressing enter on the search button the Pamac shut down again .

My system works. I can search download /apps / my other programs work as well. But Pamac has this bug where i cannot search for Rambox or open << install >> section. Also i do not find Rambox in my system.

I must say i also installed Octopi just to reinstall Pacman.

after i did that, i opened Pamac but the install bug was still there ! The pacman shut down after i pressed install section.

I closed Pamac and tried to remove it from the octopi manager.
It did not let me do it.

I dont know what to do.
Or how to search !
Please help im so tired of doing mistakes and reading PAGES of info to fix em

Suggestion... just start over fresh.

2 Likes

"pacman, ... pacman , ... pacman ...." but when i read you it's not a error with pacman but pamac
So you have pacman (in console) and can make all you want :wink: (install pamac-gtk or yay or ...)
ps: Rambox is in aur :wink:


not clear your "bug"/long message/title : only not found an aur package ?

2 Likes

Whoa, Faye you need to slow down. You're getting all freaked out and doing silly stuff out of fear. If you're only 5 hours into your install it's very easy to start over fresh.

As others have mentioned alrearedy, this is not a bug with Pacman. The program you have been using is the GUI installer Pamac. It is also likely not a bug with Pamac either. You may have created this yourself with your hard power down.

A hard power down is only to be used as an abolute last resort because of the negative side effects it can create. You never do that unless your system is completely frozen and totally unresponsive.

As you haven't put much time into your install, you may simply want a do over and then install timeshift straight away after the reinstall. I'm sure you could probably fix the mess you created if you were a little more experienced, but with your state of newbness perhaps the reinstall might just be less painful.

Good luck.

3 Likes

Try to run pamac-manager from the terminal. Not pacman, but pamac. Then do what you normally do to crash it, and keep an eye out for any messages it prints in the terminal.

Yeah, I'm getting more and more convinced that pamac needs renaming: hardly a day passes without a neophyte confusing the two.

Since you've already tired to fix your problem so many times, with each "fix" messing something up, it might be wise to listen to the advice given above and just reinstall. Clean slate to begin with. You've only lost 5 hours, and the second time it's going to take you less than that to go back to where you were.

You learnt a valuable lesson for the next time: get timeshift working right after the install.

Your approach to fixing things by trying random stuff probably caused even more issues, but it's actually a decent way to learn. The purpose of timeshift is to give you the confidence to try out stupid things (like installing random apps), without too much risk of breaking your system. However, always keep your important files backed up on an external drive.

Welcome to Manjaro! :slight_smile:

2 Likes

yeah... :c thank you ! As i said, this is my first laptop ever so thats why i kinda freak out

1 Like

yeah, Pamac* im so sorry , i corected it :sweat_smile::sweat_smile::sweat_smile::sweat_smile:
yeah.. i guess i.ll start again :woman_facepalming:

yeah, it was Pamac * i was very tired when i wrote this topic..

No biggie, everyone blows up their first install pretty quickly. That's how you learn the ropes (so to speak).

Welcome to Manjaro.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by