hi im noobie need help with GPU driver

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI
video-nvidia-440xx            2019.10.25               false            PCI

Warning: No installed USB configs!

is there any way i can make it TRUE so i can play in need for speed underground 2 ?? on linux coz that windows its anoying to me upgrade i dont know whats the problem in windows :kiluminati: makes this i like you guys i tried install nvidia drivers but i got some wierd gpu its hmm nvidia gtx 960 GPU chipset but in version windforce of Gigabyte i realy would like to do this im getting mad about this and to dont takes time somtimes when im using wine I get my programs stop insted of using virtualDJ i started to use MIXXX but problem still there when im try to use 'Gemini First mix' cannot do my favor thing like wa..wa...aw..wa.. you know i use to use illegal windows but the become annoying to older hardware so i was think that linux can help to keep up in those times that humans kicking stuff out insted fix and still use, i like music more so if anyone can help me out welcome then otherwise got ps4 :slight_smile: but i cannot make music on there on my laptop win10 'gemini first mix' not work there maybe if you know how to get scrach button in 'numark total control' i dont know my english its not to good well not grammar
;0 hope for 'indugelence' as google tlanslate tells me :slight_smile: hope for quick help

Hi there, welcome to the community!

The column FREEDRIVER in the table above means whether the display driver is a free (as in freedom, not price) and open source implementation. So answering your question, video-nvidia-440xx is a proprietary (meaning not open source) driver, so it's expected to have the value false in that column.

This does not tell you what driver you're currently using; to find that out, run glxinfo | grep OpenGL in your terminal, and if it says OpenGL vendor string: NVIDIA Corporation, that means that you're using the Nvidia drivers.

Also, since you're new here, you should take a moment reading the post below in order for us to assist you better in the future:

1 Like

ok im new in to linux my friend told me i should start to use it :stuck_out_tongue: all i know its copy /paste
stuff I know im using manjaro so lots of commends of internet not work some of them are i have install drivers few times all time its say its false i rely new into it :confused: but ill try this :100:

bash: run: command not found
that what i get :-= hmm i guess its bad command or i type it wrong or in wrong place
im rl in to Linux but i guess i should try diffrent one im on manjaro jaguar i guess

I totally understand that you're new to Linux. When your terminal says "Command not found," it means that you entered a bad command. Type the following line (from beginning to end) into the terminal:

glxinfo | grep

And it should give you an output below that command. What do you see?

1 Like

Usage: grep [OPTION]... PATTERNS [FILE]...
Try 'grep --help' for more information.

thing is i dont know how to do basic commands some other forums say about APT others use # insted $ so im lost in this totally

I edited my post above in an attempt to clarify what you type into the terminal. Can you try again please?

1 Like

Pattern selection and interpretation:
-E, --extended-regexp PATTERNS are extended regular expressions
-F, --fixed-strings PATTERNS are strings
-G, --basic-regexp PATTERNS are basic regular expressions
-P, --perl-regexp PATTERNS are Perl regular expressions
-e, --regexp=PATTERNS use PATTERNS for matching
-f, --file=FILE take PATTERNS from FILE
-i, --ignore-case ignore case distinctions in patterns and data
--no-ignore-case do not ignore case distinctions (default)
-w, --word-regexp match only whole words
-x, --line-regexp match only whole lines
-z, --null-data a data line ends in 0 byte, not newline

-s, --no-messages suppress error messages
-v, --invert-match select non-matching lines
-V, --version display version information and exit
--help display this help text and exit

Output control:
-m, --max-count=NUM stop after NUM selected lines
-b, --byte-offset print the byte offset with output lines
-n, --line-number print line number with output lines
--line-buffered flush output on every line
-H, --with-filename print file name with output lines
-h, --no-filename suppress the file name prefix on output
--label=LABEL use LABEL as the standard input file name prefix
-o, --only-matching show only nonempty parts of lines that match
-q, --quiet, --silent suppress all normal output
--binary-files=TYPE assume that binary files are TYPE;
TYPE is 'binary', 'text', or 'without-match'
-a, --text equivalent to --binary-files=text
-I equivalent to --binary-files=without-match
-d, --directories=ACTION how to handle directories;
ACTION is 'read', 'recurse', or 'skip'
-D, --devices=ACTION how to handle devices, FIFOs and sockets;
ACTION is 'read' or 'skip'
-r, --recursive like --directories=recurse
-R, --dereference-recursive likewise, but follow all symlinks
--include=GLOB search only files that match GLOB (a file pattern)
--exclude=GLOB skip files that match GLOB
--exclude-from=FILE skip files that match any file pattern from FILE
--exclude-dir=GLOB skip directories that match GLOB
-L, --files-without-match print only names of FILEs with no selected lines
-l, --files-with-matches print only names of FILEs with selected lines
-c, --count print only a count of selected lines per FILE
-T, --initial-tab make tabs line up (if needed)
-Z, --null print 0 byte after FILE name

Context control:
-B, --before-context=NUM print NUM lines of leading context
-A, --after-context=NUM print NUM lines of trailing context
-C, --context=NUM print NUM lines of output context
-NUM same as --context=NUM
--colour[=WHEN] use markers to highlight the matching strings;
WHEN is 'always', 'never', or 'auto'
-U, --binary do not strip CR characters at EOL (MSDOS/Windows)

i guess that what i get after do what console wanted me to 'grep -- help'
otherwise i get

[sudo] password for :
sudo: run: command not found

Usage: grep [OPTION]... PATTERNS [FILE]...
Try 'grep --help' for more information.

that what i meant

sorry im try to do something by my self :confused:


glxinfo | grep OpenGL

Copy and paste in into the terminal.


OpenGL vendor string: nouveau
OpenGL renderer string: NV126
OpenGL core profile version string: 4.3 (Core Profile) Mesa 20.0.7
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.3 (Compatibility Profile) Mesa 20.0.7
OpenGL shading language version string: 4.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.0.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

ok now i get something :slight_smile: what is nouveau ?

nouveau is the open-source Nvidia driver.


ok now its more to understand but if its works why when i list my gpu i get false in this ?

Look at the column heading - the "false" means that the video-nvidia-440xx driver is not "free" (free meaning open-source) but it is proprietary. See the heading of the column? The heading is FREEDRIVER - so the drivers shown under that heading are either free/opensource=true, or false if it's proprietary (not opensource).


well why when im runing programs to music they work well im glad of this but like i typed before :slight_smile: but somtimes its crash with no reasons and my games work realy slow its like my motherboard dont even have gpu on this im using PCI one and with other system 'windows witch i dont like any more' worked well
i dont understand why its goes like that on me :100:

i like Linux coz its 'easy to control' if you know what you doing :frowning:

1 Like

That's because the open source nouveau driver (the one you're using now) is known to be less reliable than the proprietary (and also official) Nvidia driver.

First, can you show me what your Hardware Configuration screen looks like in the System Settings app?



It appears that you have both video-linux (the nouveau driver) and video-nvidia-440xx (the proprietary driver) installed. Click on Auto Install Proprietary Driver, and copy-paste glxinfo | grep OpenGL into the terminal when it succeeds. That should activate the Nvidia driver for you.


Forum kindly sponsored by