High Network Ping Issue

Hello everyone,

I have been having some network trouble on my fresh Manjaro install. My connection speed when using speedof.me is ~100Mbps, but my ping always registers above 40. Additionally any web page takes over 5 seconds to load consistently (except google.com).

I did some digging on the forums and saw a recommendation to turn on ipv6 and assign an address. I'm not sure how to do that, and was hoping maybe someone here could help me to enable
ipv6.

If this doesn't fix my networking problems, what are some other options?

My System Specs:
i7 3770k
P8Z-68-V LX (NIC: RTL8111E)
GTX 1070
and a 128GB SSD for Manjaro

See here

My system came with r8168 already installed, I'm not sure if this applies to me. Maybe I'm mis-understanding the post?

Was a typo then?
To avoid all misunderstandings, provide output terminal of
inxi -Fxxxz
Share it here as text and use ``` above and below it.

System:
  Host: nicolae-linux Kernel: 4.19.32-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.3git-UNKNOWN tk: Gtk 3.24.7 
  info: xfce4-panel wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: P8Z68-V LX v: Rev X.0x serial: <filter> 
  UEFI: American Megatrends v: 4105 date: 07/01/2013 
CPU:
  Topology: Quad Core model: Intel Core i7-3770K bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56031 
  Speed: 2693 MHz min/max: 1600/5900 MHz Core speeds (MHz): 1: 2191 2: 2140 
  3: 2258 4: 2256 5: 2214 6: 2238 7: 2247 8: 2209 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia 
  v: 418.43 bus ID: 01:00.0 chip ID: 10de:1b81 
  Display: x11 server: X.Org 1.20.4 driver: nvidia tty: N/A 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 
  direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Device-3: C-Media Blue Snowball type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 4-1.1:3 
  chip ID: 0d8c:0005 serial: <filter> 
  Sound Server: ALSA v: k4.19.32-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK P8P67 and other motherboards driver: r8168 
  v: 8.045.08-NAPI port: d000 bus ID: 04:00.0 chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.94 TiB used: 7.15 GiB (0.4%) 
  ID-1: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 023 scheme: MBR 
  ID-2: /dev/sdb vendor: A-Data model: SU800 size: 119.24 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 1A scheme: GPT 
  ID-3: /dev/sdc vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC4C scheme: GPT 
Partition:
  ID-1: / size: 116.58 GiB used: 7.15 GiB (6.1%) fs: ext4 dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 35 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 36% 
Info:
  Processes: 208 Uptime: 2h 36m Memory: 7.75 GiB used: 1.81 GiB (23.3%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.2 
  running in: xfce4-terminal inxi: 3.0.32 

Use traceroute to check your route and which hops are slow.

Which stage of page load is slow? Address resolution or resource loading? Use e.g. Firefox Developer Tools -> Network (CTRL-SHIFT-E) to check.

Ok then, if you have the issue with the r8168 driver, and the link i provided doesn't help, then i propose to remove the r8168 driver, remove the blacklist r8169 from /etc/modprobe.d

Also modify in /etc/dhcpcd.conf the line from
duid to clientid

In /usr/lib/NetworkManager/conf.d/20-connectivity.conf
comment or remove the uri line

In Network Connection Settings enable Auto negotiation and Automatic MTU, disable IPv6
Reboot after all that, restart your router and the connection should be much better.

1 Like

Here are two traceroutes to 8.8.8.8 and 1.1.1.1

traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

traceroute to 1.1.1.1 (1.1.1.1), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

Also, here is a screenshot of loading a webpage:
Screenshot_2019-04-13_11-11-02

I'm on a campus, and dont have the ability to restart the router, is this step necessary?

Yup, you have a DNS issue.

Have you set up your connection according to the Campus instructions?

Have you contacted your local technical support for help, given they know how their system works?

No I haven't, but i suppose i could send them an email with my issue. But I plan on trying a VPN beforehand, I'll post if it resolves my issue. Thank you very much for your help guys!

Check the Campus network "acceptable use policy" first.

As a serial rule-breaker, the VPN solved the issue. This isn't the ideal solution and will solve it with the networking dept. on campus.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by