Hitching in all games

So ive been using linux for about a week now and have been in general enjoying it but im having a very odd issue with games hitching.

I downladed Night in the Woods to play with and almost immediatly noticed that the game was hitching, a lot. i checked and I was only using 1.5G of my 16G ram system-wide. almost as if its locked in or something. I then figured that I ought to try and run minecraft because it loves eating ram. out of an allocated 8G, it would refuse to use anything more than 3.2G, even when I put it under a really heavy load. Firefox does not seem to have this issue, upon opening a lot of tabs it will it will just eat an appropiate amout of ram. when the ram is maxed my CPU will go 100% on all cores.

ive done a lot of stuff poking around in terminal to see if there is some bottleneck, but nothing looked weird to me or my girlfriend, who has a fair bit of expierence using Linux. I can send any outputs that would be of intrest ofc

Thanks, pls halp

You can try doing things like lowering swappiness.
If you like you can use the maxperfwiz script to automate a few of the options.

I guess its worth wondering how you launch these things .. through a game client?
Are they native versions or proton or wine ?

And as always ..

(specifically at least start with inxi -Fxxxza --no-host)

System:
  Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=ef300b23-1498-4423-aee0-3773f6671499 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Acer model: Aspire TC-780 serial: <filter> 
  UEFI: American Megatrends v: R01-A1 date: 06/22/2016 
CPU:
  Topology: Quad Core model: Intel Core i5-6400 bits: 64 type: MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: D6 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 21607 
  Speed: 3171 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 3171 2: 3238 
  3: 3165 4: 3144 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Baffin [Radeon RX 550 640SP / RX 560/560X] vendor: XFX Pine 
  driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ff 
  Display: server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.36.0 
  5.6.16-1-MANJARO LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aae0 
  Device-3: Alesis type: USB driver: snd-usb-audio bus ID: 1-1.1.1:7 
  chip ID: 13b2:0087 serial: <filter> 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: d000 
  bus ID: 03:00.0 chip ID: 8086:3165 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 36.59 GiB (2.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC26 scheme: GPT 
Partition:
  ID-1: / raw size: 1.82 TiB size: 1.79 TiB (98.38%) used: 36.58 GiB (2.0%) 
  fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 69.0 C mobo: 29.8 C gpu: amdgpu temp: 72 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 229 Uptime: 1h 21m Memory: 15.60 GiB used: 2.66 GiB (17.1%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 
  running in: xfce4-terminal inxi: 3.0.37 

ah, is this what youre reffering to?

im launching Minecraft through multimc and night in the woods is just a .x86_64 file. got it from a DRM free bundle

Another thing worth mentioning since you are using AMDGPU ..
I notice your BIOS is from 2016 .. any updates available?

Actually I know there are .. from 2018 but still an upgrade:
https://www.acer.com/ac/en/US/content/support-product/6817?b=1

And ooohhhh
You are on XFCE.
Check this real fast - turn off the compositor in window manager tweaks (sic?)
[and test]

ive turned off compositor with no change. gonna update my bios now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by