Hitting walls trying/installing XFCE 17.1.10

may be this :slight_smile:

Have a look at first post of this.
Make sure the commands in section[Additional UEFI commands] are done.
If it still boots only to Windows, then the Lenovo link in the section [Some Difficult UEFI setups] would help.

That Lenovo link is quite clear (good job by OP). Copy the windows efi file and create custom.cfg entry for it. If you need further help, ask here on this topic. But provide all data required (efibootmgr -v, parted -l,....)

Good luck.

1 Like

Thanks for the info so far.

Unfortunately I'm currently stuck at an earlier step. I decided to redo everything: delete the Manjaro partition and then add the newly created unallocated space to Windows. I also recreated the DD image on my USB device.

The Manjaro installer keeps getting stuck at "unsquashing filesystem" at 20%. I'm also still not able to do much on the USB device apart from setting up the wifi connection. Almost everything I do leads to an error along the lines of "Failed to execute exo-open ..."

I'll try the KDE version now, to see if that brings me some more luck.

Yes, this is the "normal' way the installer works unfortunately. Give it time, it will continue or something really has to be wrong.

Yesterday the installer was done in just a couple of minutes (iirc). In consecutive attempts I've been waiting up to half an hour, and it was still stuck at "unsquashing filesystem". I will try again later, to see if I really am a little bit impatient here.

This is too much, it normally stays at 20% for about a few (1-2) minutes, then in a few larger steps it completes the installation.

The KDE version seems to work a bit better on my USB device. At least I get to open the terminal. However the installer doesn't do anything, and even auto-closes every time I start it myself.

In the topic Unable to install Manjaro someone suggests trying the terminal based installer by doing sudo -E calamares -d from the terminal. Unfortunately I'm getting "bus error".

Seems like another dead end. :sweat:

I think I will leave it for now. I don't really know how I should proceed from here.

I suggested to post the output of sudo -E calamares -d. The command itself won't help you.

The output was simply “bus error”.

I’m assuming the installation on the Live USB is corrupted somehow, or there is something wrong with the hardware.

Looks like here:

Hi guys. Tonight I was trying again, and I think I somehow made some progress. I will start from the beginning:

A friend told me he installed Manjaro by following http://linuxbsdos.com/2016/11/07/how-to-dual-boot-manjaro-16-10-windows-10-on-a-computer-with-uefi-firmware/, so I tried that out.

One difference in the steps is that the Windows partition is being shrinked by diskpart on Windows, and not by the Manjaro installer. The diskpart program gave an error when I tried to shrink the volume, telling me that it may be corrupted. After doing some research, I found that I should try runningchkdisk /f /r and then SRC /SCANNOW. After these steps I was able to shrink the volume. Good news!

Then I decided to redo the creation of the live usb. This time I was able to use Rufus 3.0, the newest release, instead of Rufus 2.1.8 to create the live usb. I don't remember the exact message: Rufus 3.0 notices that the Grub version of the Manjaro iso file is 2.0.3, while only Grub version 2.0.2 was available by Rufus/Windows. It was able to search for 2.0.3 online before creating the live usb. So far so good!

When I started Manjaro on the live usb, everything seemed to be working perfectly. I was able to open the user guide PDF and I was able to open the terminal. The installation also went well. I selected the 60 GB of unallocated space as my partition and the installer finished successfully. Now I'm getting really excited!

Unfortunately, but also as expected, Manjaro wasn't yet recognised as a bootable partition on restart. I decided I need to follow the steps mentioned in https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader. That's where things started to go wrong.

lsblk -f outputs:

NAME   FSTYPE  LABEL     UUID                                 MOUNTPOINT
loop0  squashf                                                /run/miso/sfs/live
loop1  squashf                                                /run/miso/sfs/mhdw
loop2  squashf                                                /run/miso/sfs/desk
loop3  squashf                                                /run/miso/sfs/root
|-sda1 vfat    SYSTEM    303C-BF7E
|-sda3 ntfs    Windows   C27C3F4F7C3F3D8B
|-sda4 ntfs    WinRE_DRV CC303F97303F880A
|-sda5 ext4              c13386f6-1468-4433-b490-1507f696c517
sdd    iso9660 MJR17110  2018-05-07-18-00-47-00
|-sdd1 iso9660 MJR17110  2018-05-07-18-00-47-00
|-sdd2 vfat    MISO_EFI  2EA9-60EC

mhdw-chroot outputs: bash: mhdw-chroot: command not found

sudo su works as expected

pacman -S mhdw-chroot outputs:

warning: database file for 'core' does not exist
warning: database file for 'extra' does not exist
warning: database file for 'community' does not exist
warning: database file for 'multilib' does not exist
error: target not found: mhdw-chroot

mount /dev/sda5 /mnt outputs: mount: /mnt: unknown filesystem type 'ext4'.

I've tried these steps a couple of times, doing several restarts. The problems I mentioned earlier, about not being able to launch the terminal, and the whisker menu crashing, also came back.

After recreating the live usb once more, I am able to load the terminal again, but thats about it.

I also tried sudo -E calamares -d, which instantly leads to Segmentation fault, whereas it was bus error two weeks ago.

The main problem seems to be that the live usb is very unstable. I'm noticing different behaviors every time I start Manjaro on the live usb.

Does anyone have an idea how to proceed from here?

Thanks in advance. :slight_smile:

And in GUI just Start from Applications Menu (start writing "chroot", it will show)

My bad, I think I misspelled it in my post, but I did it correctly in the terminal.

Good news: I made some more progress.

I don't understand why, but today I was able to complete the steps in https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader. Apparently if the live usb is not working well, I should just restart a few times until it does.

I completed all the steps, but unfortunately the Windows-Manjaro dual boot is still not available. My computer keeps booting Windows. I think I did everything correctly as the mount point of /dev/sda5, the Manjaro partition, to /mnt/boot/efi

I will try these steps again, but this time I will use a second EFI System Partition, instead of using the existing one. I will keep you posted.

can you report

sudo efibootmgr 

From the live usb:

BootCurrent: 001C
Timeout: 0 seconds
BootOrder: 0000,0017,0018,0019,001A,001B,001C,001D,001E,001F,0024
Boot0000* Windows Boot Manager
Boot0010  Setup
Boot0011  Boot Menu
Boot0012  Diagnostics Splash Screen
Boot0013  Lenovo Diagnostics
Boot0014  Startup Interrupt Menu
Boot0015  Rescue and Recovery
Boot0016  MEBx Hot key
Boot0017* USB CD
Boot0018* USB FDD
Boot0019* NVMe1
Boot001A* NVMe0
Boot001B* ATA HDD0
Boot001C* USB HDD
Boot001D* PCI LAN
Boot001E  Other CD
Boot001F  Other HDD
Boot0021* USBR BOOT Floppy
Boot0022* ATA HDD
Boot0023* ATAPI CD
Boot0024* PCI LAN

I still suggest you follow the Tutorial that was pointed out from the beginning. It is the best you can get.

If after studying and following this guide you have issues, post them please.

Big thanks @AgentS! I kinda forgot about that topic as I ran into all those other weird problems. These steps did the trick for me.

pats self on the back for being persistent, and not giving up

As you checked my post as a solution as what I said was already in a previous post, I can only accept if you consider that the real issue was that you were following the wrong Guide. :joy:

Well, the previous time you mentioned that topic, I was encountering problems on so many levels, that I wasn't sure what to try first:

On the other hand, I do remember trying the guide in your link at some point. That didn't work at the time. I don't remember why exactly, I only remember that pressing c from the Manjaro boot screen didn't help me then.

Feel free to unaccept your post being the solution, if that's even possible. :wink:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by