Hori Fighting Joytick used to work, now doesn't

Hello. I started to use a Hori Fighting stick for MAME, and everything went fine the first time around. I shut down my computer and let the joystick plugged in, then I came back later and now it doesn't work at all. The gamepad utility doesn't recognize it and neither do other emulators, for some reason though, lsusb knows it's there hori%20troubleshoot%201

I'm a beginner so I don't know how to remove the device, reinstall drivers etc. So I'd like some assistance with this issue.
Thanks.

Have you tried to unplug it and plug it back again with the system running ?

Yes, even rebooting the PC.
Tried sudo cat/dev/input/js0 to see if the live inputs get detected... and they do. There's literally no reason for the joystick to not work.

Have you tried different kernel?

Yes, had linux 5.3.12-1, tried with linux 4.19.85, still nothing.

Have you seen this

Also, did you used before the joyutils or linuxconsole or you used a different package ?
Now the image you posted was loaded, so this is strange to me ... what is that you wanted to achieve with this commands?
image

I searched for my problem and came across this stack page, but it was on ubuntu so it didn't work. I came from windows so my intention was to "delete the device", bad habits I guess.
Didn't try neither (joyutils or linuxconsole) I installed joyutils, run jstest and it registers everything:
troubleshooting-hori2
This is probably an anomaly, it really should be working...

Update: decided to hook a Dualshock 4 to see if the problem it's exclusive to the hori stick, and it isn't. The dualshock 4 doesn't get detectedby the emulators or the gamepad utility, but still appears when I uselsusb and jstest /dev/input/js0
It appears my computer has a problem with gamepads in general

Update:
Finally managed to get the Hori fightstick to work, probably my solution is dubious, but it's the only way I could make it work.
I run dolphin as root (Dolphin as root) and changed the owner of the file "js0" from "root" to my user. Now the gamepad utility, jstest, and the emulators I use detect it. The dualshock 4 now gets detected by everything but the emulators (I can even use the panel as a mouse). But I guess that's another issue.

There is no real, substantiated, technological reasons why anybody should run a GUI application as root. By running GUI applications as an admin user you're literally running millions of lines of code that have not been audited properly to run under elevated privileges; you're also running code that will touch files inside your $HOME and may change their ownership on the file system. You're opening up a massive, gaping security hole.

Well, if the only way to make something work was to make it usable for non root users, I figured out that running the eumlators as super user would allow me to use the gamepad and, it worked too. I guess this solution is not only better but less annoying, because I had to change the file owner every time I plugged in the stick.

From what I understand (unless it uses xbox-one drivers) the controllers should just work. I also use Hori stick and Dualshock4 to play stuff. No need to invoke sudo or su. Some simple troubleshooting would be enough.

  • For the Hori stick it could possibly bug out when switching between ps4/ps3 modes during use. Try unplug and replug into different usb slot. Maybe followed by relog.
  • For Dualshock 4 the wired and bluetooth modes are recognized as two distinct controllers. In the emulator you may have to remap it even though it looks the same.

They used to work, now they don't. The only way to make them work is to invoke sudo (because JS0 is only accesible by root). It's impractical though, invoking sudo messes up the audio and now there's no sound.
The error I'm having is really an anomaly. With the system update I hoped the gamepads could work again but they didn't.
I'll edit the "Solved" thing because it's hardly solved haha. I hope something can be done about it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by