Horrible performance with 20.05 on RPi4

I just reinstalled the new Manjaro ARM XFCE Release on my RPi4. At first boot, I noticed input lag, mouse lag and generally horrible graphical perfomance.
I thought maybe my SD card is damaged. But since I use an NVME anyways, I continued to setup my Pi to use the SD card only for boot and my NMVE SSD for the rest.

Still, horrible performance. I overclocked the CPU to 1800 MHz, GPU to 600 MHz, set the gpu_ram to 512 MB.
I had stellar performance with the 20.03 release, and I don't understand why it's so laggy and slow now. CPU usage is at 10 %, Memory nearly free.

One really weird thing is that lscpu doesn't output the current CPU Speed, only max and min.
cpu-temp-speed shows that the CPU speed goes between 600 and 1800 MHz, so the overclock seems to be working.

Anybody have similar problems? Have I missed something? Do I need to activate GPU usage somehow?

I'm considering going back to 20.03, this is not usable sadly.

I use XFCE here and I am unable to reproduce the issues gpu you are encountering. With all program upgrades current I tried mesa and mesa-git, kernels 4.18 and 5.4 and all seems normal like it has been. So I am at a loss on what you are experiencing with our stock image with out any modifications.

With our stock image changing the gpu_ram to 512 will do nothing but reserve ram that will not be used as in the mesa vc4/v3d mode it automatically uses cma 256M instead.

I never tried lscpu on the RPi and do not know what it displayed before but the RPi people recently went with upstream's way with displaying cpu speed. inxi and cpu-temp-speed works as always with showing current speed. I do know that some linux programs displaying things like cpu gpu are not totally compatible with the RPi's.

xfce

Hello and Welcome to the forum.

Sorry for the inconvenience,
Can you share the output of the following?

  • inxi -Fzxi
  • dmesg | grep error
  • htop
  • cpu-temp-speed

Maybe this will give us some insight.

Hey, thanks for your answer.

The output of inxi is:

System:
  Host: nilsmanjpi4 Kernel: 4.19.113-3-MANJARO-ARM aarch64 bits: 64 
  compiler: gcc v: 9.2.0 Desktop: Xfce 4.14.2 Distro: Manjaro ARM 
Machine:
  Type: ARM Device System: Raspberry Pi 4 Model B Rev 1.1 details: BCM2835 
  rev: c03111 serial: <filter> 
CPU:
  Topology: Quad Core model: N/A variant: cortex-a72 bits: 64 type: MCP 
  arch: ARMv8 rev: 3 
  features: Use -f option to see features bogomips: 432 
  Speed: 1500 MHz min/max: 600/1500 MHz Core speeds (MHz): 1: 1500 2: 1500 
  3: 1500 4: 1500 
Graphics:
  Device-1: bcm2835-vc4 driver: vc4_drm v: N/A bus ID: N/A 
  Device-2: bcm2835-hdmi driver: N/A bus ID: N/A 
  Display: x11 server: X.org 1.20.8 driver: modesetting 
  resolution: <xdpyinfo missing> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: bcm2835-audio driver: bcm2835_audio bus ID: N/A 
  Device-2: bcm2835-hdmi driver: N/A bus ID: N/A 
  Device-3: Logitech 960 Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1.3.2:5 
  Sound Server: ALSA v: k4.19.113-3-MANJARO-ARM 
Network:
  Message: No ARM data found for this feature. 
  IF-ID-1: eth0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-2: wlan0 state: down mac: <filter> 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 262.03 GiB used: 8.39 GiB (3.2%) 
  ID-1: /dev/mmcblk0 model: SD16G size: 29.14 GiB 
  ID-2: /dev/sda type: USB vendor: JMicron Tech model: JMS583 
  size: 232.89 GiB 
Partition:
  ID-1: / size: 28.39 GiB used: 4.53 GiB (16.0%) fs: ext4 
  dev: /dev/mmcblk0p2 
  ID-2: /boot size: 213.4 MiB used: 38.0 MiB (17.8%) fs: vfat 
  dev: /dev/mmcblk0p1 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 180 Uptime: 7m Memory: 3.73 GiB used: 1.28 GiB (34.3%) 
  Init: systemd Compilers: gcc: N/A Shell: bash v: 5.0.16 inxi: 3.0.37

dmesg shows:
[ 5.040083] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2

htop looks like this:
htop_screen

and cpu-temp-speed says: 1500 Mhz / 41 C

I see that mandb is taking alot of cpu, I have had this issue.
Terminate the mandb and your system should work fine.

sudo killall mandb

Try and let me know.

No change in performance. I can also not update, there is an error:

error: failed to commit transaction (conflicting files)
nss: /usr/lib/p11-kit-trust.so exists in filesystem
Errors occurred, no packages were upgraded.

Could this be connected, can I just delete that file?

Could it be related to XFCE? Should I try KDE (Can I easily switch to KDE)?

This is a known issue mentioned on the repo update post

That has nothing to do with the performance. But yes you need to update to the latest packages and see if it works fine.

I upgraded everything, but the performance issues have not been resolved...

I tried out with Raspbian couple hours ago, no performance problems there.

No sure about this then.
Can you try switching to mesa-git ?

Maybe @Darksky can help you with this.

It's weird that I have 1% CPU usage and a lot of free memory, and yet everything to do with graphics is laggy, unresponsive.
This mesa-git? https://aur.archlinux.org/packages/mesa-git/

It's also in the repo, so you can just sudo pacman -S mesa-git and then say yes to replacing mesa with mesa-git.

Same "performance" with mesa-git

Install mesa-demos and xorg-xdpyinfo and run:

inxi -G

The output should look similar to below except maybe for the bcm2711-vc5 as I have now switched back to kernel 5.4.38-2-MANJARO-ARM.

inxi

Graphics: Device-1: bcm2835-vc4 driver: vc4_drm v: N/A
Device-2: bcm2835-hdmi driver: N/A
Display: x11 server: X.Org 1.20.8 driver: modesetting tty: N/A
OpenGL: renderer: V3D 4.2 v: 2.1 Mesa 20.0.5

I hope your rebooted after installing mesa-git.
As it still shows 20.0.5

Yes I did. Since it didn't change, I reverted back to mesa

Comparing the 32bit raspian image to the 64bit OS is like comparing apples to oranges.

I have not noticed any performance issues with the mandb rebuilding but I had to disable it in the pi's with slower cpu's or I could not do anything until it quit rebuilding.

sudo nano /usr/lib/systemd/system/man-db.timer

#Description=Daily man-db cache update

#[Timer]
#OnCalendar=daily
#AccuracySec=1d
#Persistent=true

Reboot the pi4

I also overclock my pi4 to 2000 so if you have proper cooling (heat sinks and fan) try this:

over_voltage=5
arm_freq=2000
core_freq_min=500

Reboot the pi4

I don't understand how overclocking the arm would help if my CPU usage is at 1-10%?
Also, it is already overclocked.

over_voltage=4
arm_freq=1800
core_freq_min=500

What kernel are you using

Linux nilsmanjpi4 4.19.118-1-MANJARO-ARM #1 SMP PREEMPT Mon Apr 27 15:17:51 CDT 2020 aarch64 GNU/Linux

Forum kindly sponsored by