How can change screen resolution while booting with Nomodeset?

Hi guys. I got a few issues on my video card and I'm booting with nomodeset. I wanna change my screen resolution because I got only 800x600.

Maybe change in /etc/default/grub ,( 'videoinfo' in grub).

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo' must be videoinfo


$ sudo update-grub

But .. honestly .. whats the point ?
'nomodeset' should just be a way for you to boot and more easily configure things properly so that nomodeset is no longer required (and then the resolution thing becomes a non-issue)


I can only boot with 1280x1024? I need 1920x1080.

When I'm booting my system without "Nomodeset" then I get a problem. I see No Signal on my monitor. I tried my things but no one is doesn't worked.

Did you not read my response?
I am sorry things are not working 'automatically' for you .. but 'nomodeset' is just a way for you to boot so you can fix those problems.. you should not just be running a 'nomodeset' system all day every day.

Maybe this is a case of 'asking the wrong questions'. .. maybe your graphics/drivers are not configured well .. so maybe you start with something like
inxi -Fxxxza --no-host

[report output using the </> code button .. and people might be able to help fix the real problem]

  Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
  Desktop: KDE Plasma 5.15.2 tk: Qt 5.12.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: F2A68HM-DS2 v: x.x serial: <filter> 
  UEFI: American Megatrends v: FE date: 10/09/2018 
  Topology: Quad Core model: AMD Athlon X4 860K bits: 64 type: MCP 
  arch: Steamroller family: 15 (21) model-id: 30 (48) stepping: 1 
  microcode: 6003106 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 29558 
  Speed: 2802 MHz min/max: 1700/3700 MHz boost: enabled 
  Core speeds (MHz): 1: 2777 2: 2577 3: 2602 4: 2519 
  Vulnerabilities: Type: l1tf status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 mitigation: __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Device-1: AMD Turks PRO [Radeon HD 6570/7570/8550] 
  vendor: Hightech Information System driver: radeon v: kernel 
  bus ID: 01:00.0 chip ID: 1002:6759 
  Display: x11 server: X.Org 1.20.4 driver: radeon FAILED: ati 
  unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 4.19.28-1-MANJARO LLVM 7.0.1) 
  v: 3.3 Mesa 18.3.4 compat-v: 3.1 direct render: Yes 
  Device-1: AMD FCH Azalia vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 chip ID: 1022:780d 
  Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] 
  vendor: Hightech Information System driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 1002:aa90 
  Device-3: Kingston type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 1-1:2 chip ID: 0951:16a4 serial: <filter> 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 938.98 GiB used: 5.09 GiB (0.5%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC49 
  scheme: GPT 
  ID-2: /dev/sdb type: USB model: USB DISK 2.0 size: 7.46 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / raw size: N/A size: 5.85 GiB used: 157.1 MiB (2.6%) fs: overlay 
  source: ERR-102 
  System Temperatures: cpu: 51.6 C mobo: N/A gpu: radeon temp: 67 C 
  Fan Speeds (RPM): N/A 
  Processes: 193 Uptime: 9m Memory: 7.80 GiB used: 1.78 GiB (22.9%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: konsole inxi: 3.0.32

Did you install the vesa driver ?

But your system Xorg has 1080p.
If you mean grub menu screen, you can't always have it. It's configured as @sgs advice, but you have to find if your monitor can have what you set.
Check Archwiki on grub.

1 Like

I'm talking about normal screen resolution, not grub menu.

Then explain this (is it an old report?):

I do but I get black screen after the install.

This without "Nomodeset" boot report. When I'm trying boot normal then I'm getting "No signal" on my screen.

Please post

mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

What have you tried already?

Start again (I suggest). Because

  • Boot without nomodeset
  • If you get to GUI, post logs (journalctl -p -3 and xorg log )
  • If not, reboot and post logs from previous boot

How to change video drivers or configuration and troubleshoot
How to provide information about your issues

1 Like

Forum kindly sponsored by