How do i fix 403 error in lamp?

Hi, i just installed manjaro kde three days ago (i think), after playing around with it i decided it was my favorite OS ever, then i ran into a problem.

I'm learning php and tried to install lamp, everything worked until i tried including httpd-vhosts.conf in the httpd.conf file (to add multiple virtual hosts), after that i the 403 forbidden error.

I've been trying to fix this for two days now and most of the search results i got were for other linux distros. please help me, ive given up all hope.

The folder or file on the server does not have read permissions from "everyone".

how do i enable it for everyone? sorry for being a noob

You modify the files/folders permissions on the server to include read access for everyone.
Common permissions for public files are: 644.
Readable but not executable.

thanks, i'll see if it works

No, it didn't work. Just to be clear, i modified my /srv folder (where my website is stored) by typing "chmod 644 /srv", is that correct?

Not quite.

As far as I know, you have to use chmod -R to give the permissions to folders and files in the subfolders.

But since this only happened when you included the httpd-vhosts.conf file, it most be something in the folders that are added inside that.

thank you so much! it worked! but i'm getting a "server not found error" this time. I think it's just a matter of editing the hosts or the httpd-vhosts file, but if it isn't i'll report back.

Thanks for taking time out of your day to help me.

Forum kindly sponsored by