How to access an iPhone with Manjaro

If you have an iPhone and you want to copy the photos you have on it to your Manjaro computer, then you might have noticed that they aren't accessible in Manjaro when you connect your iPhone to your PC.

Many of you know that Apple devices are very closed off and that they poorly support Linux. There is however a way to access the files on your iPhone, so that you can at least copy them to your computer.

The process is as follows:

Step 1: Unplug your iPhone from your computer. (if it is plugged in)

Step 2: Install the following packages

  • ifuse
  • usbmuxd
  • libplist
  • libimobiledevice

You can install them one by one using Pamac or you can use the following terminal command to install them all at once:

sudo pacman -Syyuu ifuse usbmuxd libplist libimobiledevice

Step 3: Reboot your system

Step 4: Connect your iPhone to your computer.

Step 5: Log in to your iPhone

Step 6: Open Thunar (your file manager). Your iPhone should now be listed in the left pane in Thunar where you can access it to copy your files/photos to your computer.

*If you want to be able to do more with your phone than just copying files to your Linux system, then it's better to get an Android device, as they tend to be less closed off and they work well with Linux systems, because Android itself is based on Linux.

That's it. Enjoy.


Well, on KDE everything is installed by the default with the exception of ifuse. So I simply installed ifuse, and walla it works like a charm! I always used to import the photos via digiKam, but it's a pain in the rear! This is much more convenient. Thank you Heart-Of-A-Lion for this useful tip. :slight_smile::slight_smile:

1 Like

This worked great on both of my desktops, but it doesn't recognize the iphone on any of my laptops. I don't know if this has to to with the GPU. My desktops are NVIDIA, and my laptops, are Intel & ATI. Any idea as to why it's not connecting on my laptops? In fact I even didn't have to install "ifuse" on my home desktop, and it worked fine even without it.:confused:


You can try to verify if your laptop detects your iPhone with the following command:

dmesg | grep -i iphone

The output can look like this:

[ 31.003392] ipheth 2-1:4.2: Apple iPhone USB Ethernet device attached
[ 40.950883] ipheth 2-1:4.2: Apple iPhone USB Ethernet now disconnected
[ 47.471897] ipheth 2-1:4.2: Apple iPhone USB Ethernet device attached
[ 82.967116] ipheth 2-1:4.2: Apple iPhone USB Ethernet now disconnected
[ 106.735932] ipheth 2-1:4.2: Apple iPhone USB Ethernet device attached

1 Like

You can also try to mount your iPhone.

Create a directory called 'iPhone' in your homefolder, then mount the contents of your iphone into that new folder using ifuse:

ifuse ~/iPhone

1 Like

It just says "107.107886] ipheth 3-4:4.2: Apple iPhone USB Ethernet device attached", but won't detect anything under the Device Notifier. I guess it simply won't work with my laptop!

I tried this with a new iPhone 7. It does not work. :-1:

Has anyone else had success getting Manjaro to read an iPhone 7 :question:

1 Like

With an iphone7, maybe you want to try the latest libiphonedevice-git (AUR) ?

I have noticed that the official iPhone cable does work with this method (tested on iPhone 5s), but that some unofficial cables don't work. So using the right cable can be a factor.

1 Like

I installed Manjaro on my MacbookPro 2009, after installing the mentioned packages, it can detect and transfer photos from my iPhone 6plus.

1 Like

5 posts were split to a new topic: Using Manjaro to connect to an iPhone data storage

Forum kindly sponsored by