How to add a second monitor connected to the integrated graphics card not the dedicated one?

I have a dedicated GPU and an integrated one. The first monitor is connected to the GPU, and the second one is connected to the integrated GPU.
I have set "on board graphics" to "always" in bios, and the second monitor works only if I deleted "/etc/X11/xorg.conf", and this disables the first monitor.
If I switched to a TTY the first screen is disabled and the second one works.
On windows 10 both monitors work without any problems and I can share windows between them.
I was thinking if I could add anything to "/etc/X11/xorg.conf" to fix this but I don't know what to add.

delete or rename xorg.conf to xorg.conf.bak since manjaro uses /etc/X11/mhwd.d/ for xorg configurations which get symlinked to /etc/X11/xorg.conf.d/ .

this makes the existing driver and xorg configuration incorrect. did you change the drivers since disabling the discrete graphics?

check which drivers are installed with mhwd -li then uninstall all video drivers with this command

sudo mhwd -r pci video-???

replace ??? with the name of the installed drivers, you may have more than 1.

then make sure these directories dont have any video related .conf files in them before installing the correct driver.

/etc/X11/
/etc/X11/xorg.conf.d/

if thats good, now install correct drivers

sudo mhwd -i pci video-linux

reboot.

No I didn't disable the discrete graphics, what I did is keeping the integrated one working even when there is a discrete graphics installed.

Yes I'm not sure about the driver, there is "video-hybrid-intel-nvidia-430xx-bumblebee", "video-nvidia-435xx", "video-linux" and "video-vesa", I have installed this "video-nvidia-435xx".
Moreover deleting those configuration files disables the monitor connected to the dedicated GPU, and the other one connected to the integrated GPU works fine.

But I think nvidia-settings and related programs will not work.

More interesting things:
I have done some edits to "/etc/X11/xorg.conf" as it was:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 435.21
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"
EndSection
Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection
Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "XXX AAA"
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 1030"
    BusID          "PCI:1:0:0"
EndSection
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I have added this line

Screen 1 "Screen1" RightTo "Screen0"

after this line

Screen 0 "Screen0" 0 0

and added those line at the end

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection
Section "Device"
    Identifier     "Device1"
    Driver         "modesetting"
    BusID          "PCI:0:2:0"
EndSection
Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth   24
    SubSection     "Display"
        Depth      24
    EndSubSection
EndSection

The output of xrandr --listproviders was:

Providers: number : 1
Provider 0: id: 0x1f4 cap: 0x1, Source Output crtcs: 2 outputs: 2 associated providers: 1 name:NVIDIA-0

but now:

Providers: number : 2
Provider 0: id: 0x1f4 cap: 0x1, Source Output crtcs: 2 outputs: 2 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x42 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 2 outputs: 1 associated providers: 1 name:modesetting

The output of xrandr -q was:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 575mm x 323mm
   1920x1080     60.00*+  60.00    59.94    50.00    23.98    60.00    50.04  
   1680x1050     59.95  
   1366x768      59.96  
   1280x1024     60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93

but now:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 575mm x 323mm
   1920x1080     60.00*+  60.00    59.94    50.00    23.98    60.00    50.04  
   1680x1050     59.95  
   1366x768      59.96  
   1280x1024     60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  
VGA-1-1 connected (normal left inverted right x axis y axis)
   1360x768      60.02 +
   1024x768      75.03    60.00  
   832x624       74.55  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
   720x400       70.08  
  1024x768 (0x45) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x48) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x4a) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz

In the output of "xrandr -q", I'm wondering how both HDMI-0 and VGA-1-1 are under the same screen, and why VGA-1-1 doesn't have a resolution after "connected" word like HDMI-0

ok, this is why system info is so important. when you said

to me means that your running on only your intel and the nvidia is disabled. to take the mystery out of whats going on please post the output of these commands, use the </> so it's formatted properly.

inxi -Fxxxza --no-host
mhwd -li
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
System:
  Kernel: 5.3.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 
  root=UUID=e20d6a5e-e2d3-49d4-9ca8-49deeb26c85f rw quiet apparmor=1 
  security=apparmor resume=UUID=6e270e82-3df5-4101-9099-ab00c1b941ca 
  udev.log_priority=3 
  Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: G41M-Combo serial: <filter> 
  BIOS: Award v: F4 date: 05/30/2011 
CPU:
  Topology: Dual Core model: Intel Core2 Duo E8500 bits: 64 type: MCP 
  arch: Penryn family: 6 model-id: 17 (23) stepping: A (10) microcode: A0B 
  L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 12671 
  Speed: 2000 MHz min/max: 2000/3166 MHz Core speeds (MHz): 1: 2000 2: 2000 
  Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
Graphics:
  Device-1: Intel 4 Series Integrated Graphics vendor: Gigabyte driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:2e32 
  Device-2: NVIDIA GP108 [GeForce GT 1030] vendor: Micro-Star MSI 
  driver: nvidia v: 435.21 bus ID: 01:00.0 chip ID: 10de:1d01 
  Display: x11 server: X.Org 1.20.5 driver: intel,nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:27d8 
  Device-2: NVIDIA GP108 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb8 
  Sound Server: ALSA v: k5.3.5-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR8151 v1.0 Gigabit Ethernet vendor: Gigabyte 
  driver: atl1c v: 1.0.1.1-NAPI port: df00 bus ID: 03:00.0 
  chip ID: 1969:1073 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 8.45 GiB (1.8%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-08U6AA0 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: <unknown> rotation: 7200 rpm serial: <filter> rev: 1H19 scheme: MBR 
Partition:
  ID-1: / raw size: 50.00 GiB size: 48.97 GiB (97.93%) 
  used: 8.45 GiB (17.3%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 35 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 35% 
Info:
  Processes: 151 Uptime: 3m Memory: 5.77 GiB used: 988.2 MiB (16.7%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.36
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
    video-nvidia-435xx            2019.08.25               false            PCI


Warning: No installed USB configs!

I have installed "video-linux" also but in the "/etc/X11/xorg.conf" I have set each GPU to use the right one:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 1030"
    BusID          "PCI:1:0:0"
    Screen 	   0
EndSection
Section "Device"
    Identifier     "Device1"
    Driver         "intel"
    BusID          "PCI:0:2:0"
    Screen         1
EndSection
/etc/X11:
total 36
drwxr-xr-x  5 root root 4096 Oct 14 01:43 .
drwxr-xr-x 96 root root 4096 Oct 14 02:30 ..
drwxr-xr-x  2 root root 4096 Oct 13 22:38 mhwd.d
drwxr-xr-x  3 root root 4096 Sep 11 13:21 xinit
-rw-r--r--  1 root root 2221 Oct 14 01:43 xorg.conf
drwxr-xr-x  2 root root 4096 Oct 13 21:49 xorg.conf.d

/etc/X11/mhwd.d:
total 12
drwxr-xr-x 2 root root 4096 Oct 13 22:38 .
drwxr-xr-x 5 root root 4096 Oct 14 01:43 ..

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 Sep 11 13:21 .
drwxr-xr-x 5 root root 4096 Oct 14 01:43 ..
-rw-r--r-- 1 root root  739 Mar  4  2019 xinitrc
drwxr-xr-x 2 root root 4096 Oct 14 01:01 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  4  2019 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 Oct 14 01:01 .
drwxr-xr-x 3 root root 4096 Sep 11 13:21 ..
-rwxr-xr-x 1 root root  318 Nov  9  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 Sep 23 23:39 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 16
drwxr-xr-x 2 root root 4096 Oct 13 21:49 .
drwxr-xr-x 5 root root 4096 Oct 14 01:43 ..
-rw-r--r-- 1 root root  266 Aug 18 11:46 00-keyboard.conf

I think I have solved this problem and here is a summary:
1- This whole problem is related to the /etc/X11/xorg.conf file or as @dglt have mentioned:

the problem is related to these configurations.
2- I want to use two GPUs, so I downloaded two drivers one for each. In my case "nvidia-435xx" for the dedicated GPU and "video-linux" for the integrated GPU.
3- I don't understand exactly the syntax of the X server configuration files like /etc/X11/xorg.conf but I did my best:

  • I used nvidia-settings to generate a xorg.conf file, but the file included only what the GPU sees, because there is only one monitor connected to the integrated GPU so there was only one in the file, and the X server only saw one.
  • I read some pages to try to understand how to make this configuration file: multihead, Manjaro Doesn't Detect IGPU, Cannot detect outputs on dual graphic card configuration and other threads, but mentioned multihead on archlinux wiki was interesting, and to be honest I didn't understand all of this and I got lost in the terminology.
  • I saw some examples of xorg.conf files people made for dual display also and I realized that I have to edit my xorg.conf file to include this:
Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "intel"
    VendorName	   "Intel Corporation"
    BusID          "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth   24
    Option	   "TwinView" "0"
    Option         "Stereo" "0"
    Option         "SLI" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth      24
    EndSubSection
EndSection

I don't think I can explain this well, but:

  • I added a monitor section because I want to add another monitor.
  • I added a device section because this device section is what represents the integrated GPU, and I must specify the BusID, where I got the "BusID" is from the command lspci | grep VGA and the output was
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
01:00.0 VGA compatible controller: NVIDIA Corporation GP108 [GeForce GT 1030] (rev a1)
  • When I added the BusID, I changed the . to : and removed leading 0s and added PCI: at the beginning.
  • for the screen, I don't understand what these options do, I just copied the options that have a boolean answer from the the screen section that nvidia-settings set for the first monitor
    This might help if you want to understand these options: xorg conf
    The whole file now is like this:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 435.21

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"
    Option	   "AutoAddDevices" "1"
EndSection

Section "Files"
    ModulePath	   "/usr/lib/xorg/module"
EndSection

Section	"ServerFlags"
    Option	   "Xinerama" " 1"
    Option	   "AutoAddDevices" "1"
    Option	   "AutoEnableDevices" "1"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "XXX AAA"
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 1030"
    BusID          "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "HDMI-0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "intel"
    VendorName	   "Intel Corporation"
    BusID          "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth   24
    Option	   "TwinView" "0"
    Option         "Stereo" "0"
    Option         "SLI" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth      24
    EndSubSection
EndSection

I edited some lines that were generated by nvidia-settings:

  • I added
    Screen 1 "Screen1" RightOf "Screen0"
    after
    Screen 0 "Screen0" 0 0
    (important)
  • I added a section for files (not important, can by omitted)
  • I added a section for server flags (not important, can by omitted)
  • I added a BusID to the device section related to the dedicated GPU, so every device section have a BusID now (important)

The second monitor wasn't enabled yet, but some commands showed some hope, like:

$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x1f7 cap: 0x1, Source Output crtcs: 2 outputs: 2 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x44 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 3 outputs: 2 associated providers: 1 name:Intel

and

$ xrandr -q
Screen 0: minimum 8 x 8, current 3280 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 575mm x 323mm
   1920x1080     60.00*+  60.00    59.94    50.00    23.98    60.00    50.04  
   1680x1050     59.95  
   1366x768      59.96  
   1280x1024     60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  
VGA1 connected (normal left inverted right x axis y axis) 410mm x 230mm
   1360x768      60.02+
   1024x768      75.03    60.00  
   832x624       74.55  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
   720x400       70.08  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
  1024x768 (0x47) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x4a) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x4c) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz

I opened Settings Manager > Display, then I found that the second monitor is there but it just disabled, so I toggled the switch beside its name and it worked.
There still some problems like the panel appearing in one monitor and how to tweak the settings more, and I think this will be related to the xorg.conf file so I will keep it for another day.
For the panel I have two solutions:

  • Create another panel for the second screen Settings Manager > Panel then the + sign and customize it
    or
  • Align the bottom of the two displays from Settings Manager > Display (drag the smaller display so it's bottom is aligned with the bottom of the bigger one) and click apply.
  • Check Span monitors from Settings Manager > Panel (the panel is stretched over the two displays)
7 Likes

Congratulations! You've become an Xorg/video expert in the least amount of time!!!
You should be hired by the Forum!

Some minor notes on your work:

You have created a beautiful Xinerama setup for dual GPUs. I have a similar setup, mostly automatic with no real Xorg.conf at all. Maybe you should try that. I will surely try yours on my system! :wink:

Typo or mistake, it's modules. But as you said, it 's probably not needed.

These can be inserted in the Server Layout Section. Actually only one is missing there...

The same happens to mine. Do you have TTY on both monitors now??

This might had happened from a left-over Xorg.conf (in /etc/X11/xorg.conf.d/*.conf)? Or it has to do with LightDM Xsetup script (assigning an xrandr --auto could help).

Well done!! :crown:

2 Likes

Thank you very much for this wonderful feedback, I'm really so enthusiastic about computers and programming and these related things, but I'm still learning about computers, I'm still a student and have a lot of problems with my school and even more problems with time management :sweat_smile:.
By the way I took two consecutive days to find this :dizzy_face:, and I'm still not too expert with xorg, but thank you your feedback makes me feel more about the importance of time and hardworking.

I'm not sure I understand what automatic means, but if it means adding separate files to the /etc/X11/xorg.conf.d, I have tried that and it didn't work.

  • On the first time the config files were loaded from /usr/share/X11/xorg.conf.d (I looked at /var/log/Xorg.0.log), and when I switched to TTY2 and typed startx I got an error in 90-serverlayoutout.conf
  • On the second time after I have fixed the error only the first monitor was enabled and the config files were loaded from /usr/share/X11/xorg.conf.d also, and when I switched to TTY2 and typed startx I got two running X servers (ctrl + Alt + F2 and ctrl + Alt + F7 each have a different display)

So I just kicked the idea out of my mind, because I felt that my config files in /etc/X11/xorg.conf.d are overridden by config files in /usr/share/X11/xorg.conf.d

Yes, this was a mistake

I didn't realize I did that, until you mentioned it :sweat_smile:.

No, TTY only works on the monitor that its GPU starts first, I don't know why, but I think this is normal because I have configured the X server to use two monitors, but not the TTY.
Are there any configuration files for TTY ?

Yes, it seems that this is what happened. I found some files in /usr/share/X11/xorg.conf.d
Thank you again.

It's exactly the opposite!:laughing:
Never edit files in /usr/share/, as the changes will be gone with the next relevant package update. Only edit/add files in /etc/.

I was just checking :wink: TTY is without X (xorg-server) active.

The opposite. With no (Xorg related) conf file in /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/*.conf, the default system files are used (in /usr/share/), which are smart enough to scan HW and adjust video settings successfully (mostly... ).

1 Like

Unfortunatly, if I don't add this config file the monitor connected to the dedicated GPU won't display anything and won't appear in Settings Manager as a disabled monitor even, although the dedicated GPU is recognized! but no problems everything is fine now.

1 Like

Would you please post some more info (for my self-educating project :wink:) ?

for Xconf in $(ls /etc/modprobe.d/*.conf); do echo -e "\n" $Xconf ; cat $Xconf ; done
for Xconf in $(ls /etc/modules-load.d/*.conf); do echo -e "\n" $Xconf ; cat $Xconf ; done
1 Like

My pleasure:

 /etc/modprobe.d/mhwd-gpu.conf
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
 /etc/modules-load.d/mhwd-gpu.conf
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
nvidia
nvidia-drm

 /etc/modules-load.d/modules.conf
# List of modules to load at boot
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by