How to Boot to a Command Line and Bypass the Gui on a Pinebook Pro 14" Running Manjaro

My brand new Pinebook Pro 14" was delivered this week with the standard Manjaro installed. I updated it, and then did what it says not to do at

https://wiki.pine64.org/index.php?title=Pinebook_Pro#After_changing_builtin_LCD_resolution.2C_blank_screen

to wit:

Some people find that the text or icons are too small,

That would be me.

so they attempt to change the resolution of the built-in display.

Went there, did that.

Afterwards, the display is blank.

Actually, on boot, I got stuck at an unresponsive graphical login screen. I could enter text in the text box for the password, but there was no response upon "Enter".

I was unable to follow the instructions at the location above for fixing the problem as follows.

Use the following to fix when logged into a text console as yourself, (Control-Alt-F1 through F6).

Control-Alt-F2 got me a text interface with a command prompt.

After listing the resolutions,

I assume this was supposed to be done using xrandr, as described at

https://xorg-team.pages.debian.net/xorg/howto/use-xrandr.html

but xrander said it could not access the display.

select the native resolution, (1920x1080 aka 1080p).

Could not figure out how to do this.

export DISPLAY=:0.0
xrandr -q
xrandr -s [resolution]

Couldn't get anywhere with these, I guess because xrandr would not work.

If the above fix did not work, you can try this:

Using a text console, (Control-Alt-F1), login with your normal user ID

Needed to use Control-Alt-F1.

Edit the file nano ~/.config/monitors.xml

No such file so this path was blocked.

I am thinking that maybe the problem is that I need to boot into a command line interface without starting a gui, but I can't figure out how to do that. The instructions at

to wit:

- Boot without X - TTY1

  • Press “ e ” when the GRUB menu displays and for the kernel you wish to use
  • scroll down to the “ linux ” command line

don't work, I guess because I think the Pinebook Pro uses something called uboot, but I can't find information on how to use that to boot to a command line.

I have ordered the hardware that I hope will enable me to do a fresh installation of either Manjaro or another OS onto the Pinebook but, meanwhile, am hoping to discover a less brute force solution before it arrives.

I have been using Linux with one gui or another for a bout 15 years now, but it seems I am still having "a lot of fun."

-v

Booting to a command line is fairly easy.

When you are at the login screen press CTRL+ALT+F2.
This will get you to a TTY. Now login with your username and password. Then disable the display manager with:

sudo systemctl disable sddm #if using the default Manjaro KDE

And reboot. Now you will be greeted with the CLI login you saw in the TTY.

3 Likes

Assuming ManjaroARM is the same as Manjaro for the PC, you can change your default login target with

sudo systemctl set-default multi-user.target # for CLI

and

sudo systemctl set-default graphical.target # for GUI

I do this to toggle between the two when performing large updates.

1 Like

Both your suggestion and Strit's worked to get me straight to tty1 on boot, thanks, but when I then enter the command xrandr, which I was hoping to use to get back to the correct resolution for my Pinebook Pro display, I still get the message "Can't open display". I think that means I'm ready for more fun. Based on the alternative suggestion at

https://wiki.pine64.org/index.php?title=Pinebook_Pro#After_changing_builtin_LCD_resolution.2C_blank_screen

should I try creating ~/.config/monitors.xml with the correct resolution? If so, what exactly should the file contain?

This is quite a bit out of my knowledge zone, but I'm going to guess that you are seeing "can't open display" specifically because you are booted into a TTY, ie, no graphical display. I don't know what file you would need to edit/create or what the contents should be, but I would say you are on the right track.

Any other ideas? If not, no worries. I can always try to reinstall when my hardware arrives.

Don't change screen resolution. Change the scaling factor in KDE instead.

It's located at System Settings -> Display -> Global Scaling (slider).

1 Like

I get that now, but how do I get my gui back to do that? I did the bad thing and can only use the CLI.

I suspect that if I had a copy of what needs to go in a config file to create at /etc/X11/xorg.config.d it might do the trick. If I boot to a command line and try startx, the screen says that the kernel was loaded with what looks like the correct resolution and the computer is looking for a config file at /etc/X11/xorg.config.d, then some other messages and one saying connection to xserver lost. Config file might not be necessary if I had not done the bad thing, but maybe it would help now.

I'm not quite sure what can be your problem, but I believe X would try to configure itself if you empty the /etc/X11/xorg.conf.d folder (don't delete anything, just move it somewhere else).

Do you have a .xinitrc in your home folder?
startx will read that file if you have it, to start your session.

Here's a link to info on .xinitrc on the Manjaro Wiki:
https://wiki.manjaro.org/index.php?title=Proper_~/.xinitrc_File#.7E.2F.xinitrc_File

You need to start your KDE session, and the command is in the .xinitrc file.
You can also specify the session as a parameter to startx, for example:

  • startx /usr/bin/startplasma-x11 -- :0
  • startx /usr/bin/startkde -- :0

Also try these:

  • dbus-launch /usr/bin/startplasma-x11
  • dbus-launch /usr/bin/startkde

Or just:

  • startplasma-x11
  • startkde

If none of these helps, then it could be useful if you're able to share the output of the command that seems to work least badly?

If you have network then redirect output to a file and transfer to the computer you use for writing to this forum.

Also you have a log file /var/log/Xorg.0.log. It may be an idea to move that away or just delete it, and then try to start your session, and check that log file (it will be recreated).

1 Like

I have no idea what all you have done with changing the system setting but if things were only changed in your home directory some times removing the .ICEauthority and .Xauthority files in your home directory and rebooting will let you get past the login prompt. This may not work when changing the video resolution though.

If the above does not work then as a last ditch effort if it was me I would remove all of the dot files and dot folders in my home directory and install the original ones that came with the image. This should reset all configs for KDE back to original. This should in theory work provided you have not made any global changes in the system's files.

Remove all dot files and dot folders in your home directory
move skel.tar to your home directory and unpack it
reboot

skel.tar

1 Like

Tried the last ditch effort, which seems like it should have worked but didn't. I didn't think I had made any global changes to system files, but I've had a lot of fun and I think it's time to wait for my hardware and have some more fun learning to install a fresh image. Thanks to all for the suggestions. I learned a lot reading, thinking about, and trying them.

Hi Vdicarlo

Thanks for the post: I'm having similar issues only I corrupted my operating system entirely after the big update. The updater informed me that the 'breeze' update was corrupt so I removed the module and 'presto' no gui (well like you, an unresponsive login). So thanks to the thread above I can now log in to the operating system tty2 (couldn't see tty1).

A word of warning about the re-install of manjaro. I've tried any number of installs with manjaro operating systems on an SD card (20.06 kde/i2/xfce) but instead of a friendly set up menu I simply get a blank screen and have to power down. I've done all the right things (checked the hash, used etcher to transfer the img file to the sd card). It certainly isn't the easy to use environment promised, because the manjaro install just doesn't work as it is supposed to. The only light on the horizon is that the SD card install for Arch works (again command line only) so I know the SD card route does work: I think this is a manjaro issue of some kind.

I'm wondering if the manjaro installer is confused by the two Boot and Root drives with the same names.

Anyway thanks for your posts and I'm another step along the way but still in need of enlightenment!

Funny you should post that, @thepeckhambassplayer. I just started another thread describing my very similar experience. Maybe someone can help us. Meanwhile I am hoping that when my eMMC card and adapter arrive I will be able use that to boot and install a fresh image. If I were not the optimistic sort, I guess I wouldn't be using Linux and trying the new and exciting sounding Pinebook products while they are still in development.

P.S. - A post at another topic in which you also posted seemed to suggest that a similar sounding problem was solved by renaming the partitions, so as a wild guess hack I tried renaming BOOT_MNJRO to BOOT_MNJRO1 but it didn't help. Then I also renamed ROOT_MNJRO to ROOT_MNJRO1 and no still help.

Thanks for the heads up!

What fixed the problem was using a different brand of microSD card. Details in another topic.

Thanks to all who responded. I learned a lot and had a lot of fun.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by