How to change color background dolphin in xfce?

Hi
I use xfce 16.10
I installed dolphin file manager but not affect color for background dolphin
Can i change manual color background dolphin?
Because it is always white background

the color of any app depends on the theme that you are using

but theme not affect color for background dolphin
i use theme "vertex-maia-dark" all app background is color black but dolphin background is always color white
can i change manual color background dolphin?

could you please open manjaro-settings-manager and tell me if the background is also white

no it's black

Does anyone have this problem with dolphin?

The problem originates with Xfce being GTK2, while Dolphin, a KDE file manager, is QT5. You are really better off sticking with a GTK file manager.

Regards

Same Problem here.
Is there a File-Manager powerfull like Dolphin for GTK?
Love to get some suggestions.

You might want to try SpaceFM, though it's more demanding on configuration but is super powerful if you own it.

Thank you, I'll try it.

I had the same problem, but finally found the solution here.

Install and start the Qt5 Configuration Tool (qt5ct) and go to Style Sheets. There you can create a style sheet with the following content:

DolphinViewContainer > DolphinView > QAbstractScrollArea {
      background-color: transparent;
}

After saving and enabling the style sheet, the background in dolphin should appear right. :wink:

EDIT:
Since this still produced a white background in newer versions, i created a file with

DolphinViewContainer > DolphinView > QAbstractScrollArea {
      background-color: #383C4A;
}

which specifies a certain color and then i only start dolphin with this stylesheet:
/usr/bin/dolphin -stylesheet /home/stefan/.config/qt5ct/qss/dolphin-color.qss

2 Likes

Inspired by @stertl save to color_scheme_path=/usr/share/qt5ct/colors/i3wm-sgs.conf

[ColorScheme]
active_colors=#ffffff, #29353b, #303e45, #303e45, #303e45, #303e45, #ffffff, #ffffff, #ffffff, #303e45, #303e45, #303e45, #212b30, #f9f9f9, #212b30, #a70b06, #3d4e57, #ffffff, #3f3f36, #ffffff
disabled_colors=#4b616c, #29353b, #303e45, #303e45, #303e45, #303e45, #4b616c, #ffffff, #4b616c, #303e45, #303e45, #303e45, #212b30, #4b616c, #212b30, #a70b06, #3d4e57, #ffffff, #3f3f36, #ffffff
inactive_colors=#ffffff, #29353b, #303e45, #303e45, #303e45, #303e45, #ffffff, #ffffff, #ffffff, #303e45, #303e45, #303e45, #212b30, #f9f9f9, #212b30, #a70b06, #3d4e57, #ffffff, #3f3f36, #ffffff

grafik

grafik

grafik

+ /home/$USER/.config/qt5ct/qss/dolphin.qss

DolphinViewContainer > DolphinView > QAbstractScrollArea {
      background-color: #29353b;
}

Could be improved or there could still be errors.
I like it so far :slight_smile:

Hello,

sorry to revive this old thread but applying the settings recommended here, I have observed some strange behavior.
When I start Dolphin from a terminal with dolphin -stylesheet ~/.config/qt5ct/qss/dolphin.qss, the stylesheet settings are applied as expected.

However, appending this -stylesheet ~/.config/qt5ct/qss/dolphin.qss suffix to the xfce starter does not seem to have any effect. Dolphin then shows a white background (which seems to be its default background color), ignoring the stylesheet settings.

Looks like the xfce starter ignores abbreviations such as ~ for the current user's home directory. I had to provide the full path (/home/{username}/.config/qt5ct/qss/dolphin.qss instead of ~/.config/qt5ct/qss/dolphin.qss) there in order to make it work.

You might test with this instead:

$HOME

See what it gives

echo $HOME
1 Like

Forum kindly sponsored by