How to change/save default monitor configuration?

I moved to the AMD platform from Intel and since Ryzen 9 doesn't have in chip VGA, I had to install a 2nd one. However, due to watercooling, I have my (gaming/VM/passthrough) VGA on slot 1, and my desktop VGA on slot 3. The problem therefore is, that when system boots, I have to switch my monitor to the "gaming" input, enter my password, and then, after it loads the user, switch to "desktop" input and work.

Is there a way, to save my configuration as the default, where the desktop VGA outputs are the default ones for all users and use it at boot time?

Below my hd output for your reference:

System:
  Host: amd-manjaro Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 10.1.0 Console: tty 1 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Micro-Star product: MS-7C35 v: 2.0 serial: N/A 
  Mobo: Micro-Star model: MEG X570 UNIFY (MS-7C35) v: 2.0 
  serial: Kxxxxxx UEFI: American Megatrends v: A.40 date: 07/11/2020 
Battery:
  Device-1: hidpp_battery_0 model: Logitech G603 Wireless Gaming Mouse 
  charge: 100% (should be ignored) status: Discharging 
CPU:
  Topology: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP 
  arch: Zen L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 182455 
  Speed: 3599 MHz min/max: 2200/3800 MHz Core speeds (MHz): 1: 3599 
  2: 3598 3: 2102 4: 1983 5: 3596 6: 3589 7: 2057 8: 2058 9: 3777 
  10: 2091 11: 2199 12: 2203 13: 2056 14: 2200 15: 2804 16: 1974 17: 2132 
  18: 2114 19: 3715 20: 2119 21: 2200 22: 2199 23: 2199 24: 2814 
Graphics:
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: eVga.com. 
  driver: nouveau v: kernel bus ID: 2d:00.0 
  Device-2: AMD Baffin [Radeon RX 550 640SP / RX 560/560X] 
  vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 2e:00.0 
  Display: server: X.Org 1.20.8 driver: amdgpu,nouveau FAILED: ati 
  unloaded: modesetting resolution: 2560x1440~60Hz, 1920x1200~60Hz 
  OpenGL: renderer: NV132 v: 4.3 Mesa 20.1.3 direct render: Yes 
Audio:
  Device-1: NVIDIA GP102 HDMI Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 2d:00.1 
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] 
  vendor: Sapphire Limited driver: snd_hda_intel v: kernel 
  bus ID: 2e:00.1 
  Device-3: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 30:00.4 
  Device-4: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-2.1:4 
  Device-5: Creative Sound BlasterX G6 type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-3:3 
  Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries NetXtreme BCM5751 Gigabit Ethernet 
  PCI Express 
  driver: tg3 v: kernel port: N/A bus ID: 25:00.0 
  IF: enp37s0 state: up speed: 1000 Mbps duplex: full 
  mac: 00:10:18:1b:59:6c 
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 
  v: kernel port: f000 bus ID: 27:00.0 
  IF: enp39s0 state: down mac: 2c:f0:5d:3b:8b:df 
Drives:
  Local Storage: total: 11.14 TiB used: 1.17 TiB (10.5%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB 
  size: 465.76 GiB 
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO 250GB 
  size: 232.89 GiB 
  ID-3: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB 
  size: 232.89 GiB 
  ID-4: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB 
  size: 465.76 GiB 
  ID-5: /dev/sdc vendor: Toshiba model: HDWE140 size: 3.64 TiB 
  ID-6: /dev/sdd vendor: Toshiba model: HDWE140 size: 3.64 TiB 
  ID-7: /dev/sde type: USB vendor: Western Digital 
  model: WD30EZRX-00DC0B0 size: 2.73 TiB 
RAID:
  Hardware-1: Advanced Micro Devices [AMD] Device driver: ahci v: 3.0 
  bus ID: 2b:00.0 
  Hardware-2: Advanced Micro Devices [AMD] Device driver: ahci v: 3.0 
  bus ID: 2c:00.0 
Partition:
  ID-1: / size: 123.50 GiB used: 11.00 GiB (8.9%) fs: ext4 
  dev: /dev/nvme1n1p3 
  ID-2: /home size: 72.24 GiB used: 1.07 GiB (1.5%) fs: ext4 
  dev: /dev/nvme1n1p4 
  ID-3: swap-1 size: 32.00 GiB used: 121.5 MiB (0.4%) fs: swap 
  dev: /dev/nvme1n1p2 
Sensors:
  System Temperatures: cpu: 40.2 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: amdgpu temp: 45 C fan: 1005 device: nouveau temp: 27 C 
  fan: 0 
Info:
  Processes: 490 Uptime: 2h 49m Memory: 7.76 GiB used: 5.58 GiB (71.9%) 
  Init: systemd Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18 inxi: 3.0.37 

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by