How to check if driver exists? [Solved]

Here are results. I was not able to post in text form without internet, so made a photo.
photo_2019-05-02_12-04-23

Do not have any other network components running during the test. Shut the phone connection down and all other network related devices. Then shut off the computer.

Then start the computer..

Run the set of commands below to see if your connection can be properly initiated.

Please do not cut and paste all the commands together at once.

Paste each command separately with a few seconds between running each command.

Please do not give me a summary, such as "there were no outputs".

It is very important that you post each input and output for troubleshooting purposes.

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set wlp4s0b1 down

sudo rmmod bcma

sudo rmmod b43

sudo modprobe b43

sudo ip link set wlp4s0b1 up

sudo systemctl start NetworkManager

nmcli networking on
 
nmcli r wifi off

nmcli r wifi on

Once those commands have all been run you can start your phone hotspot if you have no other access point. Please post all inputs, and all outputs of that sequence of commands once they are finished being run.

Once all the above commands have run, then run these two commands and post the input/outputs.

ping -c5 8.8.8.8                                                                                

ping -c5 google.com

I don't understand why do you have no other wifi access yet you want a wired connection. What way are you intending to connect to the internet with this laptop.

I actually have wifi router but in current state my laptop can connect only to my iPhone hotspot. And main way I plan to connect to internet is wifi. Ability to connect over wire is just for situations like this when wifi is not available. Here is again photo with results. After all commands ran I can't connect even to iPhone.
photo_2019-05-02_13-53-42

I posted this earlier, but it was lost when the forum server went down. Reverse these two commands order:

Change these two commands order to this:

sudo rmmod b43

sudo rmmod bcma

leave the rest of the sequence the same.

So you are using a USB cable to connect to to your phones wifi hotspot. Is that correct?

I'm using my iPhone wifi hotspot without usb cable. For whatever reason this driver allows to connect to it but can't connect to wifi router constantly asking for password. I saw other guys posted same issue on forum. And they were able to fix it replacing the driver.
Here are results from next run:

photo_2019-05-02_14-21-47

You know that was not something I assumed was the case. It seemed your driver was not working. That is not the case at all, your wifi is working, you are just unable to connect to your router.

That is a very different scenario. You never mentioned anything about being able to contact your router, but being unable to connect with your password.

Have you installed kernel 5.0 or 5.1.

Sorry for not being clear. I haven't installed any other kernels. I have flash drive with Manjaro distribution with kernel 4.19

So you do not have Manjaro installed?

Are you saying you're running from a live install.

No-no-no. I've installed it from flash drive

In the guide I posted the link to it specificaliy says to install the 2 newest kernels. So you obviously never followed the guide very carefully.

Does your router use a hidden network.

Can you connect to your router from your live boot thumb drive when running off of it.

Maybe I've missed that part. Can't find info about kernels even now when skimming through the doc. Anyway, here are more details. I can't connect to my router from live boot thumb drive. It behaves in the same way: constantly asking for password. And I've checked password a couple of times. And my router doesn't use a hidden network.

OK before we go off on a different tangent you need to try to connect to your router. Can you see the router and attempt to connect to it with the b43 kernel module you are currently using. Is it giving you the same repeated password request.

Do you mean I have to try to connect to my router after all our testing steps? Or should I reboot laptop and try to connect to my router?

Do this first.

Select your wifi connection in Network Manager and apply these settings:

“All users may connect to this network”

“Automatically connect to this network when it is available”

“Store password for all users (not encrypted)”

Then, reboot.

After rebooting your computer, try to connect to your router.

I don't see this option in the network settings

Right click over the wifi icon in your system tray.

Select "Configure Network Connections" from the menu.

Select the wifi connection you wish to connect to from the list on the left.

Then select your wifi connection "WI-FI Security" tab on the right side.

Below the password entry field is a drop down selection box.

Click the drop down box and choose the middle option:

"Store password for all users (not encrypted)"

Click the "Apply" button, then click "OK" to exit.

Then, reboot.

Thanks. I've tried. I still can't connect to my router.

You need go start remembering that I'm not there to see what's happening. You need to start providing more accurate information for me to be able to help you resolve issue.

  1. Can you see networks in your vicinity.
  2. when you attempt to connect what happens.
  3. Can you connect briefly, but connection drops.
  4. Is this a fresh Manjaro install
  5. Have you fully updated your system.
  6. Which wl drivers have you tested
  7. Which kernels have you tested
  8. Are you using a VPN or a Virtual Machine.
  9. Have you tried turning off password encryption on your router to see if you can connect.

You really, really, need to read this:

Please post the entire output of:

inxi -Fxxxz

Now I'm not changing anything without you request.
Responses to your questions:

  1. Yes
  2. It keeps asking for password in cycle
  3. No
  4. Yes
  5. No, my iPhone hotspot limiting size of the download, so I can't download all updates.
  6. I'm not sure. Seems like we were not able to change driver and current driver is bcma
  7. 4.19
  8. No
  9. I've just removed password on my router and after that I don't have authentication screen pop-up and just can't connect to router.

I've rebooted router and laptop.
Here is result of running that command:

[sergey@sergey-mac ~]$ inxi -Fxxxz
System:    Host: sergey-mac Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: i3 4.16 info: i3bar 
           dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro10,1 v: 1.0 serial: <filter> Chassis: type: 10 
           v: Mac-C3EC7CD22292981F serial: <filter> 
           Mobo: Apple model: Mac-C3EC7CD22292981F v: MacBookPro10,1 serial: <filter> UEFI: Apple v: 251.0.0.0.0 
           date: 09/21/2018 
Battery:   ID-1: BAT0 charge: 63.5 Wh condition: 64.5/92.2 Wh (70%) volts: 12.4/10.9 model: SMP bq20z451 type: Li-ion 
           serial: N/A status: Full cycles: 467 
CPU:       Topology: Quad Core model: Intel Core i7-3720QM bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41524 
           Speed: 1197 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1197 2: 1198 3: 1197 4: 1197 5: 1208 6: 1197 7: 1198 
           8: 1198 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Apple driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0166 
           Device-2: NVIDIA GK107M [GeForce GT 650M Mac Edition] vendor: Apple driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:0fd5 
           Display: x11 server: X.Org 1.20.3 driver: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: compton resolution: 2880x1800~60Hz 
           OpenGL: renderer: NVE7 v: 4.3 Mesa 18.2.5 compat-v: 3.1 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:1e20 
           Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e1b 
           Sound Server: ALSA v: k4.19.2-1-MANJARO 
Network:   Device-1: Broadcom Limited BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme driver: bcma-pci-bridge v: N/A 
           port: 2000 bus ID: 04:00.0 chip ID: 14e4:4331 
           IF-ID-1: wlp4s0b1 state: down mac: <filter> 
Drives:    Local Storage: total: 465.92 GiB used: 5.32 GiB (1.1%) 
           ID-1: /dev/sda vendor: Apple model: SSD SM512E size: 465.92 GiB speed: 6.0 Gb/s serial: <filter> rev: 9A1Q 
           scheme: GPT 
Partition: ID-1: / size: 457.41 GiB used: 5.30 GiB (1.2%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 65.0 C mobo: N/A gpu: nouveau temp: 64 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 199 Uptime: 45m Memory: 7.70 GiB used: 436.7 MiB (5.5%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: urxvtd inxi: 3.0.27 
[sergey@sergey-mac ~]$ 

Forum kindly sponsored by