How to completely uninstall/disable Nvidia and use Intel HD graphics instead

Hello everyone here! I am beginner in desktop Linux and liked manjaro distributive. All worked fine out of the box, but i changed some of Nvidia drivers and it fails to launch desktop now

I have read some articles here, but solutions worked bad for me.
So i want to return graphics situation to factory settings, like it has been before my crabby hands.
And I don't want to reinstall distributive of course :slight_smile:

Now i try to describe my situation more:

My pretty desktop doesn't launch, if i manually put "startx" command it will display in logs "displays not found"

Here is my mhwd output:
15969714491431502602542677761510

And inxi -Fx output(i cropped it):

IMG_20200809_141408
Nvidia geforce 610m and intel HD graphics
Laptop model: "Lenovo, ThinkPad edge E330" if necessary

Also configuration files of xorg:

ls /etc/X11/xorg.conf.d
00-keyboard.conf  10-optimus-manager.conf

So, here i have to change optimus to intel, haven't i?

I installed bumblebee from gui installation manager, and problem appeared after reloading

I tried to find out my problem, but i think removing will be faster and better way to fix this problem(my laptop is not gaming solution, actually. So i installed linux only to reduce windows lags)

Also excuse me if i didn't give much information, and excuse for English grammar problems

Thanks for your answers, and for good linux distributive

Assuming you need 390 and bumblebee .. lets get rid of OM.

sudo pacman -Rns optimus-manager
sudo rm /etc/X11/xorg.conf.d/10-optimus-manager.conf
sudo pacman -f -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Though .. I would prefer to see specifically

mhwd -li && mhwd -l

As bumblebee isnt really desired ... PRIME is preferred .. but then again, nvidia randomly drops support for cards so its possible yours simply isnt able to.

Yes, i typed all your commands, but third didn't work, there is some error with dependencies
15969752802567442004669672345307

And mhwd output:15969753488441232462394628911227

pacman failing is not good ... I guess you dont have network access ?
(you can check with something like ping duckduckgo.com -c3)

Duckduckgo is not pinging, that strange

However i tried to ping other domain and it worked
Kernel.org also works fine

And i think it's dependencies error

Also i noticed that 90-mhwd.conf has red colour in ls output

I finally found my solution
I just changed word "Nvidia" to word "Intel" :laughing:
Changed file /etc/X11/xorgs.conf

But general question still remains.
What about Nvidia drivers if i don't need them?

Are there some glitches, or it will be just unused?
If it is unused, our discussion is closed

Where can i watch drivers loaded now and priority?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by