How to enable sleep mode with tlp package?

hey there,

I'm completely new to the linux world and I'm already sorry for this more than naive question. I'd be happy to receive any kind of critique.
I just installed Manjaro and would like to go to sleep. I also want my Laptop to sleep and tried to download tlp.
Now I do get prompted:
"Error: target not found: tlp"

I know it's horribly easy. Any help though is highly appreciated!!
Happy to have moved and exited to get started with Manjaro;)

What did you do exactly? tlp is in the repos.
You may want to sync your mirrors and do an update before installing software though.

Aside from that - tlp is most likely installed and running by default.
You can check with something like
systemctl status tlp

Most likely you just need to set your sleep preferences in your desktop settings. Which desktop do you use ? A command to share system info would be:

inxi -Fxxxza --no-host


thank you so much!!
I really think I need to read a little more before starting to as questions here. I don't even know for sure what "mirrors" are:/

Checking the system status gives me:

Unknown operation status

And apparently my desktop, after running you command is:

Xfce 4.14.1

I'm really sorry for these uninformed questions:(
Sorry to steal your time

You can install tlp and tlp-ui from the repo.

sudo pacman -Syu tlp tlp-ui

If you are using a laptop and wireless - special considerations must be taken

sudo pacman -Syu tlp-rdw

Usually tlp is installed but you may need to activate it.

sudo systemctl enable --now tlp.service tlp-sleep.service NetworkManager-dispatcher.service

To ensure proper functionality of tlp you also need to disable and mask the service systemd-rfkill.service and the socket systemd-rfkill.socket

Please have a look at the comprehensive TLP page at the Arch Wiki

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by