[How To] Flash new keyboard/touchpad firmware on Pinebook Pro

The default firmware in the keyboard and touchpad of the Pinebook Pro has been troublesome for some people.

So in late November 2019 Pine64 released a firmware flashing tool that will update the firmware inside the keyboard and touchpad hardware of the Pinebook Pro.
And we have packaged it up, so it's easy to install and use.

  1. Install the package: sudo pacman -S pinebook-pro-keyboard-updater.
  2. Run the first step: sudo updater step-1 iso or sudo updater step-1 ansi depending on the model of Pinebook Pro you have. If it does not succeed, please run the command again.
    This step is complete when the terminal outputs:
[*] Finished succesfully!
>>> release interface
[*] Please reboot now, and run `step-2`.
  1. Reboot (be aware, touchpad won't work at this stage)
    Connect an external keyboard if you have an ANSI Pinebook Pro as that would loose keyboard functionality aswell.
  2. Run the second step: sudo updater step-2 iso orsudo updater step-2 ansi. If it does not succeed, please run the command again.
    This step is complete when the terminal outputs:
[*] Finished succesfully!
>>> release interface
[*] All done! Your keyboard and touchpad should be updated.
  1. Reboot again.

Known issues:

  • Some have mentioned they had to do Step-1 and Step-2 multiple times before it worked.

Also see the README for more information.

EDIT: Updated info for version 0.0.2


I get this when trying to run step -1, after updating and rebooting:

Running STEP-1...
[*] Flashing keyboard updater firmware...
>>> Fix hex file
[*] Opening in user mode...
>>> Trying to open VID:258a PID:001e...
>>> Kernel Driver Active
[*] Sending command to switch to boot mode...
[*] Command send
>>> release interface
[*] Opening in boot mode
>>> Trying to open VID:0603 PID:1020...
>>> Device not found
>>> Trying to open VID:0603 PID:1020...
>>> Device not found
>>> Trying to open VID:0603 PID:1020...
>>> Device not found
>>> Failed to open in boot mode

EDIT: after the 3rd or 4th attempt step-1 succeeded. Step-2 also took a few tries. It appears faster typing is still a no-go, in case anyone was wondering. (I had to correct every word used in this post that has repeated letters. The trackpad feels more responsive, though.) I had Bounce Keys on (not sure why.)

How would I know if it had worked as intended?

It's different, but both step-1 and 2 have messages that denote completion. step-1 ends with a message to reboot, step-2 doesn't say to reboot, but its message does tell you when it's done.

Please see Ayufan's github page of the script for how-to and outputs: https://github.com/ayufan-rock64/pinebook-pro-keyboard-updater#update-all-firmwares
@Strit, great work! Thank you! Will try it today's evening.

Added completed messages guide to the steps in the original post. So people will know when it's safe to reboot.

1 Like

step-2 is giving me problems. More than 6-7 attempts and what I get is just

>>> Verify mismatch: type=f2, pass=e2, received=d5
>>> Touchpad verify (type=242, pass=226) data failed
>>> Touchpad erase failed
>>> release interface

Lets see which attempt will do the trick

Well, it completed step-2 on the first try from tty2. For comparison, it didn't complete successfully after 5-10 attempts from KDE (fresh Preview 4 install).

All good now!

1 Like

Worked smoothly from the first try. Thanks for this!

P.S. with preview 4

1 Like

In my experience, it works best:

  • on a text-mode console (tty2)
  • while as few things as possible are plugged into the USB ports (USB-C, USB2 USB3

i tried it today, everything worked for the first time, thanks again :slight_smile:

I am on the latest release. However, step 2 took about 5 attempts. I think it would be wise to remove any USB mouse before rebooting.
I observed that the first 4 attempts didn't work as the USB mouse was plugged in and I unplugged it for the 5th attempt.

Hi All - Curious about how effective this was.
I've flashed this about 5 times now and it always tells me it has worked, however I still get the mouse jumping around when typing.

Is this just the way it is or did it become "perfect" after the flash?

Pinebook pro from Nov batch ANSI keyboard, running Manjaro (fully updated) on emmc internal.

Hello all,
My new pinebook pro turned up today and having flashed manjaro kde to the emmc I decided the trackpad was slow and sluggish. So I tried the above advice by installing the keyboard updater.
Despite having tried step 2 several times, I had no trackpad. (External mouse doesn't work either.)
I then flashed manjaro xfce to the emmc and now I have no keyboard and no trackpad!!! (Although the system boots into xfce.)

Can anyone kindly suggest how I can rectify my mistakes and get my keyboard and trackpad operational again? I'd really appreciate some help.


You need to keep trying to flash the firmware with the tool until it says it's successful.

External USB keyboard should still work without the firmware installed.

I managed it. Thank you!

1 Like

Is is just me or does the cursor still jump around randomly after the firmware update?

I ran the ayufan Debian updater successfully upon receipt of the PBP (November 2019), then changed OS to Manjaro ARM. Trackpad behaviour was certainly improved over the out-of-the-box experience, but typing was always a problem because the cursor would often jump to previous lines, or previous positions on the same line. Very tiresome.

I've just done a clean install of Manjaro ARM 20.04 and thought I'd run @Strit's "native" firmware updater, as per the instructions in this thread. I had high hopes for a miracle, but am disappointed: the cursor still jumps around to random positions on the page. Depending on what work I'm doing, the Pinebook Pro borders on being unusable.

I'm surprised that more people are not reporting bad cursor control, which makes me wonder whether it's just me. I've written to Pine64 and posted to forums there but never received a satisfactory response (and sometimes none at all).

Any suggestions on what I can try next, or am I SOL?


Try the alternative firmware? I had thought it was only for customized keymaps, but I just saw this:

Bonus : the trackpad now works a lot better too!!


I'm experiencing the same problem. It seems a lot of people aren't complaining because they disabled the touchpad and use a mouse. Ok, but this is a thin and light laptop!

EDIT: I followed that post to update my keyboard/touchpad firmware just after I posted this. I had previously updated using the official firmware. Hours after flashing Jack Humbert's revised firmware, I can say it solves the issue of accidental touchpad touches causing the cursor to jump! I've been typing quite a bit and have had zero cursor jumps whereas before it happened about every other sentence. The firmware update also allows the Pine key to be used in combination with other keys like the arrows so overall it's a dramatic improvement to the usability of the computer!


Thanks, @damon. I've applied the new firmware patches but have encountered another (unrelated) problem. Updating the mirror list for 20.04 has caused a boot problem and my Pinebook Pro won't boot anymore :frowning:

I'll report back here on trackpad performance when I get the machine back online.

Did you remember to edit the /boot/extlinux/extlinux.conf file as mentioned in the update threads for the last month?

Forum kindly sponsored by