How to install Arch on btrfs with systemd boot

Hi, I am trying to install Archlinux with btrfs and systemd-boot. I have tried every solution online still getting the attached error. Any solution?

Mount: /new_root: unknown filesystem type 'btrfs'.
You are now being dropped into an emergency shell.

I have edited /boot/efi/loader/entries/arch.conf every way possible, still same result.

For technical issues on Arch Linux, wouldn't it be better to ask your questions on the Arch Linux official forum?

1 Like

This has been my community from a very long time. So, whenever I hit a deadlock(after exhausting available online resources) I come here first and most of the time problem is solved. That is why I don't post there. Have a good day.

Did you add "btrfs" to the hooks section in /etc/mkinitcpio.conf ?
Here's mine:

HOOKS=(base udev autodetect modconf block encrypt btrfs filesystems keyboard fsck)

But next time remember to post in the correct category #other-os :slight_smile:
Or you can try to install Manjaro the CLI way. Then you can post in the Manjaro parts of the forum.

I think you need the btrf in the MODULES array of mkinitcpio.conf - maybe also in HOOKS but I don't think that is necessary.

Did you compress the file system? I don't know if systemd-boot supports booting from a compressed btrfs file system.

Yes, I have done that.

I haven't added it in the modules. Let me try that.

Is adding compress=lzo in the mounting the problem?

Compression works just fine for me...

@Alpha , this is the guide I followed when installing my system:

I have a learned a lot by dissecting relevant parts of manjaro-architect.

I would try making an install using btrfs - then dissect the resulting - hopefully working root partition and note how the selected bootloader is configured.

I just used your provider guidelines to install again. Same result.

Is there any way I can boot into the fall back kernel from systemd-boot?

do you have btrfs-progs installed?

Yes, I have installed it with base.

Would your way to install work if you choose a different filesystem? Can you try it?
Because I believe it is a user error during installation.

Alternatively you can installl Grub and see if that would boot your system from btrfs.

I have reinstalled the whole system using the guidelines provided by @TomZ. I wanted btrfs because of its root restore feature.
i will go back to ext4 if at the end I can't fix this.

I would recommend to try Grub, I don't see any need for systemd-boot.

1 Like

i also recommend grub
with addition of

I see no other options. Thanks everyone for the help.

I have just tested the mentioned guide - it works - no problem.

I have rewritten parts of it to fit Manjaro - and it works too.

1 Like

Forum kindly sponsored by