How to install NVIDIA Driver and how to switch between intel/nvidia gpu

I just installed and use Manjaro Gnome 18 today from the website and boot with nonfree driver option
I dont know how to switch between intel and nvidia gpu, i tried to search but dont know why i cant install video-nvidia driver, but can only install video-hybrid-intel-nvidia-bumblebee. This is my screenshot
Screenshot%20from%202019-09-24%2015-42-14
I found this topic and want to choose optimus-switch method but fail when try to install nvidia-driver as the screenshot above
This is my system information, if i'm not wrong, my NVIDIA driver is N/A means it is not installed

[longlp@longlp-pc ~]$ inxi -Fxzc0
System:    Host: longlp-pc Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           Desktop: Gnome 3.32.2 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Precision 5520 v: N/A serial: <filter> 
           Mobo: Dell model: 06P8M1 v: X00 serial: <filter> UEFI: Dell v: 1.16.0 date: 07/26/2019 
Battery:   ID-1: BAT0 charge: 59.4 Wh condition: 78.2/97.0 Wh (81%) model: SMP DELL GPM0365 
           status: Discharging 
CPU:       Topology: Quad Core model: Intel Xeon E3-1505M v5 bits: 64 type: MT MCP arch: Skylake-S 
           rev: 3 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944 
           Speed: 801 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 800 2: 801 3: 800 4: 801 5: 801 
           6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel HD Graphics P530 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM107GLM [Quadro M1200 Mobile] driver: N/A bus ID: 01:00.0
           Display: x11 server: X.org 1.20.5 driver: N/A resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics P530 (Skylake GT2) v: 4.5 Mesa 19.1.5 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:   Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 953.87 GiB used: 12.08 GiB (1.3%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 953.87 GiB 
Partition: ID-1: / size: 197.31 GiB used: 12.08 GiB (6.1%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: swap-1 size: 30.52 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 44.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2466 fan-2: 2482 
Info:      Processes: 237 Uptime: 33m Memory: 15.51 GiB used: 1.67 GiB (10.8%) Init: systemd Compilers: 
           gcc: 9.1.0 Shell: bash v: 5.0.9 inxi: 3.0.36 

Im a new comer from ubuntu to arch, it will be precious for me if you guys can ELI5 about my issues.

Have you taken a look at this guide? :arrow_down:

1 Like

AFAIK the Quadro M1200 is not an Optimus card.
https://www.geforce.com/hardware/technology/optimus/supported-gpus
It might work like this if want to use simultaneously two external video ports - HDMI and thunderbolt:
https://wiki.archlinux.org/index.php/Bumblebee#Output_wired_to_the_NVIDIA_chip

Maybe you succeed with the above mentioned method.

1 Like

I tried this solution but when i switch, but it won’t boot into graphical session.

As @bogdancovaciu said, the Quadro is not an Optimus adapter.

Device-2: NVIDIA GM107GLM [Quadro M1200 Mobile] driver: N/A

Looks like you haven't installed the proper driver for it. As far as I know, the Quadro series of graphics adapters use other drivers than consumer-grade Nvidia adapters do.

Now, I don't have any Nvidia hardware in this machine, so I don't know whether the Quadro-specific drivers would be in the repository, but if they're not, then you might find them in the support section on Nvidia's website. :thinking:

2 Likes

because the way nvidia packages are labeled was recently changed. the commands you want are

#remove currently installed drivers first
sudo mhwd -r pci video-linux
sudo mhwd -r pci video-hybrid-intel-nvidia-430xx-bumblebee

#install the needed drivers
sudo mhwd -i pci video-nvidia-430xx

the instructions you should be following are here

when fumblebee is used it unloads the nvidia driver when there is nothing running on the nvidia card so it shows n/a, thats normal.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by