How to install nvidia driver for secondary GPU on laptop

I "repaired" the tutorial, after this possible "human" error was discovered.:wink:

Another option is a keyboard or panel shortcut, as was proposed by @tbg a while ago.

1 Like

is there a special way of restarting the compositor?

I guess it's restarting kwin that does the job.
I"ll try to find the command, if you don't have it already..

kquitapp5 plasmashell
kstart5 plasmashell

kquitapp5 plasmashell ; sleep 1 ; kstart5 plasmashell & exit
this seems to work as intended

1 Like

something i do notice now that was not an issue i had a week ago (last time i used kde) as @kik4444 also noticed was the graphical glitch where typing in the terminal has a transparent line under it. hmmm.... i miss my openbox, i dont have these issues :smirk:

Ok so I've restarted from scratch, this time I didn't make any mistakes on the bus ID and Xsetup, and now it runs fine, I didn't even need to mess with grub and systemctl

2 Likes

good, so your one of the lucky few that dont need kernel parameters to boot your optimus laptop. :sob:
hows the compositing? scaling?

that change i mentioned to nvidia.conf actually tamed all the crazy settings i had to make to fonts/scaling/browser text size. before changing others i would add that first and reboot.

the graphical glitches i just noticed today as you have also, seem to be fixed with opengl 3.1 and full screen repaints
spoke too soon, the only thing that fixes the "hd static" seems to be logout/login of desktop. (or reboot as i used to do with kde after suspend). either way it's annoying and its been an issue for a while now. alternatively i can just restart latte-dock which is effected the most by suspend, moving the mouse over the icons does fix the icons but the spacers remain "hd static".
ok well for me this concludes the amount of life im willing to waste on kde. back to openbox it is for me. dont get me wrong, i like kde, i just like OB better :grin:

Yeah the problem with the static text on the desktop is still present after resuming, even though this time I didn't get a KWin notification

Try this after changes and/or plasma5 restart

qdbus org.kde.KWin /KWin reconfigure

And how about "Solving" this topic?
I suggest you mark this as solution, or the one that @dglt suggested PRIME setup.

Yeah that is technically what ended it all.

Interestingly enough, if I try to rename the things on the desktop, but enter the same name, the "static" disappears, and so far that's the only problem I've noticed.

1 Like

what about my growing reputation of painfully long help threads? :rofl: like this one for example. :fearful:

1 Like

Our DMs are technically under 100 messages :+1:

now you can wipe the other backup and back this one up. no need to keep a flawed backup.

also, it would be cool if you could do some real world battery life comparisons between bumblebee and prime, theres a lot of mixed opinions on the matter but not many facts. just an idea, i think alot of people would be interested in that

Luckily for you, I solved the screen corruption after resume issue a few days back. It literally took me months to figure out the solution using a systemd user service..

Create:

~/.config/systemd/user/plasma-restart.service

Systemd plasma-restart.service file contents:

#~/.config/systemd/user/plasma-restart.service
#systemctl --user enable plasma-restart.service
#systemctl --user start plasma-restart.service
#systemctl --user status plasma-restart.service
#systemctl --user stop plasma-restart.service
#sudo loginctl enable-linger <username>
#systemctl --user daemon-reload
#systemctl --user daemon-reexec 
[Unit]
Description=Restart plasmashell after resuming
After=suspend.target
StopWhenUnneeded=yes

[Service]
User=root
Type=oneshot
RemainAfterExit=yes 
ExecStart=/usr/bin/sudo -u $USER /bin/bash -lc 'kquitapp5 plasmashell'
ExecStop=/usr/bin/sudo -u $USER /bin/bash -lc 'plasmashell > /dev/null 2>&1 & disown; sleep 2; exit'

[Install]
WantedBy=sleep.target

Enable the plasma-restart.service:

systemctl --user enable  plasma-restart.service

Reboot.

2 Likes

Well so far there is one problem that's probably resulting from the optimus drivers, since I've never had this problem before - occasionally when I boot up my laptop, it won't show my battery. I have the battery icon in the system tray, but when I hover over it it says "no batteries available", and clicking it indeed doesn't show a battery, however I do obviously have a battery that inxi -Fxxxz manages to detect.

EDIT: I should add now however, that after a while it does show a battery when I hover over the icon, but sometimes it still doesn't show it when I click over the battery icon in the system tray

EDIT2: Other than that, I still haven't used my laptop enough after making the switch to decide whether the battery is noticeably worse, however it kinda feels like my laptop's faster, which is weird since normally my nvidia gpu isn't necessary for non-game usage to feel snappy

EDIT3: Ok so after starting my laptop, it was at 86%, now however, 30 minutes later, it's at 70% battery, and every time I look at it it's dropped by several percent at once.

EDIT4: I was using my laptop in class and I literally had to restore my snapshop back to bumblebee's, cause I was afraid at this rate my battery wouldn't last another hour. Right before the restore process my battery was at 70%, now after booting into the old snapshop it's 61%.

1 Like

a perfect example of how useful snapshots can be. aside from that though you should do some battery life benchmarking from a full charge , once on prime and again on intel. since you really need every little drop of battery life possible, you may benefit more from optimus manager (tutorial) .

if you decide to try it, restore the nvidia prime snapshot first so you wont have to deal with any of the bumblebee conflicts we spent some time figuring out, this would also be better since it would keep snapshots in order bumblebee>>prime>>optimus-manager. make sure you remove any/all files/configurations made during the prime tutorial first before anything else and then follow the optimus-manager tutorial very carefully. if you run into any issues you cant figure out, create a new thread since this one is solved.

with nvidia-prime you can try this to avoid running nvidia gpu:

  • one xorg conf for intel/modesetting
  • another one for nvidia gpu
  • create a script that:
    for intel:
  • disable/blacklist nvidia modules (if they still get loaded when blacklisted disable them)
  • also blacklist nouveau modules if you have them installed (probably not)
  • symlink the correct config to /etc/X11/xorg.conf.d
    for nvidia:
    same as above just load the nvidia modules and symlink the correct xorg.conf

That seems to work for me, because if I check enabled value of nvidia gpu in sysfs it shows 0 if I'm not using nvidia and dont have nvidia modules loaded. If I'm using nvidia it shows 1. It also shows 1 if I use intel with loaded nvidia modules (for switching without reboot)

1 Like

19 posts were split to a new topic: Vetzki's PRIME tutorial discussion

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by