How to load manjaro on Grub command line?

What other bootloader did you install before rebooting?

I'm pretty sure that's no "terminal" (as in linux commands work there) but some (grub?) rescue shell.
Easiest way to fix would be to get grub back:

  • boot from usb
  • chroot into your existing installation
  • reinstall grub

I don't have a bootable usb with manjaro but I have a windows 10 bootable usb.
I didn't install any bootloader before rebooting.

I managed to boot TinyCore on my laptop. What can I do with it?

Perhaps downloadig a Manjaro .iso file and making a bootable usb.

1 Like

My bandwidth is really low so I can only download 500 mb isos and I flash them using an app on my phone.

If you get grub command line grub> try the method described in the following link and see if you can boot into your Manjaro install (skip the step for booting up live cd/usb):

Maybe you could chroot to your Manjaro install from TinyCore as well and then re-install grub. See if the manual chrooting method in the following link works for you:

https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

I tried super grub 2 and got to this.
IMG_20200308_181511
What should I click?

I would try the first or second option from the top.

When I choose the first or the second, It loads up all the files (like when I boot manjaro from the usb) and just shuts down the display (I know this because my USB keyboard is still on)

Sorry, I have no more ideas than perhaps using your TinyCore, chrooting manually as per description in the link previously posted and restoring grub following the instructions in the same link.

It says chroot: can't execute '/bin/sh': Exec format error

Admittedly you would need to be assisted by a more experienced user than I. On that note, I withdraw and wish you good luck in restoring your system.
:crossed_fingers:t3:

Yeah, I think I'm gonna wait for another user to help me. On a different note however, I tried Slitaz and is now trying to install grub on this.

Thank you and so long!

1 Like

Thank you for the help!

1 Like

Try this using an Arch ISO (usb or dvd- whichever works for you)

Boot ISO

(#) lsblk (to verify and identify partitions)

(#) mount /dev/sdXX /mnt (where XX= OS partition)

(#) mount /dev/sdXX /mnt/home (where XX= home partition)- if used

(#) swapon /dev/sdXX (where XX= swap partition)- if used

(#) arch-chroot /mnt /bin/bash

(#) pacman -Sy

(#) pacman -S grub

(#) grub-install /dev/sdX (where X= system drive)

(#) grub-mkconfig -o > /boot/grub/grub.cfg

(#) pacman -S os-prober

(#) exit

(#) umount -R /mnt

(#) poweroff

Remove USB

Boot

Note: Probably no need for mounting /home or enabling swap- just making the road wide as possible to avoid the unforseen.

1 Like

I suggest you try again Marte's link.
You did not say you have tried it except that you used supergrub.
Use [Kernel Boot Method] as your grub is kaput by installing TinyCore.
That will also erase your firmware efi boot entries.

And if you have any problem, needless to say (but I'll say), what is the command and what is the error message.

I'm gonna try that when my bandwidth refreshes. Thanks for the tip!

Okay I'm gonna try that tomorrow.

That should do it if nothing else is FUBAR. Arch will at least be OS compatible. Keep us posted. Good luck.

Forum kindly sponsored by