How to make fallback boot the default?

I've been evaluating Manjaro KDE for some weeks, and have so far run into several different boot problems where the GRUB fallback initramfs option worked but the default boot option would not. One was the subject of an earlier question and the underlying problem was solved. I currently have an open question on the new problem. It's always nice to solve the underlying problem, but a solution that isn't sensitive to this range of issues simply avoids them.

Is there a way to make the fallback initramfs option the default in GRUB?

1 Like

In your /etc/mkinitcpio.conf, remove autodetectfrom your HOOKS array. This makes your regular initramfs exactly like fallback initramfs. If you do this, you may want to disable generating the fallback initramfs, because there is no difference between the two. You can do this by removing fallbackfrom the PRESETS array of your /etc/mkinitcpio.d/linux.preset (there is separate file for each kernel, for example /etc/mkinitcpio.d/linux414.preset)

In the end, regenerate your initramfs with

 sudo mkinitcpio -P

For more information, refer to

https://wiki.archlinux.org/index.php/Mkinitcpio

Chrysostomus, thanks for that. I'm still pretty much a novice, so it's a little intimidating to be messing with stuff at that level, but success!

Can you please inform the topic and future users, what exactly led to success?
What actions have you done?

How many modules are loaded with fallback initramfs? Why do some configurations not work correctly with autodetect?

1 Like

petsam, I didn't think that was unclear. I asked a specific question, received specific instructions from a maintainer (which we can all assume are correct instructions for what I asked), implemented the instructions, they worked as expected, I referenced that answer in my comment, and linked to that answer when I indicated that it solved the problem. Are you saying that it's necessary for me to not only link to the solution as what solved the problem, but also repeat the solution in another reply of my own? OK, as suggested by ChrysostomusMaintainer:

In your /etc/mkinitcpio.conf, remove autodetect from your HOOKS array. This makes your regular initramfs exactly like fallback initramfs. If you do this, you may want to disable generating the fallback initramfs, because there is no difference between the two. You can do this by removing fallback from the PRESETS array of your /etc/mkinitcpio.d/linux.preset (there is separate file for each kernel, for example /etc/mkinitcpio.d/linux414.preset)

In the end, regenerate your initramfs with

 sudo mkinitcpio -P

For more information, refer to

https://wiki.archlinux.org/index.php/Mkinitcpio

Now the solution is at the beginning, middle, and end of the thread. No possibility of ambiguity. :smiley:

I am not that smart, so I still am not sure what you have done, after the given advice.
It's great lack we have new smart people in the forum.
I can't wait asking for help to solve my problems..

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by