How to persistent keyboard layout

Hi,

Is there a reason why changing the layout doesn't persist? Every time I suspend my computer I rather have to change using the GUI or running setxkbmap -layout us -variant intl. I appreciate the developers behind Manjaro, but this is a very frustrating experience. I'm new to Linux, every day I learn something new, and yet, I haven't found how to persist the change of my keyboard layout - I would like the help of someone more experienced to make this happen.

System information:

Kernel: 5.4.22-1-MANJARO x86_64
bits: 64
compiler: gcc
v: 9.2.1
Desktop: KDE Plasma 5.17.5
tk: Qt 5.14.1
wm: kwin_x11
dm: SDDM
Distro: Manjaro Linux

Thanks

This are my layouts and their settings:

image

Regardless what layout i chose, it remains default after reboot/sleep/suspend ... i do not have to do anything of sorts trough setxkbmap commands. Now, if you need the -variant intl then make sure it is so defined in the Variant entry for the US layout, and not empty as is on mine (as i don't require the intl variant). As you can see on the Romanian layout i need to use the standard cedilla, otherwise i would type wrong characters ...

Hope this makes sense now.

It seems to be working now. I don't understand the difference between Keyboard Settings and Keyboard. When I change in the Keyboard just like you showed me, it works, but when I change in the Keyboard Settings, the changes do not persist. Any idea why is that?

The Keyboard settings are where you chose the real keyboard layout and usually that config is written in /etc/X11/xorg.conf.d/00-keyboard.conf when you install the system.
The Keyboard Layout settings are strictly for "virtual" layouts in user space. That way each user can have as many or just one layout as they want, and the default one will be active/selected when they log in.

that is my explanation, don't quote me on that tho :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by