How to re-enable require login password?(old post no longer valid)

Hello,
I tried to search for solution to this but the old forum thread, while it is there. seems to be oudated.
thread I found is here: Disable login password (how to?)

I was trying out Manjaro(love it so far) so I choose to auto log in without password during installation. However now that I have settled I want to re-enable password at log in. I for the life of me cannot find the setting to re-enable password.

Please help, thank you very much.

If you are using XFCE thats lightdm by default - is there no setting there ?

I just tried that program and all it did was give me appearance options, accessibility options etc. No password choices or any log in choices.

cat /etc/lightdm/lightdm.conf
cat /etc/pam.d/lightdm

auth include system-login
-auth optional pam_gnome_keyring.so
account include system-login
password include system-login
session include system-login
-session optional pam_gnome_keyring.so auto_start

Ah didn't know I have to change it in terminal. How would I go about setting it to require password again? Thanks.

Lightdm doesnt provide an easy interface to configure this, and these are rather major changes.

Your output looks like you skipped the first one? Do you have any other lightdm folders/files?
ls /etc/lightdm/

cat /etc/lightdm/lightdm.conf

[also tip - its helpful to use the </> code button for output]

[sen@imp ~]$ ls /etc/lightdm
keys.conf  lightdm.conf  lightdm-gtk-greeter.conf  users.conf  Xsession
[sen@imp ~]$ cat /etc/lightdm.conf
cat: /etc/lightdm.conf: No such file or directory
[sen@imp ~]$ cat /etc/lightdm.conf
cat: /etc/lightdm.conf: No such file or directory
[sen@imp ~]$ 

Sorry I'm complete noob in linux. I assume you wanted me to run those commands in terminal? Yes I have the XFCE version. Those are the results

Oh, I had a typo, look again :wink: /etc/lightdm/lightdm.conf

ahhh ok, a huge list of info popped up. I copy pasted the ones that looks relevent:

#autologin-guest=false
autologin-user=sen
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

How do I go about changing it?

sudo nano /etc/lightdm/lightdm.conf
put a # in front of that line
and exit (and save) with Ctrl+X

2 Likes

Yay it worked! Thank you so much for helping me through it. Much love.

1 Like

glad to hear it.
It seemed kinda scary, but not much to it right? :wink:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by