How to remove this ACPI boot-up error: "ACPI Error: [CAPB] Namespace lookup failure, AE_ALREADY_EXISTS"

Back in August 2017, I started a thread asking how I might get rid of the above ACPI error, whenever I booted the Manjaro17-xfce setup on my 6-year-old 10" Samsung N145 netbook (CPU= Intel Atom N455), with the installed 4.9 kernel. That thread is now closed, but you can see the original post at: [UNSOLVED] ACPI Error: [CAPB] Namespace lookup failure, AE_ALREADY_EXISTS - what does this error on booting mean & how do I resolve it?

Apart from this ACPI error, the netbook continues to run very smoothly with Manjaro-xfce. However, I have today found a very simple solution for removing this boot-up error and would like to share it with you, after resolving a similar issue with a 10-year-old Toshiba Satellite A300 running PCLinuxOS-xfce. It involves simply substituting the 4.9 kernel (4.9.74-2) for the 4.4 kernel (4.4.109-2). I have used the GUI method in Manjaro to remove the ACPI error, as follows:

  1. Open Manjaro Settings Manager (type in search bar after opening menu)
  2. Click on Kernel icon (shown as a penguin)
  3. You will see a list of kernel available: scroll down to the current 4.4 version available
  4. Click “Install”
  5. Enter password when prompted (this is your login one, not the security password)
  6. When install open terminal and type: sudo update-grub
  7. Reboot (it will reboot in kernel 4.9)
  8. Reopen Manjaro Settings Manager, click Kernel icon, scroll down, click Uninstall for the 4.9 kernel.
  9. When uninstalled, open terminal and type: sudo update-grub

When you reboot, the netbook will boot with the newly installed kernel, in this case 4.4.

2 Likes

ACPI errors normally show up when the kernel adds support for newer hardware. The hardware might not be fully supported, or may be able to report more information than before, so while switching to an earlier kernel series will remove the message that's because it offers less hardware support.

2 Likes

Thanks Jonathon for pointing this out - much appreciated. Wondered if you could clarify this point for me...

Don't older kernels, such as 4.4, provide more support for older hardware, while newer kernels (e.g., 4.9 to 4.14) tend to provide better support for newer hardware? As time goes on, do the newer kernels become obsolete for older hardware, or it it the contrary, newer kernels support older hardware more effectively?

From what you say, is it wiser to always upgrade to the latest LTS kernel for an older machine, i.e. 6 years or older?

I suppose there is a software issue too, the newer updates might not run properly on older kernels...

Please feel free to delete this tutorial, if you feel it is misleading and may confuse matters, or alternatively, place it under another section.

I don't know much about kernels so take my respond with the grain of salt.

As long as kernel is supported, you are OK no matter what, all security patches are up to date.

While they are removing support for older hardware in newer kernels, they are doing it quite slowly. Usually this is not an issue. So if latest LTS works on your hardware, stick with it, since it will be supported longer.

The biggest difference is, newer kernels have support for newer hardware.

So in your case, (and in mine too :smile: ) all that "warning" is, is really just a notice, your system doesn't support something that this newer kernel does support. That's all, just a harmless msg.

You can safely switch to earlier LTS kernel, and eliminate the msg, but 4.4 will become unsupported earlier than 4.9

Since that msg doesn't bother me and I know why it is there, I'm on latest LTS 14.14 with the backup kernel 4.9.

When 4.4 stops being supported (don't know when), you will need to move to a never version anyway.

1 Like

@AlManja
Very many thanks indeed - your reply was really helpful as well as being very reassuring.
Like you, I find the error message to be just a harmless warning, and certainly in all other respects the netbook runs very well on kernel 4.9.

However, I came across this in the Linux Kernel Archives, see https://www.kernel.org/category/releases.html, which shows the following end-of-life for these kernels. From this link, I notice that 4.4 has a longer life than 4.9 and 4.14, given as follows:

4.4 .... February 2022
4.9 ... January 2019
4.14 ... January 2020

So, assuming I don't have any compatibility issues when updating software applications, with kernel 4.4, I might just stay with this kernel release till the end of its life.

Also, I assume the 4.4 updates will continue to keep the kernel patched against any potential malware till its end-of-life.

Do you think the above two points are reasonable assumptions? I should add that my needs on the netbook are very modest, i.e. checking e-mails, some internet browsing, but mainly listening to radio podcasts and watching recorded TV programmes when I'm on the move.

Many thanks for your interest AlManja - much appreciated
Mike

Yes. 

Many thanks Jonathon for your reassurance.

Mike

the support dates near enough coincide with those of LTS distributions using particular branches

So.. As for every ACPI error thread ever newer==better.

Moreover (putting aside the tangible chance of this being already fixed if not any in 4.14, at least in linux-pm git) after this discussion I had on reddit, I really cannot avoid to think how much "don't touch it if it ain't broken" is stupid (at least for a normal "inexperienced" user).

For starters, for as much as you know, you are putting yourself under years of inefficiencies.
And more than anything, the next time you'll update - the hammer is going to hit very hard, should any problem arise. Bisecting old stuff is not happy.

Good research work, I just assumed newer kernel will be supported longer. I remember some kernels are getting extended support, so this is probably it.

Yes, perfectly fine and this kernel just may last longer than your old hardware, who knows... :wink:

Btw, any time, when there is new LTS out, you could try it and see if that msg is gone and if it works without any problems.

Sorry, I didn't understand your reply.

Yes, worth trying :wink:

Forum kindly sponsored by