How to swap DE (from KDE to XFCE)

Tried to swap DE from KDE to XFCE. Did everything from this guide:
https://wiki.manjaro.org/index.php/Install_Desktop_Environments#Install_a_basic_XFCE_environment
apart from creating new user ( Installed a basic XFCE environment; installed and enabled lightdm; edited /etc/lightdm/lightdm.conf , did not edit /etc/lightdm/lightdm-gtk-greeter.conf )

Restarted computer, can't log in anymore. The new login screen (light-dm I assume) does not log in after entering password and just reopens itself and letting me enter password again. So I am in kind of login loop now in GUI. (ctrl+alt+F2 and was able to log into cli just fine).

What am I missing? How to fix this? :smiley:

Don't really want to create multi-DE environment, just get XFCE running and then start removing KDE parts.

What session do you have selected in lightdm on the login screen?

What do you mean by session? there is .. just username (select) and password field and "Log In" button.

Can you provide a screenshot of the login screen? All the lightdm screens are different so I can't remember which is which. :slight_smile:

Also, if you didn't create a new user, there are some additional things you need to do but lets get you logged in first.

... now when you mentioned it, I started to look around and there is this selection indeed in the title bar thing that I didn't even notice before at all... which was for some mysterious reason set on "GNOME + Remmina KIOSK". Selection options were then this gnome+remmina / KDE / Xfce .... selected Xfce and was able to log in into GUI :smiley: thanks.

Can you give me some hints how to make Xfce the only/default option there?

Another n00b question, why does the GUI die when I swap between terminals (CTRL+ALT+F1; CTRL+ALT+F2 etc.) and how to make it go back into GUI? right now had to ctrl+alt+next_F and log in in cli and start another lightdm.... which seems rather wrong having like several of them running in background. Don't remember having this issue with KDE where I could F2 to cli ad then F1 back to GUI...

Are you sure you are checking the correct TTY? They gui isn't always on TTY1, sometimes it is on a different TTY, like TTY6/7. kde is on TTY1 but I don't remember where xfce is.

1 Like

Heh! You were right ... it was there under tty7 :slight_smile: Thanks!

Now then. What additional things? :slight_smile:

  • Delete the file ~/.gtkrc-2.0 if you haven't already.
  • If you want the Manjaro xfce config copy the contents of /etc/skel into your home folder. Make sure you get all the hidden files. Be aware that will overwrite some of your settings.
  • Tweak any oddities that popup due to having converted from plasma
1 Like

Have ran into more annoyances, maybe you can help with any of those also:

  1. I can't find a place to choose display language or localization settings in the settings. Only place was in the light-dm where I could select language and this seemed to affect the DE own language, and that's all.

  2. Logoff / reboot etc take FOREVER (like 2 minutes or so, like nothing happening... GUI active still, although when I click on the logoff button again, it gives some error) to do it. But then it does reboot/shut off.

  3. Firewalld config GUI (/usr/bin/firewall-config) doesn't work anymore (opens gui, gives this popup with "Trying to connect to firewalld, waiting..." and stays there forever). Service seems to run though.

Summary
[deemon@Zen ~]$ systemctl status firewalld.service 
● firewalld.service - firewalld - dynamic firewall daemon
     Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2020-05-08 13:53:36 EEST; 2h 4min ago
       Docs: man:firewalld(1)
   Main PID: 711 (firewalld)
      Tasks: 2 (limit: 19110)
     Memory: 45.5M
     CGroup: /system.slice/firewalld.service
             ├─711 /usr/bin/python /usr/bin/firewalld --nofork --nopid
             └─822 /usr/bin/ebtables --concurrent -L

mai   08 13:53:35 Zen systemd[1]: Starting firewalld - dynamic firewall daemon...
mai   08 13:53:36 Zen systemd[1]: Started firewalld - dynamic firewall daemon.

when trying to run from cli I get this:

[deemon@Zen ~]$ firewall-config
/usr/bin/firewall-config:2390: DeprecationWarning: Gtk.Misc.set_alignment is deprecated
  label.set_alignment(0, 0.5)
/usr/bin/firewall-config:2454: DeprecationWarning: Gtk.Misc.set_padding is deprecated
  label.set_padding(12, 0)
ERROR:dbus.proxies:Introspect error on :1.19:/org/fedoraproject/FirewallD1: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

blueman is what comes with the official ISO. You can see everything that is installed here

1 Like

Did you check "locale settings" in "manjaro settings manager"?

What is the error?

You might want to create a seperate topic for this one.

Found, thanks! :slight_smile:

Found a solution (rm /var/lib/ebtables/lock + systemctl restart firewalld.service). No idea, why this happened with DE switching. It should have nothing to do with this. Anyway, now fixed and firewall-config works perfectly fine etc. even the firewall icon appeared now into systray (firewall-applet was also not working then before I assume) :slight_smile:

EDIT: Apparently fixing the firewall thing fixed automatically the logout issue also. Now logging out works instantly. :slight_smile:

Rebooting though has this CLI 1.5m killing Session 2 delay still:
[ * ] A stop job is running for Session 2 of user deemon (23s / 1min 30s)

Could there be a fix for this also? :stuck_out_tongue:

Found the "problem" - pcloudcc fails to close nicely. Doing pkill pcloud before reboot "removes" the delay. But would like nicer solution... ... well actually running the pcloudcc gives this:

pCloud console client v.2.0.1
Daemon process created. Process id is: 4640
sudo kill -9 4640
 To stop it.

so it kind of expects itself be killed by kill -9 command? What? :disappointed_relieved: Oh well... will add logout script to kill it :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by