How to - Switch from legacy to UEFI?

Ok cool. I will try the VM part at first. Because why not.
I'm so grateful for your help!!
I will write you back after i try out the new stuff.
Wish me luck.

1 Like

Update :

  • for the VM part it refused to detect the USB no matter what.
  • good news i was able to boot into the UEFI live usb.
    Didn't do anything unusual. Just choosed the uefi usb.
    And as usual black screen takes forever but after some long time it did actually show up!
    Well that's a progress. BUT..

there is always some setbacks.
The keyboard is not working in the initial welcome to manjaro screen.
2
The NumLock is ON. But doesn't turn off. It doesn't respond to any thing. Tried every port.
But i noticed something..
As I tried to press Up and Down desperately but no results, after a couple of minutes i noticed the highlighted choice went step down (on its own).
And after more than a couple of minutes it went back up.

the keyboard works fine in legacy Live USB

@dagrlx
@korealinux

Update 2

  • The the keyboard on uefi live usb didn't respond
  • Reinstalled manjaro (legacy)

Tried this command you mentioned

sudo dd if=XXX.iso of=/dev/sdb bs=4M status=progress conv=fdatasync

But i get

No such file or directory

for the .ISO img.
i also tried

if=/dev/sdb/img.iso 

But the same result.
the iso img is on the usb

Any thoughts?

We need to replace if=XXX.iso with the path and filename of the iso file.

For example if the iso file was on my desktop:
if=/home/korealinux/Desktop/manjaro-xfce-18.0.4-stable-x86_64.iso

Also you verified /dev/sdb is the USB drive with lsblk?

And sorry for not doing this earlier, but I also created a UEFI bootable Manjaro USB in Windows 10 with Rufus portable 3.4.1430. I followed the recommendation to use rufus in "dd" mode.

In the first screen only select the iso and leave everything else default.
rufus1
After selecting START, select No for checking for new version of GRUB (it will not matter for us anyway)
rufus2
Finally, Rufus will detect the ISOHybrid Manjaro image and ask us if we want to write in dd mode. We want dd mode so yes/select the option.rufus3

It works fine on my machine (with my usb 3.0 stick).

:thinking: Maybe this depends on the VM software. We will have to ask dagrlx about it if he ever comes back.

2 Likes

I tried to do it directly from the thumb drive but i will try from desktop.

Yes I did.

Sorry I'm a lil bit confused.
Do we use rufus after using the "dd command"
Or it's alternative way? Because i tried using Rufus but with different settings.
Like

  • .iso not dd
  • gpt not mbr
    i wonder why we chose mbr? I format the usb as gpt everytime to work in UEFI. Was that a mistake?

Yeah exactly. I tried different methods but none worked unfortunately. But it's alright.

You can use dd command in linux. You can use Rufus dd mode in Windows.

If you follow the Rufus screenshots it should work. I do not think any of the options in the first screen even matter in dd mode (other than selecting the correct iso file).

1 Like

This is wrong, probably the reason for unsuccessful creation.

Probably doesn't matter, since the installer sees the "hybrid" image and asks what to do. That answer should be dd, or else.. :wink:

1 Like

@AgentS
@korealinux

Ok that was great. Using dd in rufus was instantly better. Managed to boot into uefi usb easily.
but when i try to boot manjaro it says "unknown (filesystem?)"
Tried reFlashing again but here I'm waiting for it to boot into the usb and no keyboard response again.

Also legacy manjaro kept saying no such a file or directory for some reason.

You have to slow down and be more detailed. Please do not assume I know what you are talking about when saying things like "boot manjaro" and "legacy manjaro". Boot the live image? Boot the hard disk install? Boot the hard disk install from the USB menu? There are many different ways to do things, and they are not all compatible.

You cannot boot a legacy install on a hard drive if you have booted the UEFI USB. And also the reverse, you cannot boot a UEFI install on a hard drive if you have booted a legacy USB.

If you have Windows 10, make sure you disabled hybrid sleep and fast startup.

If you boot the live USB and get unknown filesystem error there is no reason to re-flash it. Unless you are trying to re-flash using a different method. Did you use the same method to get back to the situation of no keyboard response?

There are ways forward if you can boot the live USB in UEFI mode but get a GRUB error.

So please slow down, and if you get to a point you cannot get past, please try to write down as much information as possible. What the error is exactly and also how you got to that point. Do not assume other people know what is going on just by the error message alone. The steps you took to get to that point are also important as well. Thinking through such things while trying to ask for help can also help us understand the situation better as well.

Also try to find answers for yourself while waiting for thread responses. This thread is already 3 days old and we have only made a little progress. There is only so much that get done when we are solving already solved problems one by one. The Rufus dd solution was something a 30 second search on google for "manjaro uefi usb" would have yielded. Same also for linux dd syntax questions. Instead of relying on the help of the few people reading this thread, you should tap into the thousands of people who have already helped others with the same problems as you have.

So to summarize,

  1. Be mindful of exactly what you are doing at all times.
  2. If you don't know what to do, search for an answer first.
  3. If you are still lost, then ask for help explaining what you did in as much detail as possible and also what you did to find a solution first
3 Likes

You are right.
But it's not I'm assuming you "know"
I was assuming you "remember"

As for the "legacy manjaro" i was referring to the already installed version of manjaro.

And "boot manjaro" is simply booting manjaro from the live usb. I was talking about the live usb and there was an option called boot manjaro. I don't know what else should I call it. I'm trying not to add many pictures. I guess that's why it got confusing.

I did.

Yeah i thought i might have forgotten something or did something wrong. Just as a double check. And clearly using the exact same method lead to different result. Probably i did something wrong. That's why I try to double check.

I was trying to buy myself sometime. I don't act on my own actually. I look up the forum and Google first if i encountered a new error. And i got many useful solutions to some of my problems.

Yes i actually stumbled upon it before and there the same for dd command but then i wasn't sure if this was the problem since it was working fine on the desktop with .ISO and the dd command did not work what so ever. Still getting the exact same error. No such a file or directory.

Ok cool I will be more cautious this time.

update
I managed to do the "dd command" it worked just fine in booting into the live uefi usb. Just as dd in rufus. Went smooth but when i choose boot manjaro (just as in the image) 2
I get unknown filesystem.
IMG_20190410_133746_598
Also for one second there was a different error.
It had something related to Arch. But it just disappeared quickly. And I'm left with "unknown filesystem".
I tried finding a solution for this before but couldn't find any. I will try searching again but i won't take further steps until i inform you.

[Edit: Wait... are you using a stock image from the website? I just realized ... Please do not attach random images you find elsewhere. That is confusing and counter-productive. Please remove any images from your posts that you have not taken yourself.]

This does not seem like a proper UEFI boot. There should not be an entry for memtest (the version of memtest included in the live ISO can only be used in legacy mode).

Is the movement through the menu items quick or laggy? It will be very quick in UEFI mode, like you are playing a game. In legacy mode it will be slightly laggy.

Also there should be an entry further down (below the visible menu items) for "Find EFI bootloaders" or similar wording. It should find your Windows 10 install and be able to boot it when you go to this menu. If that entry is not there, or it cannot find it, this is definitely not a UEFI boot.

This BIOS does not seem to be telling the truth for this live USB. Maybe the BIOS on this machine tries to boot UEFI, fails, then falls back to legacy mode incorrectly. Try to disable anything in the bios menu related to legacy usb support. Also, what is the model number?

I am only human. This is not the only thing I think about all day (I'm sure this thread is much more important in your life). Please just provide more details next time. Thank you for understanding. :smiley_cat:

2 Likes

OH MY BAD!
There was already similar picture to the one i had so i didn't take a picture of it myself.
Here is mine IMG_20190410_145526_595
It's kind of laggy though.

Only "welcome to manjaro" i got from Google. The rest is ok

I have this option enabled. When i disable it, it no longer detect the usb at all.

before
IMG_20190410_150605_241
changing
IMG_20190410_150632_474
after
IMG_20190410_150645_738

dell latitude E6410

Ok sure!

I want to mention.. It again doesn't boot into uefi usb maybe 10 minutes later it will and the keyboard will be not responding.
I didn't do anything unusual. Just tried to disable usb legacy from the bios. When i turned it on back it detected the uefi usb but again shows only black screen for a long time.

Is secure boot disabled in bios? You might have to set an admin password to disable it.

Also make sure your bios firmware is up to date (E6410 uefi issue).

I think this is because it is a USB 2.0 drive. Yes leave this option alone.

1 Like

it's disabled but i didn't find an option for it in bios.
I saw it disabled in msinfo.
-- last one --
IMG_20190410_155951_391

I have the latest bios. My ram is not more than 4gb.

Also rebooted again to the current installed legacy manjaro and re-inserted the usb. Booted back to uefi usb and it opened normally and less laggy. Same error though.

Option : since I'm planning to use manjaro more often than windows. I can set the boot sequence priority to legacy and get manjaro boot up first. And if i need to work on windows i will just have to get into boot option and select windows before it starts. Seems like this laptop can't handle it. Since it's working perfectly fine on my desktop.
Another option would be to try again making the vm detect the usb or something.

I'm so thankful to all of you. And really appreciate all the time and effort you put in this thread to help. It helped a lot.

One last thing, see if there is a GPT protective partition on the USB. Here are steps to remove it from Windows.

I am not sure why Rufus cannot write over this partition. Maybe because this partition is protected from within Windows?

Maybe having another USB thumb drive would have helped in troubleshooting also.

1 Like

OH MY GOODNESS!!!
I CAN'T BELIEVE IT'S ACTUALLY HAPPENING!!
I'm now in live uefi manjaro and I'm using everything normally!!

I don't wanna screw this part up.
So please bear with me.
Im now trying to use this command

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

But i have to mount and chroot first.
sda4 - swap
sda5 - esp,boot (one i created)
sda6 - root

So i mounted sda6 to /mnt
And chrooted

Sudo mhwd-chroot 

And from there "cd /mnt"
And hit the grub install command but got

/boot/efi doesn't look like efi partition. 

The esp,boot partition i created during installing manjaro legacy in the last time was somehow changed into msftData. I set it back to esp, boot from gparted
And mounted it to /mnt/boot (didn't work)
Then remount to /mnt/boot/efi (didn't work either)

Good! Glad @korealinux has taken you so far.
Now, at uefi liveOS (refer korealinux link at the 2nd post)

  1. First copy down what your kernels are in the installed manjaro OS partition (sda5). Is it vmlinuz-4.20-x86_64 and initramfs-4.20-x86_64.img or something else? Write that down.
  2. Verify again that your livecd OS is booted in uefi mode. At terminal
    test -d /sys/firmware/efi && echo UEFI || echo BIOS
    Output must be "UEFI". Do not continue if it is not.
  3. make fstab entry of sda6's /etc/fstab. Make sure you have this entry.
    UUID=xxxxxxxxxxx /boot/efi vfat defaults 0 0
    where xxxxxx is UUID of sda5
  4. At livecd terminal,
mount /dev/sda6 /mnt
mount /dev/sda5 /mnt/boot/efi    
(if directory not found, make directory - sudo mkdir -p /mnt/boot - and do again above command)
sudo grub-install  --target=x86_64-efi --efi-directory=/mnt/boot/efi --bootloader-id=manjaro --boot-directory=/mnt/boot  --recheck --debug
  1. Reboot normally (without liveusb).
    If you reboot to a grub prompt, don't worry, at grub prompt,
    grub> probe -u $root --set=abc
    grub> linux /boot/vmlinuz-4.20-x86_64 root=$abc rw
    grub> initrd /boot/initramfs-4.20-x86_64.img
    grub> boot
    (use the correct kernel you copied down earlier)

  2. When rebooted,
    sudo grub-install
    sudo update-grub
    sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

When done print out and let us take a look at

efibootmgr
efibootmgr -v
1 Like

If I translate all these literally, failure is normally expected.
If in Live Manjaro ISO, unmount the partitions of the target system and use

manjaro-chroot -a

It will find any candidates for chroot and offer a selection list.
Unless I miss something. I am not sure if the utility takes care of esp partition as well, but after chrooting you can verify.
IIRC esp should be mounted both outside and inside chroot. So, if you find it is not mounted inside, exit and mount manually.

Nevertheless, you may try whatever way, but what needs care is the proper partitions. I would suggest you post

sudo fdisk -l
lsblk -f

for possible advice.

BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64

yep the folder is there. (positive)

at first when sda5 and 6 was mounted, YES.
but now (rebooted the uefi usb), no. it shows this...

#
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
/dev/mapper/root-image /             auto      defaults           0      0

when i do this.. it is mounted but the answer always : doesn't looks like efi partition
and then i can't unmount it : "busy target"
so i had to shut down because i wasn't able to do any thing..
and now cant boot to the installed legacy manjaro..
and that what i get ... (emergency mode)
![IMG_20190411_101307_411|690x178]
IMG_20190411_101334_982 (upload://4YE9B71r0xkFP8PKuvLX4Y6DGoG.jpeg)
The cool part is.. I NOW GET THE GRUB!
I don't know why.
IMG_20190411_101915_284

some extra details :

  • manjaro fallback option also get into emergency mode

not sure if the journal log would help but here is it..
IMG_20190411_101754_724

and also lsblk results
Screenshot%20from%202019-04-11%2013-44-59

Forum kindly sponsored by