How to take ownership/mount drive and change Steam library location?

So I today I added my second drive into my rig and I went to go install Modern Warfare 2 onto said drive. However it's not like Windows where you can set your path and just go, I can't even create a folder on that second drive and I am not sure why? Is there something I missed?

I formatted the drive using GParted into EXT4 and it's just one partition, not sure if that's the wrong thing to do.


You can choose your game library path in Steam Settings just like in Windows

Yeah, I've tried that...

Just spits out this error.


Then says "New Steam Library folder must be writeable".

See if this helps:

sudo chown $USER:$USER -R path

Just change the path properly to your second drive.

Change owner on your drive to your user and create a mountpoint for it, modify /etc/fstab to mount it on boot, then select the mountpoint in your STEAM configuration as target for your installations

sudo chown $USER:$USER /run/media/$USER/Manjaro\ HDD
1 Like

Hey, I looked through those articles that you linked and didn't really understand them, I tried different commands and all of them said something along the lines of "can't find file".

Also I tried that command and this is what i got back.


I explicitly added a backslash to accomodate for the space in your mountpoint - and it is the path shown in your OP. Of course if you unmounted the device or rebooted the mountpath is no longer vaild.

sudo chown $USER:$USER /run/media/$USER/Manjaro\ HDD

You can also add " to the beginning of the path and to the end - leaving out the backslash

sudo chown $USER:$USER "/run/media/$USER/Manjaro HDD"

That "$USER" in the command linux-aarhus gave you is an environment variable that equates to your user name. When executed the $USER will be replaced by your name. Try this in a terminal: echo $USER

EDIT: Sorry linux-aarhus, I meant this to be a reply to the OP.

1 Like

Still says the directory doesn't exist. Let me reread that link you sent.

Thank you for helping. :smiley:

Just a huge tip... next time when naming drives... do not put spaces in them. Prevents headaches.

IDK about your file manager, but in Dolphin, you can right click the empty space within the drive, and give ownership to user. If your FM doesn't have that option, try the below command:

sudo chown tyler:tyler /run/media/tyler/Manjaro_HDD

1 Like

Yeah... I might rename and remake the partition on the drive. Noted for next time.

Oh also that still says it has no file or directory. I have an idea I will try now, not sure if it will work.

Alright, logging in as root and selecting the drive didn't fix it. Don't know why I thought it would, was worth a try.

I'm an idiot. All I needed to do was open the HDD in Thunar as a root user then set the perms from from there.

I am so sorry for wasting people's time!!

Can't believe I didn't think to do that.

OK - lets take it from the beginning.

Locate which device id/partition matches your second device.

An educated guess on a system with two (2) disks is /dev/sdb and with one partition it would be /dev/sdb1

lsblk -la 

Everything below assumes the device/partition to be /dev/sdb1 - if it is not change the below commands to match accordingly.

Now you have identified your second device - lets get the UUID of the partition (sample output)

~ >>> lsblk -o UUID /dev/sdb1

Now select the identification - the long hexadecimal number on line number two in the output - with your mouse and press ShiftCtrlc.

Now edit the file /etc/fstab

sudo nano /etc/fstab

Move to the line where you have UUID=xxxx / ext4 and press Ctrlk then press Ctrlu twice

In the second line remove the UUID after the = and press ShiftCtrlv to paste the UUID you copied before.

In the same line modify the root mount point / to read /data/steam

Then press F2yEnter

Next create a new folder /data/steam

sudo mkdir -p /data/steam

Now mount using fstab

sudo mount -a

To verify you actually mounted the partition (sample output)

~ >>> lsblk -la /dev/sdb
sdb    8:16   0  477G  0 disk 
sdb1   8:17   0  400G  0 part /data/steam

Next change ownership on the content of the mount - ($USER translates to your logged in username)

sudo chmod -R $USER:$USER /data/steam

To verify you have writing access test by creating a file

echo "this is a test" > /data/steam/test.txt

Read the file back

~ >>> cat /data/steam/test.txt
this is a test

Then point your steam configurtion to use folder /data/steam as installation target.


Changed title from "How do I install steam games onto my second drive?" to "How to take ownership/mount drive and change Steam library location?" to reflect this thread

1 Like

Just remember - mounting it in the filemanager - only makes the device available for the session.

Unless you modify your file system table (/etc/fstab) when you restart your computer tomorrow - you will wonder where your installed games has gone.

I used steam like that (then invested in bigger HDD) what linux-aarhus said its correct, also since I play some windows games and use Steam Play (proton) when I changed the default library location I needed to reinstall all windows games and when steam proton got updated they did not work again.

Live Long and Prosper \//

1 Like

Maybe contact Valve and ask for the feature to choose installation destination during game install like you can in Windows. That way, the original games would still be accessible along with new ones on the secondary location. They should be open to that if they really give a rats arse about Linux.

well my main point was the changing default steam library location made a lot of problems for me and it spend me a lot of time, I value my time so I invested in bigger HDD. I tried once contacting steam valve via support email and on discort on another matter (when it was announced in beta that they will allow Linux Native games to be able to force Windows version), but I got the impression that people support engineers working at Valve were using Windows as primary and only ubuntu as secondary OS and were not Linux experts. At the time I was using Fedora so most of the advice was useless anyways. Last advice I got from valve was well try on Windows (I said bye to windows back in 2007).

Live Long and Prosper \//

Already exists since ages.
When multiple libraries are available, you will be asked where to install the game to, or offering to create a new lib:


1 Like

Forum kindly sponsored by