HP LaserJet 1018 printer not installing (again) [Solved]

Things worked quite well after following tips as per this thread.

Not so with latest attempt on XFCE 20.0.3
HP-plugin installs but always end up with this error message:

Cups enabled as per initial thread does nothing.

Hi
There is an issue with the latest GUI version, ending up in this circle. You can solve it by installing from cli:

hp-setup -i

Using connection type: usb

error: No device selected/specified or that supports this functionality.

Just to show that the plugin is installing:

Then, with HP device manager, try to set it up and it still wants that plugin.
Hence, the aforementioned error message (cf. initial screenshot in this thread).

Just installed it via KDE version and it works just fine!

Funny thing tho.
KDE installs printer but still need to get plugin.
hp-plugin does the trick (but always takes a long time).

Just wondering...

On XFCE, i hadn't waited to try the HP device manager to automatically install the printer.
In fact, it didn't seem to happen at all so i proceeded to install the plugin first.
Might this have had an impact?

Did fresh install (KDE 20.0.3), waited for OS to install printer after turning it on then did hp-plugin in terminal (remembering to sudo passwd root beforehand) - works fine! :slight_smile:

Did finally get XFCE 20.0.3 to finally install it but only via CUPS.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by