HP OMEN 15 No sound on installation of Manjaro KDE or Manjaro XFCE

Hey there, I am new to the Manjaro community and I am trying to dual boot Manjaro Linux, the first distro I have ever tried. I booted the iso in a bootable drive, switched the secure boot off and loaded the live session onto the screen and chose no free mode for drivers while installing the distro. Everything worked fine until after a while I realized the audio wasn't working, I realised this after installing on the partition. Then I decided to look on the forum to try and solve this, after spending the whole day trying, I decided to uninstall: XFCE, the version I had just installed and try KDE. Again I faced the same issue. I tried installing Linux Mint to see if this is distro specific and realised my audio is the problem. Inside the pulse audio plug in settings where we can choose profile I see nothing but unavailable nvdia hdmi stuff. I have an Intel with Realtek sound card inbuilt which doesn't get detected probably.

I'd be glad if someone could help me, because I am really interested in Manjaro.

There is a lot of topics on this HP model - please look for a solution there.

Hey, I have referred the answers but they seem to have some devices that are recognized or graphic issues, I have all that fixed its the audio specifically, with a little assistance I can get this working . At this moment I am in the manjaro kde environment. Please help me if possible.

after aplay-l:
type or paste code here

card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

UPDATE: Just used focusrite scarlett soundcard and the audio is working but the moment i disconnect its all gone

aplay is only showing HDMI and no onboard audio

please post system information - inxi -Fxxxz

sudo alsa-info.sh --upload

Hey, thanks for helping me out.
Here is what you asked for:

inxi -Fxxxz

System:    Host: manjaro Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.5 
           tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: OMEN by HP Laptop 15-dh0xxx v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 8600 v: 44.31 serial: <filter> UEFI: AMI v: F.08 date: 06/13/2019 
Battery:   ID-1: BAT1 charge: 50.2 Wh condition: 56.1/69.0 Wh (81%) volts: 11.6/11.6 model: COMPAL PABAS0241231 type: Li-ion 
           serial: <filter> status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 801 7: 801 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Hewlett-Packard driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1f11 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nouveau alternate: fbdev,nv,vesa compositor: kwin_x11 
           resolution: 1920x1080~144Hz 
           OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.6 compat-v: 3.1 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard driver: sof-audio-pci bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA TU106 High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:10f9 
           Sound Server: ALSA v: k5.6.11-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: 3000 bus ID: 3c:00.0 chip ID: 10ec:8168 
           IF: enp60s0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.30 TiB used: 107.0 MiB (0.0%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000H1 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: EXA73H1Q scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: RPM2 scheme: GPT 
           ID-3: /dev/sdb type: USB vendor: Seagate model: BUP Slim BK size: 931.51 GiB serial: <filter> rev: 0304 scheme: MBR 
           ID-4: /dev/sdc type: USB vendor: SanDisk model: Cruzer Blade size: 14.59 GiB serial: <filter> rev: 1.00 scheme: MBR 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5020 bus ID: 00:17.0 
           chip ID: 8086.282a rev: 10 
Partition: ID-1: / size: 11.64 GiB used: 107.0 MiB (0.9%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 10.0 C gpu: nouveau temp: 42 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 285 Uptime: 1m Memory: 15.52 GiB used: 944.2 MiB (5.9%) Init: systemd v: 245 Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37 

sudo alsa-info.sh --upload result link:


onboard audio has not been fully working for some time now
archived.forum.manjaro.org - Laptop microphone not working (HP Omen 15)

the IntelSST digital microphone array was supposed to be supported by sof-firmware and kernel v5.5
it worked for some laptops, but not this one

and problems appear to be ongoing
new issue reported to sofproject recently

there was mention that a lot of these bugs will be fixed with kernel v5.7 and Pulseaudio v14
but neither have been released yet
Ubuntu 20.04 is alleged to include a release-candidate of Pulseaudio (v13.99) which has most of the fixes for sof-firmware to be included in v14
so if there are still issues on Ubuntu, microphone still may not work

best i can suggest at the moment is to disable detection of the dmic and the rest of the onboard audio should work ok with snd_hda_intel driver

create a file with a text editor

sudo nano /etc/modprobe.d/audiofix.conf

(use another editor instead of nano if preferred)

add these 2 lines

save and exit
and reboot system to reload ALSA


DUDEEE! its working. After so much effort. Thanks alot!!

Hey just after using for an hour or so I realized the mic is not working. Does it have something to do with the file we just create or is it another issue?

The patch above disables the Omen 15's digital microphone array in order to get the speakers and internal audio working. Fortunately, they don't have to be mutually exclusive with some elbow grease: you need to be running the 5.7.9 kernel, have the sof-firmware package installed on your system, and build the latest pulseaudio from source.

If you need help, I wrote a troubleshooting guide for Manjaro on the Omen 15.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by