hp-uiscan: No device connected


First of all, I'd like to thank all the developers for making this such awesome OS, and, for the first time, I think I can say that my distro hopping is cured. By also shipping the distro with hplip pre-installed, they saved me lots of time (I've never been able to install in Ubuntu).
I've configured my printer and everything went fine. But when I open hp-uiscan it says "No device connected".
Anyone can help me?

BTW, HP Device Manager has no icon, as you can see.



Thanks in advice :slightly_smiling_face:


System:    Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A515-51G v: V1.21 serial: <filter> 
           Mobo: KBL model: Charmander_KL v: V1.21 serial: <filter> UEFI: Insyde v: 1.21 date: 08/08/2018 
Battery:   ID-1: BAT1 charge: 38.4 Wh condition: 38.4/48.9 Wh (78%) volts: 16.7/15.2 model: LG 004B384234314341 type: Li-ion 
           serial: <filter> status: Full 
Memory:    RAM: total: 7.65 GiB used: 2.11 GiB (27.6%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 6144 KiB 
           bogomips: 28808 
           Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c 
           flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt 
           invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
           pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
           smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: NVIDIA GM108M [GeForce MX130] vendor: Acer Incorporated ALI driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:174d 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: GeForce MX130/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 3000 bus ID: 02:00.1 chip ID: 10ec:8168 
           IF: enp2s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 3000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           IF-ID-1: ham0 state: unknown speed: 10 Mbps duplex: full mac: <filter> 
           IP v4: <filter> scope: global broadcast: <filter> 
           IP v6: <filter> scope: global 
           IP v6: <filter> scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 55.38 GiB (5.9%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 1J scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 110.32 GiB used: 55.38 GiB (50.2%) fs: ext4 dev: /dev/sda8 label: N/A 
           uuid: 02517fd8-b768-422c-8ff3-b1a689198bb3 
           ID-2: /boot/efi size: 511.0 MiB used: 300 KiB (0.1%) fs: vfat dev: /dev/sda9 label: N/A uuid: 6CB5-0035 
           ID-3: /var/lib/snapd/snap/core18/1754 raw size: 54.9 MiB size: <root required> used: <root required> fs: squashfs 
           dev: /dev/loop3 label: N/A uuid: N/A 
           ID-4: /var/lib/snapd/snap/gnome-3-28-1804/128 raw size: 161.4 MiB size: <root required> used: <root required> 
           fs: squashfs dev: /dev/loop4 label: N/A uuid: N/A 
           ID-5: /var/lib/snapd/snap/gtk-common-themes/1506 raw size: 62.1 MiB size: <root required> used: <root required> 
           fs: squashfs dev: /dev/loop6 label: N/A uuid: N/A 
           ID-6: /var/lib/snapd/snap/kde-frameworks-5-qt-5-14-core18/4 raw size: 290.6 MiB size: <root required> 
           used: <root required> fs: squashfs dev: /dev/loop0 label: N/A uuid: N/A 
           ID-7: /var/lib/snapd/snap/kdenlive/24 raw size: 87.8 MiB size: <root required> used: <root required> fs: squashfs 
           dev: /dev/loop5 label: N/A uuid: N/A 
           ID-8: /var/lib/snapd/snap/snapd/8140 raw size: 29.8 MiB size: <root required> used: <root required> fs: squashfs 
           dev: /dev/loop1 label: N/A uuid: N/A 
           ID-9: /var/lib/snapd/snap/whatsdesk/19 raw size: 75.5 MiB size: <root required> used: <root required> fs: squashfs 
           dev: /dev/loop2 label: N/A uuid: N/A 
           ID-10: swap-1 size: 3.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 label: N/A 
           uuid: 47a940f1-22ac-4b02-8276-4c3041ce3878 
Unmounted: ID-1: /dev/sda1 size: 100.0 MiB fs: vfat label: ESP uuid: 64F8-A2E8 
           ID-2: /dev/sda10 size: 1024.0 MiB fs: ntfs label: Recovery uuid: EAE8FB98E8FB60ED 
           ID-3: /dev/sda2 size: 16.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-4: /dev/sda3 size: 677.33 GiB fs: ntfs label: N/A uuid: 1AB64A6EB64A4B09 
           ID-5: /dev/sda4 size: 579.0 MiB fs: ntfs label: N/A uuid: DEE8F7F5E8F7C9B3 
           ID-6: /dev/sda5 size: 50.00 GiB fs: ext4 label: PrimeOS uuid: e5d445e4-f59f-5158-b9c7-465f7009bc23 
           ID-7: /dev/sda6 size: 75.00 GiB fs: ntfs label: Jogos uuid: 1694B5A794B589AF 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-1:2 info: Sunplus Innovation Optical Mouse type: Mouse driver: hid-generic,usbhid interfaces: 1 
           rev: 2.0 speed: 1.5 Mb/s chip ID: 1bcf:0005 
           Device-2: 1-5:3 info: Lite-On type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
           chip ID: 04ca:3015 
           Device-3: 1-7:4 info: Quanta HD Webcam type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
           chip ID: 0408:a060 serial: <filter> 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 47 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 280 Uptime: 1h 42m Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 running in: konsole 
           inxi: 3.0.37 

Printer: HP DeskJet 3639

I have a HP OfficeJet Pro 8720 and if I start hp-uiscan I get the same error. But scanning via xsane is no problem. So perhaps try scanning with xsane.

1 Like

Thank you very much.
I'll try it :wink:

Before HP Manager GUI can be used you must first install the device using the *Printer Settings app (system-config-printer) and you must use the HP driver.

1 Like

It's installed. HP Device Manager works perfectly, hp-uiscan is the one with problems.

Skanlite is the scanner application to install & use for KDE Plasma, and will be listed under Graphics. It acquires and works perfectly with my shared HP Envy 5542 Multifunction Printer/Scanner/etc.



Thanks. I already used Skanlite :wink:

Anyone knows if I can install NAPS2 here? I use it on Windows and I simply love it. :smiling_face_with_three_hearts:

Then use it. HP-uiscan has never worked for me in any Arch-based KDE installation. Dunno about other systems or DEs.

1 Like

Have you tried accessing the scan functionality by using the printer's builtin web service?

Use any web browser and access the printer's IP like this (the last slash is important - otherwise the browser will open a searchpage)


Extra note:

I am annoyingly curious - so when a member asks a question - I have to verify it this or that can or cannot do.

Lying on my back - a place comfortable - with a laptop which - until this moment - didn't have any printing or scanning support.

  1. Installed printer support - including HPlip because we have a cheap HP Envy 4520.
  2. started cups
  3. Setup the printer using the HPlip library and hp uiscan doesn't work for me either
  4. installed simple scan
  5. Opened simple scan gui (it scanns for devices) and found the hp
  6. Still lying on my back - I could run a scan - it was blank of course - the printer is in the other end of the house :slight_smile: but it worked.
1 Like

If you're still interested to use the hp tools, you can give hp-scan from terminal. It does what hp-uiscan is supposed to do but without gui feedback.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by