HP Zbook G6 Sound Not Working

I've installed Manjaro with KDE on an HP Zbook G6 and the sound does not work. I've uploaded the Alsa info here:
ZBook G6 Alsa Info
I've looked through quite a few posts and tried a number of different solutions, but nothing seems to work with the G6. Any help would be appreciated. If there is other info that would be helpful let me know.

Please change to a LTS kernel or the latest. The one you are booting is EOL.
Try disabling HDMI audio and change some settings in alsamixer . Make sure auto mute is disabled too.

Thanks for the information. It appears that I probably have two options based on what I see in Kernel - 5.4.39-1 and 5.6.11-1. Just curious how I would know that the 5.5 kernel is EOL? My thinking is that I should try the 5.6 kernel, but any recommendation?

As far as disabling HDMI audio, I'll have to look into that as I'm not sure how I go about disabling it. I have tried different settings in alsamixer, verified that the mute is disabled, but still no sound.


No worries. Hopefully changing the kernel will help.

Usually is mentioned in the updates announcement, in the notes section.

I always suggest to keep at least two kernels at hand. One that is LTS (long term support) and one that is not there yet like 5.6 or even try experimental kernels (if not afraid of some inconveniences that might come up, or a few of regressions) like 5.7... That way there is always a way to compare and know what works best for that hardware and even report about it.

Use pavucontrol for now.

I switched to the 5.6 kernel, but still no sound. It seems now that there are no devices that show up in pavucontrol. I checked alsamixer and only the default device shows up and is not muted. Here's the link to the alsa-info upload: Alsa-info with v5_6
Here's the output from inxi -Fxzc0

tSystem:    Host: ric-hpzbook17g6 Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP ZBook 17 G6 v: N/A serial: <filter> 
           Mobo: HP model: 860C v: KBC Version 65.23.00 serial: <filter> UEFI: HP v: R92 Ver. 01.03.04 date: 11/06/2019 
Battery:   ID-1: BAT0 charge: 86.8 Wh condition: 91.3/91.3 Wh (100%) model: Hewlett-Packard Primary status: Unknown 
CPU:       Topology: 8-Core model: Intel Core i9-9880H bits: 64 type: MT MCP arch: Kaby Lake rev: D L2 cache: 16.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 73625 
           Speed: 900 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
           9: 900 10: 901 11: 901 12: 900 13: 900 14: 900 15: 900 16: 900 
Graphics:  Device-1: NVIDIA TU104GLM [Quadro RTX 5000 Mobile / Max-Q] vendor: Hewlett-Packard driver: nvidia v: 440.82 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Quadro RTX 5000/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard driver: sof-audio-pci bus ID: 00:1f.3 
           Device-2: NVIDIA TU104 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.6.11-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 4000 bus ID: 70:00.0 
           IF: wlp112s0 state: up mac: <filter> 
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 4.10 TiB used: 1.70 TiB (41.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000H1 size: 476.94 GiB 
           ID-2: /dev/sda vendor: Seagate model: ST2000LX001-1RG174 size: 1.82 TiB 
           ID-3: /dev/sdb vendor: Seagate model: ST2000LX001-1RG174 size: 1.82 TiB 
Partition: ID-1: / size: 239.31 GiB used: 67.64 GiB (28.3%) fs: ext4 dev: /dev/dm-0 
Sensors:   System Temperatures: cpu: 48.0 C mobo: 40.0 C gpu: nvidia temp: 38 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 363 Uptime: 13m Memory: 78.42 GiB used: 1.69 GiB (2.2%) Init: systemd Compilers: gcc: 9.3.0 Shell: bash 
           v: 5.0.16 inxi: 3.0.37 

Let me know if any of this helps to troubleshoot this issue.

Create /etc/modprobe.d/audiofix.conf and add this line to it:
You can by running this commands one by one:
sudo touch /etc/modprobe.d/audiofix.conf
echo 'dmic_detect=0' | sudo tee -a /etc/modprobe.d/audiofix.conf
Reboot. Sound should be working.

I did as you suggested and created the audiofix.conf file. After rebooting the sound is still not working and no devices show up in the pavucontrol and alsamixer does not show any devices other than "- (default)" and "0 HDA NVidia". Any other ideas?

I wonder what @nikgnomic will make about all this ? :slight_smile: Hopefully will join the conversation, and provide some suggestions.
Edit: Hey @TheRicster - just noticed i had a typo in my previous comment:
audiofix.con has to be audiofix.conf

1 Like

@bogdancovaciu Thanks for mentioning the typo. I figured that was the case and made my changes using .conf as the file name. I appreciate your attempt to pull additional help into my issue. It seems to be something particular to either the Cannon Lake or the ZBook G6.

alsa-info is only showing basic recognition of audio device
Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
Cannon Lake devices should be fully supported with sof-firmware drivers instead of the usual snd_hda_intel driver
but changing driver has not been working out so good for some laptops
the github site for sofproject has a growing list of issues - https://github.com/thesofproject/sof/issues

your alsa-info data has the SOF drivers listed in section: !!All Loaded Modules
but they are not loaded instead of snd_hda_intel

adding the option to disable dmic detection will disable the internal microphone, but it will allow the rest of the audio system to work with the snd_hda_intel
this option has been a good partial solution whilst the bugs with sof-firmware are getting worked out

please post full ALSA information with sudo alsa-info.sh --upload
sudo is needed with this script to get dmesg information that may have some error messages
but i expect ALSA to detect the audio device ok when the modprobe option is in place

1 Like

@nikgnomic thanks for the info. I had looked into switching drivers and ended up abandoning that as I couldn't find a good resource. With the right info I'd be interested in trying it again. I would really like to get the mic working , but hopefully the driver development will get that done at figured out. Here's the link to the alsa_info:

It seems that there is some issue with the dmic_detect=0 line that I added is in error.
Thanks for your help.

Just passed by to mention that maybe is not enough to have the dmic_detect=0 in the conf, but needs to be:
options snd-hda-intel dmic_detect=0
options snd-hda-intel model=laptop-amic enable=yes

The first line is to enable the speaker, the second for the internal microphone.

1 Like

once the modprobe options allow audio to work with snd_hda_intel they could be deactivated to work on getting everything working with sof-firmware
change the filename from '.conf' to something like '.conf.off'
or edit the .conf file and add a comment tag '#' to deactivate options
then reboot to see if audio will work with snd_sof
if it does not work, change the filename back or remove comment tags and reboot again to get back to snd_hda_intel

any data you could get trying to get dmic working would be helpful to a number of other users at the moment

1 Like

I modified the .conf file as @bogdancovaciu suggested. That made it so the sound works, so that's a good step. The mic shows up now in pauvcontrol, but it doesn't seem to capture anything. I tested with a meeting that allows me to see the mic input level. I checked alsamixer and made sure that nothing was muted. Turned the inputs up to 100%, but still nothing. I uploaded the alsa_info here:

@nikgnomic, I'll try disabling the options that I added in the .conf file and see what happens on reboot.

I played around with the audiofix.conf file a bit and didn't come up with a combination that worked any better. With both lines commented out there is again no audio device that shows up in pauvcontrol. Not sure how to get the sof-firmware to be enabled. Perhaps it is, but just not loading anything, or the right thing. For now at least I have sound with the snd_hda_intel, but hopefully can still get something that will allow my microphone to function.

If there is something else I should try or additional information I can send let me know.

So far it seems that the audio does work, running kernel 5.6.12-1 now. But the microphone is still not recognized. I have added the lines to the audiofix.conf file that were indicated above. Any more help on this?
Also, where can I look to see what development may be happening on the sof-firmware that I'm hoping will take care of this issue?

I seem to be talking to myself here, but wanted to give another update. The speakers are working on the G6 now, but I can't control the sound volume through pauvcontrol, only through aslamixer. Why would that be the case?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by