hplip update failure [Solved]

Hi, I ran updates and everything was fine until the file integrity check. at that point it it states failed to commit transaction: conflicting files and then a line of what might be all of the hplip python files stating that each already exists in the file system. After listing the files it just stops. Any help would be great. thanks in advance for any help

System:    Host: zenlinux Kernel: 4.19.108-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: Awesome 4.3 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: SABERTOOTH X79 v: Rev 1.xx serial: <root required> 
           BIOS: American Megatrends v: 4701 date: 05/06/2014 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master charge: 100% (should be ignored) 
           status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-3960X bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 
           L2 cache: 15.0 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 79251 
           Speed: 1202 MHz min/max: 1200/3900 MHz Core speeds (MHz): 1: 1201 2: 1201 3: 1201 4: 1201 5: 1201 
           6: 1201 7: 1201 8: 1201 9: 1201 10: 1201 11: 1201 12: 1201 
Graphics:  Device-1: NVIDIA GM204GL [Quadro M4000] driver: nvidia v: 430.64 bus ID: 01:00.0 
           Display: x11 server: X.org 1.20.7 driver: nvidia resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel C600/X79 series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-3: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo bus ID: 4-1.2:3 
           Device-4: RODE Microphones type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 4-1.4:5 
           Sound Server: ALSA v: k4.19.108-1-MANJARO 
Network:   Device-1: Intel 82579V Gigabit Network vendor: ASUSTeK P8P67 Deluxe driver: e1000e v: 3.2.6-k port: f040 
           bus ID: 00:19.0 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 40:16:7e:7b:d0:c8 
Drives:    Local Storage: total: 3.86 TiB used: 1.19 TiB (30.8%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 Series size: 111.79 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 840 Series size: 111.79 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD2002FAEX-007BA0 size: 1.82 TiB 
           ID-4: /dev/sdd vendor: Samsung model: SSD 860 EVO 2TB size: 1.82 TiB 
Partition: ID-1: / size: 109.53 GiB used: 71.75 GiB (65.5%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 80 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 60% 
Info:      Processes: 346 Uptime: 17h 10m Memory: 62.85 GiB used: 11.26 GiB (17.9%) Init: systemd Compilers: 
           gcc: 9.2.1 Shell: zsh v: 5.8 inxi: 3.0.37 


The issue and the fix was described and provided countless times already in the forum, plus is in the stable update announcement

Plus here

1 Like

Please read the anouncement:known issues before you update.

@bogdancovaciu beat me to it :slightly_smiling_face:

1 Like

Sorry but I did search the technical forum for hplip references and nothing came up

Ok doing it now thanks

1 Like

Ok ran it cli and it went through great, thanks for your help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by