Hybrid AMD/NVIDIA set up

i think there is, but i dont think optimus-manager is the way to go. finding a xorg configuration that works first is probably a better idea, then setup optimus-switch thats much easier to bend to your will.

are you able to make it to a graphical desktop on any manjaro? live? installed? and if so what did you do to get there.

or if you can chroot in from another distro's live usb and post these outputs

inxi -Fxxxza
mhwd -li
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
ls -la /etc/modprobe.d ; cat /etc/modprobe.d/*.conf
ls -la /etc/modules-load.d ; cat /etc/modules-load.d/*.conf

what you need is a properly setup xorg configuration, and the nvidia gpu should be able to offload to the amdgpu/modesetting driver.

do you have the option available in bios to disable one of the gpu's?

Unfortunately there is no setting in bios to turn one off. I have contacted Asus and according to them the Nvidia driver is the sole controller of the hybrid system. When I get home I will pull those and post them.

I am thinking optimus manager, it has to be switch automatically as far as I know there is no way to set up my system to switch via the terminal or any other means. . That's where the automatic offloading script comes it.

Try with only nvidia driver and no xorg conf file.
I mean install video-nvidia with mhwd and delete/rename /etc/X11/xorg.conf.d/nvidia.conf (or similar filename).

If it fails, try the configuration instructions for the new Nvidia Prime for linux. Look in this topic.

Else go with @dglt advice :wink:

Read through the new prime configuration. Tried a few different options. I am throwing in the towel, I can't even use just the AMD gpu like I can with arch by only installing the amdgpu. While I love Manjaro there are plenty of other distros that work with out issue. I don't really understand how I can build arch from the wiki and it works. Yet Manjaro is unable to run. Or how I can install and use Arco Linux. I will check back from time to time and see if they ever update the live image. The moment that works is the moment Manjaro will work. Thanks for the suggestions and help.

It might help improving if we knew what you have tried and failed.
Would you mind for some feedback?

:point_up: this. "it doesnt work" doesn't help you or the users willing to help you. nvidia to amd offload does work with the correct configuration. you get out what you put in.

since you didnt post the requested outputs, nobody other than yourself knows whats going on.

replace whatever gpu configuration (if any) in /etc/X11/xorg.conf.d/ (probably 90-mhwd.conf) with this one.

#/etc/X11/xorg.conf.d/offload.conf

Section "ServerLayout"
  Identifier "layout"
  Option "AllowNVIDIAGPUScreens"
  Screen 0 "iGPU"
EndSection

Section "Device"
  Identifier "iGPU"
  Driver "amdgpu"
  Option "DRI" "3"
EndSection

Section "DRI"
    Group "video"
    Mode 0666
EndSection

Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection

Section "Screen"
  Identifier "iGPU"
  Device "iGPU"
EndSection

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
EndSection

save/exit/reboot

do keep in mind, both nvidia and amdgpu need to be installed. when you installed video-nvidia-435xx it created conf files that are probably conflicting with what you want to do. so in case i forgot to mention it... post the requested outputs

1 Like

This is what I have done, install using architect because even the 18.1.0 live doesnt work.

Install desktop, bootloader and free drivers. Then install the Nvidia driver using mhwd -i pci video-nvidia-435xx

Replace the 90-mhwd.conf with the offload.conf you provided.

I blacklist the nouveau driver in /etc/modprobe.d/blacklist.conf

Reboot the PC it goes to a black screen I am able to get to tty and took some pictures of the requested commands. IMG_20190913_110140 IMG_20190913_110244 IMG_20190913_110208 IMG_20190913_110159

ok, in the third picture you can see that you have more than one xorg configuration in use which is always a great way to end up at a black screen. you were suppose to remove 90-mhwd.conf because it's taking priority over the .conf file you actually want to use.

make sure thats the only file in there that does not belong
ls -la /etc/X11/xorg.conf.d

then get rid of it

sudo rm -rf /etc/X11/xorg.conf.d/90-mhwd.conf

then reboot. and if for whatever reason you might end up back at a black screen, edit the file you created earlier and replace "amdgpu" with "modesetting"

Well that worked to get past the black screen. I got to the login screen entered my password. A mouse pointer appeared then the middle of screen flashed static and now I can't do anything. I can't even get a tyy screen to appear. As I am writing this reply I notice the brightness dimmed down and when I pressed a key in increased, while remaining black. I decided to open another tty entered my user name and password. Pressed enter and the input "shutdown now" the computer shut itself down.

small step towards progress :sweat_smile:

have you tried this yet?

Yup, how would I default xorg to use the AMD igpu? That's how every other distro is able to work withy setup.

That configuration is wrong I used this configuration and got it to work. I now have a bootable Manjaro desktop for the first time in 3 months. I had lost all hope as you guys could previously read haha. Thank you to both of you for being patient with my super frustrated ass lol.

7 Likes

that sounds painful :smirk:

glad to hear you figured it out :+1:

1 Like

Hello everyone,

I have similar laptop configuration. The laptop is Asus FX705DU (NVIDIA GTX1660Ti, AMD Ryzen R7-3750H).

I went through all the steps you wrote, now there is no black screen anymore. However, I cannot use the external monitor. I often use my computer by extending an monitor and a laptop screen.

Nvidia panel sees external monitor via HDMI but I have no changing option :frowning:

Screenshots:

Screenshot%20from%202019-10-30%2008-08-03

Screenshot%20from%202019-10-30%2008-09-31

Thanks.

@Akicay Please create a new thread for your issue. It is never a good idea to jump into someone else's thread with an issue. Especially when the thread is marked as "Solved".

When you create your new post, please follow these guidelines.

Thank you.

1 Like

because render offloading doesnt support external monitors, not yet anyway. using a prime setup would perform better and not make your video outputs useless.

dont respond here and create a new thread as @linesma suggested.

1 Like

Thanks @dglt @AgentS @Swagglepuf, this topic was helpful for my laptop with Ryzen 5 and Nvidia 1650.

2 Likes

yw, welcome to the forum.

Thank you guys. This worked for me also with ryzen 5 and gtx 1650. May I know what is the difference between offloading and prime?

Not easy to describe.
You may find this useful.

Forum kindly sponsored by