I am stuck in the rootfs console and the commands for /sbin/init do not work

Hello,

I am using a Mac with Manjaro KDE Minimal 18.0 Illyria Beta. The Manjaro KDE Mnimal uses the GPT UEFI mode (/boot/efi). I rembember that I flagged /dev/sda1 which is /boot/efi, as esp and boot.

When I started the Manjaro gub, I got stuck in the rootfs terminal which told me to run fsck /dev/sda3. I did.

Rebooting, stuck again in the same rootfs terminal which told the /sbin/init does not eist. I followed the non-Manjaro but Arch Linux-related tutotials:

https://wiki.archlinux.org/index.php/syslinux#Automatic_Install

I tried everything, but nothing worked.

The command init=/lib/systemd/systemd does not work on both grub and rootfs terminals. I did not know how to install Syslinux on grub and rootfs.

I have discovered. A lot and a lot of files are missed and all missed files, including /etc/fstab/ are in lost+found.

That sounds totally messed, did you check the integrity of your downloaded iso.

I burned Manjaro KDE Minimal ISO into a 4GB SanDisk USB drive with Etcher at macOS.

How to check and know the integrity of the downloaded ISO?

I downloaded the ISO from https://osdn.net/projects/manjaro-community/storage/kde-minimal/17.1.8/.

On the download page will be an sha1 file or sha256 file.
Download the file that matches the iso you downloaded. Mac must have a checksum utility to verify the file. I have never used a Mac, so I can't say what utility to use for verification.

Then I own a laptop with Manjaro. I can check the integrity of my Manjaro USB drive and the ISO. Then how check both Manjaro USB drive downloaded ISO on Manjaro?

I use Dolphin on KDE. You can easly add a dolphin service menu checksum app. Search and install "checksums".

On other DE's I'm not sure. There is also the terminal, but I'm lazy and just prefer to check by a right click menu.

Ah, OK, here:

4499ae8585a50ad1085f795cda71e848b419337daaaf7b86fa94c42613b8c502 /Users/gusbemacbe/Downloads/Manjaro KDE Minimal.iso
908560cf7e7238e8d79a5ad1a17c12404d9dc905 /Users/gusbemacbe/Downloads/Manjaro KDE Minimal.iso

I compared them to the shasum files downloaded from that link:

4499ae8585a50ad1085f795cda71e848b419337daaaf7b86fa94c42613b8c502  manjaro-kde-minimal-17.1.8-stable-minimal-x86_64.iso
908560cf7e7238e8d79a5ad1a17c12404d9dc905  manjaro-kde-minimal-17.1.8-stable-minimal-x86_64.iso

They are all OK.

Well that doesn't make things any easier, that would have been a simple answer to what was causing this. Unfortunately, I think you will have to wait for someone more experienced than me with these matters.

Hopefully someone that knows what's causing your issue will stop by to help you before too long.

1 Like

Apparently, you need to re-install Manjaro. You have posted a few topics with installation problems lately. Is it the Mac Mini? What was the procedure you have followed to install on this one?
Has this Manjaro installation ever booted successfully?

1 Like

Yes. A Mac mini 2011.

Yes. The grub always works normally, then I was swalloed into the rootfs console.

During the step Partitions:

  1. I selected "Generic Mass Storage Device" (an external HDD) for storage device;
  2. I chose Manual partitioning;
  3. I deleted all partitions of that selected device;
  4. I clicked in New Partition Table and chose GUID Partition Table (GPT);
  5. I created three partitions by order:
    • 1st partition: Size: 300MiB; File System: fat32; Mount Point: /boot/efi/; Flags: boot, esp;
    • 2nd partition: Size: 7360MiB; File System: linuxswap; Flags: swap;
    • 3rd partition: Size: 220≠MiB; File System: ext4; Mount: /; Flags: root.
  6. I selected "Generic Mass Storage Device" for boot loader.

Observe that I chose non-free drivers.

you dont need non-free drivers , only for Nvidia,
if you have only GPU intel or any Radeon card , Free do a best choice

This needs the a --removable parameter on grub-install command.
Also, how do you boot to this system? Do you select from a menu, or is it the default boot entry?
Boot to your Manjaro installer media and detect EFI bootloaders. If your external installation is found, use it to see if it works. If it works, run grub-install again with --removable parameter .

sudo grub-install --removable --recheck 

You might want to check again and post the relevant info

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

The 2010s Mac computers do not use NVIDIA and Raedon cards. They Intel cards.

I press option/alt (⌥) and the boot partitions list. See the screenshot:

Untitled

The grey EFI belongs to Ubuntu EFI and the orange EFI belongs to Manjaro.

OK, I will reinstall.

Can I run sudo grub-install --removable --recheck /dev/sdc?

do not include the drive.
Run it from Manjaro installation

There is something wrong, strange and mysterious.

I did not find /boot/efi in the list of mount point during the Partitions step. I thought it was the ISO. I reinstalled the ISO, but it is still the same thing.

I remember what I did the last 10 reinstalling times. I decided to explore that bug. Chekcing Install Manjaro Linux, it appeared as Manjaro 18.0.1-alpha Illyria. After running the commands pacman-mirrors and pacman -Syyu. After finishing the upgrade, checking Install Manjaro Linux, it apperaed as Manjaro 17.1.8.

I remembered that on my external HD, my OS was Manjaro 18.0.1, and after running -Syyu, it appeared as Manjaro 17.1.18.

I believe it causes the bugs of boot and /sbin/init.

I think maybe @excalibur1234 and @philm must know these bugs.

Do you think I must migrate from KDE Minimal Illyria to KDE Minimal Holaika or KDE Full 17.1.18 or KDE Full 18.0.1 Beta 5? Which of them offers /boot/efi?

Observe that I have already installed normally both Manjaro KDE Minimal Holaika and Illyria and applied /boot instead of /boot/efi, but after rebooting, the orange Manjaro EFI orange does not exist anymore.

It becomes a nightmare. I repaired during a week!

I decied t download the ISO indicated by @excalibur1234 at his official topic of KDE Minimal. The ISO was exactly 17.1. But I checked Install Manjaro Linux, it appeared as Manjaro 18.0.1.

Better migrating to KDE Full Stable or Beta 5 unitl @excalibur1234 and @philm fix these bugs.

ISO versions does not matter. After a pacman update you will be where the rolling distro number is (all users of the same branch)

We did need a #faq for that too, I guess

You my friend are getting a little carried away here on several fronts. Firstly these are not bugs. Its bad enough your going around claiming Manjaro is full of bugs when it's really your own inexperience that is the issue here.

Secondly, it is not reasonable to go pinging the developers of the distro about unsubstantiated claims on your part. Philm deals with upwards of 100 communications a day and he can't personally respond to every newbie who's having difficulty installing Manjaro.

If one of the mods or devs have the free time to respond to your issue consider yourself fortunate. Do not ping them if they have not already responded on your help request themselves. Could you possibly imagine how inundated with notifications they would be if everyone with an issue expected them to personally respond.

I wish you well with your issue but maybe you need to slow down a bit on your help requests. The devs of this distro are not at your personal beck and call. Let the developers be to work on what needs to be done without a cacophony of noise disrupting their efforts.

Forum kindly sponsored by