I am stuck in the rootfs console and the commands for /sbin/init do not work

Yes. A Mac mini 2011.

Yes. The grub always works normally, then I was swalloed into the rootfs console.

During the step Partitions:

  1. I selected "Generic Mass Storage Device" (an external HDD) for storage device;
  2. I chose Manual partitioning;
  3. I deleted all partitions of that selected device;
  4. I clicked in New Partition Table and chose GUID Partition Table (GPT);
  5. I created three partitions by order:
    • 1st partition: Size: 300MiB; File System: fat32; Mount Point: /boot/efi/; Flags: boot, esp;
    • 2nd partition: Size: 7360MiB; File System: linuxswap; Flags: swap;
    • 3rd partition: Size: 220≠MiB; File System: ext4; Mount: /; Flags: root.
  6. I selected "Generic Mass Storage Device" for boot loader.

Observe that I chose non-free drivers.

you dont need non-free drivers , only for Nvidia,
if you have only GPU intel or any Radeon card , Free do a best choice

This needs the a --removable parameter on grub-install command.
Also, how do you boot to this system? Do you select from a menu, or is it the default boot entry?
Boot to your Manjaro installer media and detect EFI bootloaders. If your external installation is found, use it to see if it works. If it works, run grub-install again with --removable parameter .

sudo grub-install --removable --recheck 

You might want to check again and post the relevant info

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

The 2010s Mac computers do not use NVIDIA and Raedon cards. They Intel cards.

I press option/alt (⌥) and the boot partitions list. See the screenshot:


The grey EFI belongs to Ubuntu EFI and the orange EFI belongs to Manjaro.

OK, I will reinstall.

Can I run sudo grub-install --removable --recheck /dev/sdc?

do not include the drive.
Run it from Manjaro installation

There is something wrong, strange and mysterious.

I did not find /boot/efi in the list of mount point during the Partitions step. I thought it was the ISO. I reinstalled the ISO, but it is still the same thing.

I remember what I did the last 10 reinstalling times. I decided to explore that bug. Chekcing Install Manjaro Linux, it appeared as Manjaro 18.0.1-alpha Illyria. After running the commands pacman-mirrors and pacman -Syyu. After finishing the upgrade, checking Install Manjaro Linux, it apperaed as Manjaro 17.1.8.

I remembered that on my external HD, my OS was Manjaro 18.0.1, and after running -Syyu, it appeared as Manjaro 17.1.18.

I believe it causes the bugs of boot and /sbin/init.

I think maybe @excalibur1234 and @philm must know these bugs.

Do you think I must migrate from KDE Minimal Illyria to KDE Minimal Holaika or KDE Full 17.1.18 or KDE Full 18.0.1 Beta 5? Which of them offers /boot/efi?

Observe that I have already installed normally both Manjaro KDE Minimal Holaika and Illyria and applied /boot instead of /boot/efi, but after rebooting, the orange Manjaro EFI orange does not exist anymore.

It becomes a nightmare. I repaired during a week!

I decied t download the ISO indicated by @excalibur1234 at his official topic of KDE Minimal. The ISO was exactly 17.1. But I checked Install Manjaro Linux, it appeared as Manjaro 18.0.1.

Better migrating to KDE Full Stable or Beta 5 unitl @excalibur1234 and @philm fix these bugs.

ISO versions does not matter. After a pacman update you will be where the rolling distro number is (all users of the same branch)

We did need a #faq for that too, I guess

You my friend are getting a little carried away here on several fronts. Firstly these are not bugs. Its bad enough your going around claiming Manjaro is full of bugs when it's really your own inexperience that is the issue here.

Secondly, it is not reasonable to go pinging the developers of the distro about unsubstantiated claims on your part. Philm deals with upwards of 100 communications a day and he can't personally respond to every newbie who's having difficulty installing Manjaro.

If one of the mods or devs have the free time to respond to your issue consider yourself fortunate. Do not ping them if they have not already responded on your help request themselves. Could you possibly imagine how inundated with notifications they would be if everyone with an issue expected them to personally respond.

I wish you well with your issue but maybe you need to slow down a bit on your help requests. The devs of this distro are not at your personal beck and call. Let the developers be to work on what needs to be done without a cacophony of noise disrupting their efforts.

Hello @AgentS,


I have read. OK!

Hello @tbg

OK, I will not ping them. Sorry for my behaviours because I am autistic and deaf-born.

1 Like

Hello @AgentS again!

Please, let me tell what happened now.

I installed the Manjaro 18.0 Beta 5 KDE Full. I found /boot/efi in the list of mount points during the Partitions step. I installed. Everything worked. The orange Manjaro EFI appeared.

Finally, I followed your step and ran all these commands:

$ sudo grub-install --removable --recheck 

[sudo] password for gusbemacbe: 
Installing for x86_64-efi platform.
Installation finished. No error reported.

$ efibootmgr -v
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0002,0080,0001,0000
Boot0000* ubuntu        HD(1,GPT,2b51e9de-db7c-473e-9238-db0d2691cb4c,0x28,0x64000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* deepin        HD(1,GPT,2b51e9de-db7c-473e-9238-db0d2691cb4c,0x28,0x64000)/File(\EFI\deepin\shimx64.efi)
Boot0002* Manjaro       HD(1,GPT,0e5c0064-9992-445e-84c5-f60b97e00315,0x22,0x967de)/File(\EFI\Manjaro\grubx64.efi)
Boot0080* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,822f779b-012e-4aa9-9596-75ebfedddec9,0x64028,0x3a1ec0c0)
Boot0081* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,822f779b-012e-4aa9-9596-75ebfedddec9,0x64028,0x3a1ec0c0)
Boot0082*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,0d3bd842-ba9a-442d-a33b-4f70567f7dcf,0x64028,0x3a1ec0c0)
BootFFFF*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,000072ce-62da-0000-532e-0000b35c0000,0x64028,0x3a1ec0c0)/File(\System\Library\CoreServices\boot.efi)

$ sudo parted -l
[sudo] password for gusbemacbe: 
Model: ATA Hitachi HTS54755 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      20.5kB  210MB  210MB  fat32        EFI System Partition  boot, esp
 2      210MB   499GB  499GB  hfs+
 3      499GB   500GB  650MB  hfs+

Model:  Mass Storage Device (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      17.4kB  316MB   316MB   fat32                 msftdata
 2      316MB   8316MB  8001MB  linux-swap(v1)
 3      8316MB  500GB   492GB   ext4

$ sudo blkid
/dev/sda1: LABEL="EFI" UUID="67E3-17ED" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="2b51e9de-db7c-473e-9238-db0d2691cb4c"
/dev/sda2: UUID="0ad0d00c-4782-3d2c-a629-5acbd1792bc1" LABEL="High Sierra" TYPE="hfsplus" PARTUUID="822f779b-012e-4aa9-9596-75ebfedddec9"
/dev/sda3: UUID="01cb061d-937b-3aba-943c-0ba15f417b93" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="4cf1744f-ccc4-4df8-b7c0-71560b6792a4"
/dev/sdb1: UUID="8235-0EA7" TYPE="vfat" PARTUUID="0e5c0064-9992-445e-84c5-f60b97e00315"
/dev/sdb2: UUID="8cc42c67-e60e-4375-90cf-f2d9e218961f" TYPE="swap" PARTUUID="7d0f8dc1-0bc1-46ab-b792-a5da9be1169c"
/dev/sdb3: UUID="e7cbb87d-6b31-47b9-bd07-62fa2088eba6" TYPE="ext4" PARTUUID="174b5d02-e028-4f5f-bf16-11d3896d00ea"

$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=8235-0EA7                            vfat   defaults,noatime
swap      UUID=8cc42c67-e60e-4375-90cf-f2d9e218961f swap   defaults,noatime
/         UUID=e7cbb87d-6b31-47b9-bd07-62fa2088eba6 ext4   defaults,noatime

$ findmnt /boot/efi
/boot/efi /dev/sdb1 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,

Alright and all OK?

I received the notification of Octopi that there are new updates. Should I update now?

Do not update via Octopi the last update was problematic and best done from the tty. That is the non graphical command prompt (terminal).

It seems your issue is solved. Have a nice time!

1 Like

Be sure to credit @AgentS with the solve.

OK, thank you, @tbg and @AgentS. Just the last two questions:

Can I install yay to install some application and install any applications (pacman -S any-app) I need for working? Or better I wait for the next updates?

Can I remove many unnecessary applications or do I have to wait?

Update first.

Update via terminal instead of Octopi? Or do I have to wait for the next update?

Syu or Syyu? For not breaking sbin.




Will get you to a tty.


sudo pacman -Syyu

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by