I am stuck in the rootfs console and the commands for /sbin/init do not work

Hello @AgentS,

OK!

I have read. OK!

Hello @tbg

OK, I will not ping them. Sorry for my behaviours because I am autistic and deaf-born.

1 Like

Hello @AgentS again!

Please, let me tell what happened now.

I installed the Manjaro 18.0 Beta 5 KDE Full. I found /boot/efi in the list of mount points during the Partitions step. I installed. Everything worked. The orange Manjaro EFI appeared.

Finally, I followed your step and ran all these commands:

$ sudo grub-install --removable --recheck 

[sudo] password for gusbemacbe: 
Installing for x86_64-efi platform.
Installation finished. No error reported.

$ efibootmgr -v
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0002,0080,0001,0000
Boot0000* ubuntu        HD(1,GPT,2b51e9de-db7c-473e-9238-db0d2691cb4c,0x28,0x64000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* deepin        HD(1,GPT,2b51e9de-db7c-473e-9238-db0d2691cb4c,0x28,0x64000)/File(\EFI\deepin\shimx64.efi)
Boot0002* Manjaro       HD(1,GPT,0e5c0064-9992-445e-84c5-f60b97e00315,0x22,0x967de)/File(\EFI\Manjaro\grubx64.efi)
Boot0080* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,822f779b-012e-4aa9-9596-75ebfedddec9,0x64028,0x3a1ec0c0)
Boot0081* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,822f779b-012e-4aa9-9596-75ebfedddec9,0x64028,0x3a1ec0c0)
Boot0082*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,0d3bd842-ba9a-442d-a33b-4f70567f7dcf,0x64028,0x3a1ec0c0)
BootFFFF*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,000072ce-62da-0000-532e-0000b35c0000,0x64028,0x3a1ec0c0)/File(\System\Library\CoreServices\boot.efi)

$ sudo parted -l
[sudo] password for gusbemacbe: 
Model: ATA Hitachi HTS54755 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      20.5kB  210MB  210MB  fat32        EFI System Partition  boot, esp
 2      210MB   499GB  499GB  hfs+
 3      499GB   500GB  650MB  hfs+


Model:  Mass Storage Device (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      17.4kB  316MB   316MB   fat32                 msftdata
 2      316MB   8316MB  8001MB  linux-swap(v1)
 3      8316MB  500GB   492GB   ext4

$ sudo blkid
/dev/sda1: LABEL="EFI" UUID="67E3-17ED" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="2b51e9de-db7c-473e-9238-db0d2691cb4c"
/dev/sda2: UUID="0ad0d00c-4782-3d2c-a629-5acbd1792bc1" LABEL="High Sierra" TYPE="hfsplus" PARTUUID="822f779b-012e-4aa9-9596-75ebfedddec9"
/dev/sda3: UUID="01cb061d-937b-3aba-943c-0ba15f417b93" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="4cf1744f-ccc4-4df8-b7c0-71560b6792a4"
/dev/sdb1: UUID="8235-0EA7" TYPE="vfat" PARTUUID="0e5c0064-9992-445e-84c5-f60b97e00315"
/dev/sdb2: UUID="8cc42c67-e60e-4375-90cf-f2d9e218961f" TYPE="swap" PARTUUID="7d0f8dc1-0bc1-46ab-b792-a5da9be1169c"
/dev/sdb3: UUID="e7cbb87d-6b31-47b9-bd07-62fa2088eba6" TYPE="ext4" PARTUUID="174b5d02-e028-4f5f-bf16-11d3896d00ea"

$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=8235-0EA7                            vfat   defaults,noatime
swap      UUID=8cc42c67-e60e-4375-90cf-f2d9e218961f swap   defaults,noatime
/         UUID=e7cbb87d-6b31-47b9-bd07-62fa2088eba6 ext4   defaults,noatime

$ findmnt /boot/efi
TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sdb1 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,

Alright and all OK?

I received the notification of Octopi that there are new updates. Should I update now?

Do not update via Octopi the last update was problematic and best done from the tty. That is the non graphical command prompt (terminal).

It seems your issue is solved. Have a nice time!

1 Like

Be sure to credit @AgentS with the solve.

OK, thank you, @tbg and @AgentS. Just the last two questions:

Can I install yay to install some application and install any applications (pacman -S any-app) I need for working? Or better I wait for the next updates?

Can I remove many unnecessary applications or do I have to wait?

Update first.

Update via terminal instead of Octopi? Or do I have to wait for the next update?

Syu or Syyu? For not breaking sbin.

CTL +ALT + F2

or

CTL +ALT + F3

Will get you to a tty.

Then:

sudo pacman -Syyu

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by