I broke the keyring and now can't find a solution. Is it recoverable?

Hello people! I am running Manjaro 18.0.0 w/ Kernel 4.19.6 on a new-ish Intel notebook.

First of all, I know I kinda f'ed up. Trying to recover the system currently.

I was doing a update for the first time in a few months and for some reason the pc rebooted during the update. It booted without any running service so I just rebooted it again (this one took some time) and tried to update.

After rebooting got a PGP error for every package. I was following the forum carelessly and found a series of commands link

The problem is that I removed the gnupg, but I was still unable to use pacman-Sy, so now I could not reinstall it.

I tried compiling gnupg from source, but I needed libreadline.so.7, while I have libreadline.so.8 at the system. I tried creating a link with ln, the install progressed but failed at another point (dirmngr).

After making the link the error with pacman -Sy changed too. Now for anything I try to install through Pacman the process fails to download required keys ("key ABC123 could not be looked up remotely")

sudo pacman-key --init does not have an output.
sudo pacman-key --refresh-keys fails: "gpg: connecting dirmngr at '/etc/pacman.d/gnupg/S.dirmngr' failed: IPC connect call failed

I am currently at a loss, I'd love to be able to restore this system to a functional state. Any help is welcome.

I do have a bootable usb for manjaro 18.0.0 in hand, if that could help.

Check this FAQ thread, it has a load of options:

You'll probably need to use th "nuclear option" which is essentially the same as the steps you used, but skip pacman until after you've fixed the keyring setup.


Ah all the commands seems to work up to the --refresh-key, then it fails all the same.

gpg: connection dirmngr at '/etc/pacman.d/gnupg/S.dirmngr' failed: IPC connect call failed
gpg: keyserver refresh failed: No dirmngr
==> ERROR: A specificed local key could not be updated from a keyserver.

Any other ways I can try to tackle this issue? It seems the problem is directly with Dirmngr so I am searching for posts about it atm.

Edit: I managed to install dirmngr after a couple of reboots and it seems It is working now :o thank you very much!!!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by