I cannot boot after the recent update, what should i do after chroot?

Something wrong happened after the update.
I did not read "update recommendation" before updating my system, so now I can't boot.
I am using the usb installation media for manjaro at the moment. And I know how to chroot. But what is the next step?

Next step would be to gather information what went wrong.

  • /var/log/pacman.log
  • find /usr/lib -size 0 > broken_files.txt

Maybe a kernel update went bad, then reinstall the kernel with --force option. Or mkinitcpio didn't finish. Or, or ...

Sounds like just get yourself a 'sudo pacman -Syyu --force' and/or try different kernel.
..hopefully;-)

Edit - yeah, as per eugen, might as well run 'sudo update-grub' aswell

eugen: I have a lot of broken files apparently.

So I should simply run pacman -Syyu --force and sudo update-grub?
I get: ''/usr/bin/grub-probe: error while loading shared libraries: /usr/lib/libudev.so.1: file too short'' when trying to update grub

I saw recently that pacman -Syyu --force doesn't change anything. The packages are updated but the files are broken.
This list of "broken" files you can try to analyse to see which packages you might update.

A more brute force approach would be this:

Means get all istalled packages and reinstall everything.

1 Like

Thank you very much for the reply, however when trying to run
pacman -Qqen > pkglist.txt
I get an error saying /var/lib/pacman/local/systemd-231-4/desc: File does not exist

edit: I dont know if its worth noting, but all broken files are from /usr/lib

Maybe reinstall the systemd stuff first, because the side effects of its upgrade caused the whole chaos.
sudo pacman -S --force systemd libsystemd systemd-sysvcompat

Haha, don't want to sound smartass, but you got them with the command find /usr/lib

oh yeah lmao i'm just stressed over this xD

Anyway, I still get that error when trying to reinstall. But I also get:
warning: could not download metadata for systemd-231-4

I really appreciate your help so far!

What error exactly?
You could also try getting su and then run pacman.

When trying to run the command:
sudo pacman -S --force systemd libsystemd systemd-sysvcompat
I get these output:
Could not open file /var/lib/pacman/local/systemd-231-4/desc: File does not exist
Warning: could not fully load metadata for package systemd-231-4
Error: failed to prepare transaction (invalid or corrupted package)

Edit: should i try:
rm -r /var/lib/pacman/local/systemd-231-4
sudo pacman -S --force systemd libsystemd systemd-sysvcompat

That's a standard error which has a standard troubleshoot in the Arch Wiki.
But it indicates that you are in the right direction with reinstalling these three.
However, I need to go to bed now.

Man I love you, it worked!
And I love @Bigsquirrel too for that solution!
Thanks guys!!

1 Like

:clap:

And you too for replying earlier! Also appreciate it very much!

1 Like

Forum kindly sponsored by