I can't see PCI-E Wireless card FENVI FV-HB1200

I can't see PCI-E Wireless card FENVI FV-HB1200 on Manjaro Cinnamon, but this card works on Hackintosh Mojave very well.
01
Maybe I need to install some drivers.

Please post:

inxi -Fxxxz
System:
  Host: office Kernel: 4.14.134-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 Desktop: Cinnamon 4.2.2 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: VIGLEN product: DQ77MK v: N/A serial: <filter> 
  Chassis: Viglen type: 3 v: Medium Tower serial: <filter> 
  Mobo: Intel model: DQ77MK v: AAG39642-500 serial: <filter> BIOS: Intel 
  v: MKQ7710H.86A.0060.2013.0618.1012 date: 06/18/2013 
CPU:
  Topology: Quad Core model: Intel Core i5-3570 bits: 64 type: MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27149 
  Speed: 1634 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1596 2: 1653 
  3: 1596 4: 1600 
Graphics:
  Device-1: NVIDIA GK107 [GeForce GTX 650] vendor: Gigabyte driver: nvidia 
  v: 430.26 bus ID: 01:00.0 chip ID: 10de:0fc6 
  Display: x11 server: X.Org 1.20.5 driver: nvidia tty: N/A 
  OpenGL: renderer: GeForce GTX 650/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Device-2: NVIDIA GK107 HDMI Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0e1b 
  Sound Server: ALSA v: k4.14.134-1-MANJARO 
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: eno1 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  Adapter 
  vendor: Apple driver: bcma-pci-bridge v: N/A port: e000 bus ID: 02:00.0 
  chip ID: 14e4:43a0 
  Device-3: Intel 82574L Gigabit Network driver: e1000e v: 3.2.6-k 
  port: d000 bus ID: 03:00.0 chip ID: 8086:10d3 
  IF: eth1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 2.73 TiB used: 851.02 GiB (30.5%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC43 scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZRZ-00HTKB0 
  size: 931.51 GiB speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A01 scheme: GPT 
  ID-3: /dev/sdc type: USB vendor: Samsung model: M3 Portable 
  size: 931.51 GiB serial: <filter> rev: 1301 scheme: MBR 
Partition:
  ID-1: / size: 491.15 GiB used: 70.36 GiB (14.3%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 63% 
Info:
  Processes: 191 Uptime: 46m Memory: 15.62 GiB used: 6.08 GiB (38.9%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 
  running in: gnome-terminal inxi: 3.0.35

Oh great broadcom again, surprise, surprise.

Install some of the newer kernels. You may need to install 5.2 to get full support for the wl driver.

Follow my guide here:

I forgot to say that I used only this part from your guide:

Installing the required Linux kernel headers:

To automatically install all required Linux headers packages for all installed kernels, use the following command:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

*command courtesy of @dalto

Once you have completed the linux-headers package installation, install the "dkms" package with the following command:

sudo pacman -S dkms 

After all those steps are complete unplug any tethering, LAN, or other internet connections and reboot.

After rebooting, your WiFi may be working with the native modules already included in the kernel. If you find the kernel driver works satisfactorily you may simply want to continue using it.

If your WiFi is not working (or the kernel driver performs poorly), then continue with the directions to install the proprietary broadcom-wl-dkms driver.

Perform some tests on your WiFi, and if it is not performing adequately proceed with installing the broadcom-wl-dkms driver. Reconnect to an alternate internet source to perform the driver installation.

Install the "broadcom-wl-dkms" driver package from the Manjaro extra repo with this command:

sudo pacman -S broadcom-wl-dkms

After the driver has finished installing, again unplug any tethering, LAN, or other internet connections and reboot.

and the card works very well now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by